Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Access and Trunks Ports on ASR9K

Hi,

I need to adapt a Cisco Catalyst switch configuration into a new ASR9000 router and I do not know how to configure trunks and access ports on an ASR9K router.

This is the configuration of the catalyst switch I want to replace.

interface GigabitEthernet1/0/1

description Access-Port -> SERVER

switchport access vlan 5

spanning-tree portfast

!

interface GigabitEthernet1/0/2

description Trunk-Port -> DISTRIBUTION SWITCH

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 5,6,7

switchport mode trunk

I think it should be someting like this:

interface GigabitEthernet0/0/0/0

description Access-Port

interface GigabitEthernet0/0/0/0.5 l2transport

interface GigabitEthernet0/0/0/1

description Trunk-Port

interface GigabitEthernet0/0/0/1.5 l2transport

encapsulation dot1q 5

interface GigabitEthernet0/0/0/1.6 l2transport

encapsulation dot1q 6

interface GigabitEthernet0/0/0/1.7 l2transport

encapsulation dot1q 7

Am I right? Or do I need to use the command “rewrite ingress tag pop 1 symmetric”

on any of the interfaces o subinterfaces? Do I have to configure the command “encapsulation dot1q untagged“ on the GigabitEthernet0/0/0/0.5 subinterface?

Please, help!!

Thank you in advance.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: Access and Trunks Ports on ASR9K

Hello,

You’d need to create separate l2vpn bridge domains per different customers and use tag rewrite on trunk subif.

! Trunk port

!

interface GigabitEthernet0/0/0/1.5 l2transport

  encapsulation dot1q 5

  rewrite ingress tag pop 1 symmetric

!

interface GigabitEthernet0/0/0/1.6 l2transport

  encapsulation dot1q 6

  rewrite ingress tag pop 1 symmetric

!

interface GigabitEthernet0/0/0/1.7 l2transport

  encapsulation dot1q 7

  rewrite ingress tag pop 1 symmetric

!

! Access ports

!

interface GigabitEthernet0/0/0/0

  description Access-Port vlan 5

  l2transport

!

!

interface GigabitEthernet0/0/0/2

  description Access-Port vlan 6

  l2transport

!

!

interface GigabitEthernet0/0/0/3

  description Access-Port vlan 7

  l2transport

!

l2vpn

!

bridge group VLANs

  bridge-domain vlan5

   interface GigabitEthernet0/0/0/1.5

   interface GigabitEthernet0/0/0/0

!

  bridge-domain vlan6

   interface GigabitEthernet0/0/0/1.6

   interface GigabitEthernet0/0/0/2

!

  bridge-domain vlan7

   interface GigabitEthernet0/0/0/1.7

   interface GigabitEthernet0/0/0/3

!  

Regards,

/A

Cisco Employee

Access and Trunks Ports on ASR9K

If you configure a subinterface, you’d need to define an encapsulation.

As I understood that is access port with untagged frames, hence we don’t need subinterfaces and we should use a main interface as l2transport.

Regards,

/A

5 REPLIES
Cisco Employee

Re: Access and Trunks Ports on ASR9K

Hello,

You’d need to create separate l2vpn bridge domains per different customers and use tag rewrite on trunk subif.

! Trunk port

!

interface GigabitEthernet0/0/0/1.5 l2transport

  encapsulation dot1q 5

  rewrite ingress tag pop 1 symmetric

!

interface GigabitEthernet0/0/0/1.6 l2transport

  encapsulation dot1q 6

  rewrite ingress tag pop 1 symmetric

!

interface GigabitEthernet0/0/0/1.7 l2transport

  encapsulation dot1q 7

  rewrite ingress tag pop 1 symmetric

!

! Access ports

!

interface GigabitEthernet0/0/0/0

  description Access-Port vlan 5

  l2transport

!

!

interface GigabitEthernet0/0/0/2

  description Access-Port vlan 6

  l2transport

!

!

interface GigabitEthernet0/0/0/3

  description Access-Port vlan 7

  l2transport

!

l2vpn

!

bridge group VLANs

  bridge-domain vlan5

   interface GigabitEthernet0/0/0/1.5

   interface GigabitEthernet0/0/0/0

!

  bridge-domain vlan6

   interface GigabitEthernet0/0/0/1.6

   interface GigabitEthernet0/0/0/2

!

  bridge-domain vlan7

   interface GigabitEthernet0/0/0/1.7

   interface GigabitEthernet0/0/0/3

!  

Regards,

/A

Community Member

Re: Access and Trunks Ports on ASR9K

Thanks for your reply,

If I configure:

interface GigabitEthernet0/0/0/0

description Access-Port

interface GigabitEthernet0/0/0/0.5 l2transport

do you think it would work?

Thanks in advance

Cisco Employee

Access and Trunks Ports on ASR9K

If you configure a subinterface, you’d need to define an encapsulation.

As I understood that is access port with untagged frames, hence we don’t need subinterfaces and we should use a main interface as l2transport.

Regards,

/A

Community Member

Access and Trunks Ports on ASR9K

Hi,

I tryed the configration but I saw not runing. Configurations are below.

!

interface TenGigE0/1/0/0.611 l2transport

encapsulation dot1q 611

rewrite ingress tag pop 1 symmetric

!

interface TenGigE0/1/0/0.612 l2transport

encapsulation dot1q 612

rewrite ingress tag pop 1 symmetric

!

l2vpn

bridge group kzy2kyl

  bridge-domain kzykd2kylmlt

   interface TenGigE0/1/0/0.611

   !

   interface TenGigE0/1/0/0.612

   !

  !

!

!

Community Member

Access and Trunks Ports on ASR9K

Thank you for your help. I appreciate it very much.

Best regards

2816
Views
10
Helpful
5
Replies
CreatePlease to create content