Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

access server

I have a 2511 router as an acces server.  When I connect to any host it says connection refused or I get half of the 2511 banner and then freezes.  If I turn the switch or router off then back on it I can see it fine but eventually they disconnect and again connection refused or half the banner.

any suggestions?

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

access server

What command are you using to telnet?  Cables checked?

13 REPLIES
New Member

access server

Can you post your terminal server's config?  I had a similar issue to this.  I had to hard code each console line with "speed 9600", to manually set a default baud rate.  Have you checked layer 1 connections?  What command are you using to reverse telnet?  Are you using a loopback address or active interface for reverse telnet?  I will post a config that I use for my terminal server in a sec.

New Member

access server

Be sure to clear your lines frequently.  I had to do this all let, but only when I was testing it for the first time.  Use "show line".  Clear any lines with a "*" on it. Here is a sample config:

ip host R1 2001 200.200.200.1

ip host R2 2002 200.200.200.1

ip host R3 2003 200.200.200.1

ip host L3S1 2004 200.200.200.1

ip host L3S2 2005 200.200.200.1

ip host S1 2006 200.200.200.1

ip host S2 2007 200.200.200.1

ip host S3 2008 200.200.200.1

!

interface Loopback0

ip address 200.200.200.1 255.255.255.0

!

line con 0

exec-timeout 0 0

logging synchronous

line 1 8

no exec

transport input telnet

telnet speed 9600 9600

autohangup

stopbits 1

alias exec R1 telnet R1 2001

alias exec R2 telnet R2 2002

alias exec R3 telnet R3 2003

alias exec L3S1 telnet L3S1 2004

alias exec L3S2 telnet L3S2 2005

alias exec S1 telnet S1 2006

alias exec S2 telnet S2 2007

alias exec S3 telnet S3 2008

New Member

access server

This is the running config of my server.

[code]

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname aserver

!

logging queue-limit 100

enable secret 5 $1$wNEB$ukZ5UkS8pup6ajVFk7JLQ/

!

username admin secret 5 $1$AGHA$Mut7gz/WYbirHC9g1g7Ii/

ip subnet-zero

no ip domain lookup

ip host h1 2001 10.10.10.10

ip host h2 2002 10.10.10.10

ip host h3 2003 10.10.10.10

ip host h4 2004 10.10.10.10

ip host h5 2005 10.10.10.10

ip host h6 2006 10.10.10.10

ip host h7 2007 10.10.10.10

ip host h8 2008 10.10.10.10

!

!

!

!

interface Loopback0

ip address 10.10.10.10 255.255.255.255

!

interface Ethernet0

ip address 10.105.21.250 255.255.255.0

!

interface Serial0

no ip address

shutdown

no fair-queue

!

interface Serial1

no ip address

shutdown

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.105.21.254

!       

!

!

!

banner motd ^C

##################################################

ALL TRAFFIC IS BEING MONITORED.

###################################################

^C

!

line con 0

exec-timeout 0 0

logging synchronous

line 1 16

exec-timeout 0 0

flush-at-activation

no exec

transport input telnet

line aux 0

line vty 0 4

exec-timeout 0 0

logging synchronous

no login

!

end

[/code]

New Member

access server

What command are you using to telnet?  Cables checked?

New Member

access server

hX where x is 1-8

i have checked all the cables.  it works only if I turn off the router or switch and back on.  This while I am connected to it when i do ctrl shift 6 X then go to another device and back to the original one it says cannot connect.

New Member

access server

Have you tried clearing the lines after you exit a telnet?

New Member

access server

nope not sure how to do that.  But also do i need to do this all the time because it is constantly happening.

access server

How are you "going back to the original" one?  Are you selecting the session as would be found under "show sessions"?  If you're trying to re-initiate the connection, your previous connection is still "holding" the line, unless you actually "exit" from the session while you're in that device.  Ctrl-Shft-6 X only drops you back to the terminal server; it does not end the session.

You can also clear the line ("clear line x") and try again.  You may need to clear the line a couple of times.

Good luck!

Ed

New Member

Re: access server

the problem is if i do show sessions no session are avail. then i do hX and it says connection refused. I would understand the current session, but what about the other routers that dont have any sessions why can i not connect to them?

New Member

access server

Try setting the baud rate on all of the devices your trying to reverse telnet to.  If there are set for, say 57600, that will not allow you to reverse telnet.

New Member

Re: access server

how do I do this?

New Member

Re: access server

Go into each end device, and enter "speed 9600" their console lines.

New Member

Re: access server

OK ill try that

thx

491
Views
0
Helpful
13
Replies
CreatePlease login to create content