Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Access to ISP internet from LAN using a 2600 router

I have a 2600 router which is link to my ISP ADSL which I get a DHCP IP from them, I have config the interface to take the DHCP from the ADSL, I have config NAT overload on the outside interface, however I am unable to access the internet from the LAN, when I try to ping the ISP DNS server from the router it works but when I try to ping ISP DNS from the LAN if fail. Can anyone tell me what step I am not doing to get access to the internet?

I am able to ping the IP address I got from the ADSL from the LAN.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Access to ISP internet from LAN using a 2600 router

Hi,

I noticed a number of things in your config.

1) in the DHCP config, you need to exclude your router IP address for the pool that your router will be leasing out to its clients.

from the global config, please put the following command to exclude the first two ip address from the dhcp pool.

ip dhcp excluded-address 192.168.10.1 192.168.10.2

2) I also noticed that you are using the router as a dhcp client to your ISP. but you still have a static default route. please remove the default route and the static route also pointing to the outside interface.

1.e remove

ip route 0.0.0.0 0.0.0.0 72.252.152.1

ip route 192.168.2.0 255.255.255.0 FastEthernet0/0

regards.

7 REPLIES

Re: Access to ISP internet from LAN using a 2600 router

Shane,

It doesn't sound like NAT is configured properly on your router. Please see the following example. If this does not help please post your config.

You need the nat configuration

int fa0/0

ip nat inside

int fa0/1

ip nat outside

ip nat inside source list 1 interface fa0/1 overload

access-list 1 permit x.x.x.x 0.0.0.255

replace x.x.x.x with your private IP addresses.

HTH,

Mark

New Member

Re: Access to ISP internet from LAN using a 2600 router

When I am setting the default route should it be

0.0.0.0 0.0.0.0 x.x.x.x 1

x should be my ISP gateway?

I have set the nat just like u say, but looking at it should I get it to my ISP gateway?

Re: Access to ISP internet from LAN using a 2600 router

Do you have a modem or a router connected to your ISP?

New Member

Re: Access to ISP internet from LAN using a 2600 router

I have a router connected to my ISP

Hall of Fame Super Blue

Re: Access to ISP internet from LAN using a 2600 router

Shane

As Mark has suggested it would help if you could post your router config.

Jon

New Member

Re: Access to ISP internet from LAN using a 2600 router

Current configuration : 1027 bytes

!

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

ip subnet-zero

ip dhcp pool TEST

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

dns-server 65.183.0.76

lease 8

call rsvp-sync

interface FastEthernet0/0

ip address dhcp

ip nat outside

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface BRI0/0

no ip address

encapsulation hdlc

shutdown

interface FastEthernet0/1

ip address 192.168.10.1 255.255.255.0

ip nat inside

duplex auto

speed auto

interface Serial0/1

no ip address

shutdown

ip nat inside source list internet interface FastEthernet0/0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 72.252.152.1

ip route 192.168.2.0 255.255.255.0 FastEthernet0/0

ip http server

ip access-list standard internet

permit 192.168.0.0 0.0.255.255

!

dial-peer cor custom

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

!

end

New Member

Re: Access to ISP internet from LAN using a 2600 router

Hi,

I noticed a number of things in your config.

1) in the DHCP config, you need to exclude your router IP address for the pool that your router will be leasing out to its clients.

from the global config, please put the following command to exclude the first two ip address from the dhcp pool.

ip dhcp excluded-address 192.168.10.1 192.168.10.2

2) I also noticed that you are using the router as a dhcp client to your ISP. but you still have a static default route. please remove the default route and the static route also pointing to the outside interface.

1.e remove

ip route 0.0.0.0 0.0.0.0 72.252.152.1

ip route 192.168.2.0 255.255.255.0 FastEthernet0/0

regards.

151
Views
0
Helpful
7
Replies