Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Active/Active HSRP configuration

All,

I'm trying to confirm a proof-of-concept. Within the next couple months we're migrating our WAN to an MPLS solution and relocating our data center.

My question focuses on the feasibility of running an active/active HSRP configuration on a pair of Cisco 3750s. I seem to remember reading this can be done somewhere, but now I can't find it. I believe it's just a matter of creating two HSRP groups on each interface. I've seen some configuration for this on PIX firewalls, but not standard IOS routers.

One noteworthy point- the original proposal was to run two T1s with IMA on each router, but now the customer is contemplating the need for a third T1 on one of the routers. Can we do this without running into issues with assymetrical bandwidth or will this function as a true round-robin configuration?

Thanks for any input.

Mike

7 REPLIES
New Member

Re: Active/Active HSRP configuration

Mike, Your HSRP idea is very feasible. This can be done. The answer to your question regarding IMA will have to come from another source.

New Member

Re: Active/Active HSRP configuration

Does anyone have any sample configs to illustrate what I'm wanting to do?

This article shows HSRP, but it's not really what I'm wanting.

(http://www.cisco.com/univercd/cc/td/doc/cisintwk/ics/cs009.htm#wp3389)

This would only work if half my clients pointed at one router, the other half at one of the other routers. Within a DHCP-environment, you can't do that unless you get really tricky with VLANs and this is more admin-intensive than I'd like to get.

Super Bronze

Re: Active/Active HSRP configuration

Hi

Maybe you're thinking of GLBP?

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_white_paper09186a00801541c8.shtml

I don't think it's supported on 3750s though.

What is it you're trying to achieve?

A single 3750 will route pretty fast, and if you have a layer 2 network with STP running half your links are likely shut down - so an optimal option would be to make one 3750 the STP root and HSRP active router.

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: Active/Active HSRP configuration

OK, I'll give more detail on the setup:

We're migrating an existing 85-site frame relay network to MPLS. At the same time, we're relocating our DC. The DC site currently has a single 3640, but we're installing a pair of 3750s with 2 circuits running IMA into each router.

We want to be able to utilize all 6 Mb available to us. AT&T is proposing an active-active environment, but I haven't seen this done before.

This morning a manager threw out the notion to add a third T1 to one router, but my colleague and I question whether this will cause some asymmetrical routing issues.

That's pretty much it in a nutshell...

New Member

Re: Active/Active HSRP configuration

Aaron, I looked over that GLBP article that you referenced and it sounds like it might be closer to what I'm looking for.

I see that round-robin is the load-balancing default, but based on what I read, it doesn't appear to be true round-robin. Meaning, packets are truly load-balanced across the two routers so that they are both essentially running in active mode.

Am I just not understanding that correctly?

New Member

Re: Active/Active HSRP configuration

we are also planning a migration from frame to MPLS. I will have about 39 sites connected. I am trying to get a handle on the ability for our 3640 to handle it.

I currently have 6MB of host circuit capacity that is frequently close to peak. So, i expect i'll be regularly using more than 6M. Moreover, we want to increase the port speed on some links.

I will have a 12MB DS3 coming into an nm-1hssi.

i will max the mem on the 3640. Do you think it can handle it?

New Member

Re: Active/Active HSRP configuration

U will put config some thing like this...

interface FastEthernet0/0

ip address 10.10.33.33 255.255.255.224

no ip redirects

no ip proxy-arp

no ip mroute-cache

speed auto

duplex auto

standby use-bia

standby 1 timers 3 10

standby 1 priority 110 preempt delay 120

standby 1 authentication HSRP_G1

standby 1 ip 10.10.33.34

standby 1 track Serial0/0 10

standby 2 timers 3 10

standby 2 priority 105 preempt

standby 2 authentication HSRP_G2

standby 2 ip 10.10.33.36

standby 2 track Serial0/0 5

interface FastEthernet0/0

ip address 10.10.33.35 255.255.255.224

no ip redirects

no ip proxy-arp

no ip mroute-cache

speed auto

duplex auto

standby use-bia

standby 1 timers 3 10

standby 1 priority 105 preempt

standby 1 authentication HSRP_G1

standby 1 ip 10.10.33.34

standby 1 track Serial0/0 5

standby 2 timers 3 10

standby 2 priority 110 preempt delay 120

standby 2 authentication HSRP_G2

standby 2 ip 10.10.33.36

standby 2 track Serial0/0 10

If u have more then one WAN int on the router u will have to change the track command and the weight drop parameters attached ot it.

With MPLS u will have to come with the plan , which is going to be your primary site and and anouce the default from that site for the rest of the spoke site...U can also - design- fail-over...

8834
Views
0
Helpful
7
Replies