Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Adaptive Bandwidth allocation.

Dear Experts,

I need your help to identify the problem in this configuration .

This is the example scenario.

Total Bandwidth Available 512Kbps.

Cust A - CIR 256Kbps PIR also 256Kbps

Cust B - CIR 256Kbps PIR 512Kbps

Config -

policy-map test1

class Test1 ! Cust B

shape average 512000

bandwidth 256

class test2 ! Cust A

bandwidth 256

shape average 256000

After applying this i've montiored around 64Kbps getting for Cust A when the Cust B using whole bandwidth (512Kbps).

How i can sort out this problem ? ( IOS - spservices,1841 Router )

12 REPLIES
Super Bronze

Re: Adaptive Bandwidth allocation.

The Cust A configuration shouldn't limit itself to 64 Kbps. What's the physical toplogy?

PS:

BTW, for Cust B, if you really want

Cust B - CIR 256Kbps PIR 512Kbps

you might want a variation of

policy-map test1

class Test1 ! Cust B

shape peak 256000

New Member

Re: Adaptive Bandwidth allocation.

thanks for the response,

FA0/0 -> Router -> Fa0/1

Fa0/0 i've police rate for 512 Kbps, and applied fa0/1 particular policy shaping. if i use shape peak 256 also the same problem comes in the practical scenario. the router that given 256 peak utilize the around 47KBps. and other one get around only 16KBps. I'm really confused with what documents says.(http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfcbshp.html)

Super Bronze

Re: Adaptive Bandwidth allocation.

If you're both inbound policing in fa0/0 and outbound shaping on fa0/1, poor performance might be due to the policer. What's the policer's config?

Why are you both policing and shaping? Normally, you use one or the other, not both serially.

New Member

Re: Adaptive Bandwidth allocation.

Hi ,

Actual requirement is more complex than what I've explained. Its like ISP provides only 512Kbps that's the reason I've put the police rate on fa0/0. This is to simulate the same scenario. Is there anyway i can prioritize that particular 256Kbps ?

Super Bronze

Re: Adaptive Bandwidth allocation.

"Is there anyway i can prioritize that particular 256Kbps"

Yes, either using a shaper alone or a hierarchal policy map.

e.g. (hierarchal policy map)

class-map match-(any or all) 256Kb

match . . .

policy-map shape_out_to_512Kb

class class-default

shape average 512000

service-policy prioritize_256Kb

policy-map prioritize_256Kb

class 256Kb

bandwidth 256000

interface fa0/1

service-policy output shape_out_to_512Kb

New Member

Re: Adaptive Bandwidth allocation.

thanks for the reply & for ur time, I'll check this on tomorrow with real setup & let you know the results.

New Member

Re: Adaptive Bandwidth allocation.

Hi ,

Here i've attached the configuration. I could only add police-rate& bandwidth . I tried to add shape average then I got "GTS : Can be enabled only at the first level" error. But it gave the prioritization even though it is not 256Kbps. when i doing the download from one ftp site i noticed I'm getting around 160Kbps only. any help ?

Thanks in Advance .

New Member

Re: Adaptive Bandwidth allocation.

for more here I've attached what I'm trying to achieve.

Super Bronze

Re: Adaptive Bandwidth allocation.

Ah, well then . . .

policy-map shape_out_to_512Kb

class class-default

shape average 512000

service-policy customers

policy-map customers

class custB

bandwidth 256000

class class-default

no fair-queue

interface fa0/1

service-policy output shape_out_to_512Kb

Notes:

You'll need a class-map for custB. Since you're doing NAT, that becomes a bit more complex. One method might be to mark packets before NAT and match on the markings.

The above will guarantee 256 Kbps for custB, but will allow either custA or custB to use more bandwidth if available.

The above should work well for outbound.

New Member

Re: Adaptive Bandwidth allocation.

Hi josephdoherty ,

thanks for the support on this. Actual implementation doesn't having natting :). only contain around 8 customers with 6Mbps connection from ISP.

I've done some testing with police rate and different burst rate. That produced what i expected. real testing will be in this week.:)) i'll let you know the results . Thanks again for the support.

Super Bronze

Re: Adaptive Bandwidth allocation.

"Actual implementation doesn't having natting "

That makes things easier, but then why does your posted running-config.txt show . . .

interface FastEthernet0/0

ip address x.y.z.4 255.255.255.240

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

ip nat inside

duplex auto

speed auto

service-policy output shape_512

New Member

Re: Adaptive Bandwidth allocation.

this is actually test setup. Otherwise need to answer the customers :). As i mentioned real setup has 5.5Mbps connection divided to 8 customers one main customer can utilize all 5.5 Mbps when the others are not using. Earlier queuing configuration gave some problem that's why i started to test everything. I applied the real queuing like this.

policy-map shape-cbq

class CustA

bandwidth 64

police rate 64000 bps burst 32000 bytes

class CustB

bandwidth 160

police rate 160000 bps burst 64000 bytes

class CustC

bandwidth 350

police rate 350000 bps burst 128000 bytes

class CustD

bandwidth 2048

police rate 2048000 bps burst 512000 bytes

class CustE

bandwidth 256

police rate 256000 bps burst 128000 bytes

class CustF_Night

bandwidth 128

police rate 128000 bps burst 32000 bytes

class CustG

bandwidth 512

police rate 512000 bps burst 128000 bytes

class CustH

bandwidth 64

police rate 64000 bps burst 32000 bytes

class CustI_Temp

bandwidth 128

police rate 128000 bps burst 32000 bytes

class CustJ

bandwidth 64

police rate 64000 bps burst 32000 bytes

policy-map shaper_5_5M

class class-default

shape average 5632000

service-policy shape-cbq

Again thanks. :)

278
Views
9
Helpful
12
Replies