Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ADSL 837 - DNS resolution problem (See config)

This is my 837 router, it gets onto the Internet but many Internet pages don't resolve, if I go to google and type them then I can get to them. What have I done wrong?

Current configuration : 1972 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname

!

boot-start-marker

boot-end-marker

!

no logging buffered

!

no aaa new-model

!

resource policy

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.0.0.1 10.0.0.10

--More-- !

ip dhcp pool client

network 10.0.0.0 255.255.255.0

default-router 10.0.0.2

dns-server 195.216.16.129

lease 0 2

!

!

no ip cef

!

!

!

username password

!

!

!

!

!

interface Ethernet0

ip address 10.0.0.2 255.255.255.0

ip nat inside

ip virtual-reassembly

hold-queue 100 out

--More-- !

interface Ethernet2

no ip address

shutdown

hold-queue 100 out

!

interface ATM0

no ip address

no ip mroute-cache

atm vc-per-vp 64

no atm ilmi-keepalive

dsl operating-mode auto

cdp enable

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet1

duplex auto

speed auto

!

interface FastEthernet2

--More-- duplex auto

speed auto

!

interface FastEthernet3

duplex auto

speed auto

!

interface FastEthernet4

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname A3305@pipex.com

ppp chap password 0 st578

ppp pap sent-username A3305@pipex.com password 0 st578

!

--More-- ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

no ip http secure-server

!

ip nat inside source list 102 interface Dialer1 overload

!

logging trap debugging

logging facility local4

logging source-interface Ethernet0

access-list 102 permit ip 10.0.0.0 0.0.0.255 any

dialer-list 1 protocol ip permit

!

control-plane

!

!

line con 0

no modem enable

transport output telnet

line aux 0

transport output telnet

line vty 0 4

login local

transport input telnet ssh

--More-- transport output all

!

scheduler max-task-time 5000

end

ADSL#

2 REPLIES
Cisco Employee

Re: ADSL 837 - DNS resolution problem (See config)

Usually this is a proble with MTU size. PPPoE cannot support an MTU larger than 1492.Try adding this to your Ethernet0 config:

ip adjust−mss 1452

CJ

Cisco Systems

New Member

Re: ADSL 837 - DNS resolution problem (See config)

I fixed it by deleting dns-server 195.216.16.129 and adding import all and ppp ipcp dns request ppp ipcp wins request.

118
Views
0
Helpful
2
Replies