Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

adsl chap failure - 887va

Hi all,

hoping someone can shed some light on this,

 

i have an 887va configured to connect to my isp on my test bed. I have configured the router to connect using PPPoA as usual but i am getting LCP TERMREQ packets from my ISP in response to my CHAP responses. no other errors, just a termreq.

Strange thing is , from time to time it does connect but can take hours. I know the username and password are correct as they work straight away when i use a little netgear adsl modem i have here so clearly something else is wrong, i suspect the ISP end but thought i would check here first.

I am not getting any clue as to the reason why im getting termreq back from the ISP , sh ppp stats shows the disconnect reasons as entirely due to '17 received LCP TERMREQ from peer'. Its almost like it doesnt understand my response rather than it being incorrect. i wondered if the secret is being hashed correctly but i cant think of a reason why it wouldnt be I have a crypto map confiured buy not applied as yet..

here is the debug output for the failed session (debug ppp auth, neg  and errors)

*Jul  2 06:50:59.837: PPP: Alloc Context [86E2C804]
*Jul  2 06:50:59.837: ppp975 PPP: Phase is ESTABLISHING
*Jul  2 06:50:59.837: Vi2 PPP: Using dialer call direction
*Jul  2 06:50:59.837: Vi2 PPP: Treating connection as a callout
*Jul  2 06:50:59.837: Vi2 PPP: Session handle[F3000030] Session id[975]
*Jul  2 06:50:59.837: Vi2 LCP: Event[OPEN] State[Initial to Starting]
*Jul  2 06:50:59.837: Vi2 PPP: No remote authentication for call-out
*Jul  2 06:50:59.837: Vi2 LCP: O CONFREQ [Starting] id 1 len 10
*Jul  2 06:50:59.837: Vi2 LCP:    MagicNumber 0x14194245 (0x050614194245)
*Jul  2 06:50:59.837: Vi2 LCP: Event[UP] State[Starting to REQsent]
*Jul  2 06:51:00.089: Vi2 LCP: I CONFREQ [REQsent] id 103 len 19
*Jul  2 06:51:00.089: Vi2 LCP:    MRU 1500 (0x010405DC)
*Jul  2 06:51:00.089: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
*Jul  2 06:51:00.089: Vi2 LCP:    MagicNumber 0x23918A01 (0x050623918A01)
*Jul  2 06:51:00.089: Vi2 LCP: O CONFACK [REQsent] id 103 len 19
*Jul  2 06:51:00.089: Vi2 LCP:    MRU 1500 (0x010405DC)
*Jul  2 06:51:00.089: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
*Jul  2 06:51:00.089: Vi2 LCP:    MagicNumber 0x23918A01 (0x050623918A01)
*Jul  2 06:51:00.089: Vi2 LCP: Event[Receive ConfReq+] State[REQsent to ACKsent]
*Jul  2 06:51:00.093: Vi2 LCP: I CONFACK [ACKsent] id 1 len 10
*Jul  2 06:51:00.093: Vi2 LCP:    MagicNumber 0x14194245 (0x050614194245)
*Jul  2 06:51:00.093: Vi2 LCP: Event[Receive ConfAck] State[ACKsent to Open]
*Jul  2 06:51:00.097: Vi2 PPP: Queue CHAP code[1] id[1]
*Jul  2 06:51:00.117: Vi2 PPP: No authorization without authentication
*Jul  2 06:51:00.117: Vi2 PPP: Phase is AUTHENTICATING, by the peer
*Jul  2 06:51:00.117: Vi2 CHAP: Redirect packet to Vi2
*Jul  2 06:51:00.117: Vi2 CHAP: I CHALLENGE id 1 len 35 from "bras-xxxxx"
*Jul  2 06:51:00.117: Vi2 PPP: Sent CHAP SENDAUTH Request
*Jul  2 06:51:00.117: Vi2 LCP: State is Open
*Jul  2 06:51:00.117: Vi2 PPP: Received SENDAUTH Response FAIL
*Jul  2 06:51:00.117: Vi2 CHAP: Using hostname from interface CHAP
*Jul  2 06:51:00.117: Vi2 CHAP: Using password from interface CHAP
*Jul  2 06:51:00.117: Vi2 CHAP: O RESPONSE id 1 len 37 from "shmyusername@myisp.com"
*Jul  2 06:51:00.861: Vi2 LCP: I TERMREQ [Open] id 104 len 4
*Jul  2 06:51:00.861: Vi2 PPP DISC: Received LCP TERMREQ from peer
*Jul  2 06:51:00.861: PPP: NET STOP send to AAA.
*Jul  2 06:51:00.861: Vi2 PPP: Phase is TERMINATING
*Jul  2 06:51:00.861: Vi2 LCP: O TERMACK [Open] id 104 len 4
*Jul  2 06:51:00.861: Vi2 LCP: Event[Receive TermReq] State[Open to Stopping]
*Jul  2 06:51:02.869: Vi2 PPP: No remote authentication for call-out
*Jul  2 06:51:02.869: Vi2 LCP: Event[Timeout-] State[Stopping to Stopped]
*Jul  2 06:51:02.869: Vi2 LCP: Event[DOWN] State[Stopped to Starting]
*Jul  2 06:51:02.869: Vi2 PPP: Phase is DOWN

 

here are the relevant parts of the config, dialer 1 is bound to virtual-access 2

controller VDSL 0

interface Ethernet0
 no ip address
 shutdown
!
interface ATM0
 description BT-Circuit-No...
 no ip address
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !

interface Dialer1
 description Connection-To-BT-number-ATM0
 ip address negotiated
 no ip redirects
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin optional
 ppp chap hostname mysername@myisp.com
 ppp chap password 0 mypassword
 ppp pap sent-username myusername@myisp.com password 0 mypassword
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
 no cdp enable

dialer-list 1 protocol ip permit

 

ip nat inside source list PUBLIC-PAT interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1

any ideas appreciated.

Cheers

Shaun

 

 

 

Everyone's tags (6)
222
Views
0
Helpful
0
Replies
CreatePlease to create content