Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ADSL connection (DNS)

dear all,

I would like to inform me why I don't have any DNS service through my laptop. It takes IP address, but when I hit URLs, there is no response. What should I look for? Below is the configuration of the router:

Current configuration : 4943 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Cisco877w

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-61071307

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-61071307

revocation-check none

rsakeypair TP-self-signed-61071307

!

!

crypto pki certificate chain TP-self-signed-61071307

certificate self-signed 01

  3082023D 308201A6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  2F312D30 2B060355 04031324 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 36313037 31333037 301E170D 30323033 30313031 35303531

  5A170D32 30303130 31303030 3030305A 302F312D 302B0603 55040313 24494F53

  2D53656C 662D5369 676E6564 2D436572 74696669 63617465 2D363130 37313330

  3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100EB64

  6DACF565 D04F4A31 6F2BFB0C A94377E5 6105B1FD 19765A6D EE354DD6 2CBBDD5B

  336DE8F7 170D79EC FB3A47C9 8EC8D5F4 2E9C3E64 3366232A D9FDE553 18C778B6

  8FD12A0E 8416C8CC B08FEB86 DC23B661 879D1BF5 F8AD8585 80656BA6 0EFC0FF9

  363730FD 4F19333B 5122516F 5BB27B29 613F3EB1 E2C605E5 1192D5F3 44250203

  010001A3 69306730 0F060355 1D130101 FF040530 030101FF 30140603 551D1104

  0D300B82 09436973 636F3837 3777301F 0603551D 23041830 168014F8 B69398EA

  CA969B20 CD8FF464 4015E6D0 2D1B5F30 1D060355 1D0E0416 0414F8B6 9398EACA

  969B20CD 8FF46440 15E6D02D 1B5F300D 06092A86 4886F70D 01010405 00038181

  00A29028 EB7B94E1 D7F03D11 EC042A5D 55FE8747 42BC106C 3BA10CD2 BB26DC05

  5B0E3DAB 2F838914 15EE80C7 17862B84 05002013 2BB8CA19 DF403EE1 8E2F8CDB

  7C512CCB 17592407 57651C49 4C80780D A9F5DBDA 34E3A4A9 25A39BF4 6E9F31A5

  F2E61442 ACD55A0F 1ABAEFB5 ACF60E36 B2197F85 6C747658 C910DB62 8F2CCF4C E4

        quit

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 192.168.0.1

!

ip dhcp pool LAN

   import all

   network 192.168.0.0 255.255.255.248

   default-router 192.168.0.1

   dns-server X.X.X.X X.X.X.X

!

!

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

archive

log config

  hidekeys

!

!

!

bridge irb

!

!

interface ATM0

description Broadband link

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no ip mroute-cache

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet0

no cdp enable

spanning-tree portfast

!

interface FastEthernet1

no cdp enable

spanning-tree portfast

!

interface FastEthernet2

no cdp enable

spanning-tree portfast

!

interface FastEthernet3

no cdp enable

spanning-tree portfast

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

description Network 1

no ip address

ip nat inside

ip virtual-reassembly

no ip route-cache cef

bridge-group 1

!

interface Dialer1

description Outside

ip address negotiated

ip access-group 101 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip flow ingress

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname XXXXXXX

ppp chap password 7 050A040C6F021F5B4A

!

interface BVI1

description Bridge for VL1

ip address 192.168.0.1 255.255.255.0

ip nbar protocol-discovery

ip flow ingress

ip flow egress

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

ip http secure-server

!

ip flow-top-talkers

top 5

sort-by bytes

!

ip nat inside source list 1 interface Dialer1 overload

!

logging history debugging

logging trap debugging

logging 192.168.0.4

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 101 remark --- Deny special-use address sources

access-list 101 deny   ip 127.0.0.0 0.255.255.255 any log

access-list 101 deny   ip 192.0.2.0 0.0.0.255 any log

access-list 101 deny   ip 224.0.0.0 31.255.255.255 any log

access-list 101 deny   ip host 255.255.255.255 any log

access-list 101 deny   ip host 0.0.0.0 any log

access-list 101 remark --- Filter RFC 1918 space

access-list 101 permit ip 192.168.0.0 0.0.255.255 any log

access-list 101 deny   ip 10.32.0.0 0.0.255.255 any log

access-list 101 deny   ip 10.0.0.0 0.255.255.255 any log

access-list 101 deny   ip 172.16.0.0 0.15.255.255 any log

access-list 101 permit udp any any eq ntp log

access-list 101 deny   tcp any any eq telnet log

access-list 101 permit ip any any log

dialer-list 1 protocol ip permit

no cdp run

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

bridge 2 protocol ieee

bridge 2 route ip

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

Everyone's tags (4)
6 REPLIES
Hall of Fame Super Blue

Re: ADSL connection (DNS)

If you do an "ipconfig /all" on your laptop (assuming windows) what is the DNS server ?

On your router you have -

dns-server X.X.X.X X.X.X.X 

under your DHCP config.  What is this DNS server and can it resolve internet names ?

Jon

New Member

Re: ADSL connection (DNS)

I manually configure the DNS service at my laptop to be router's (877w) DNS which is the X.X.X.X (dns-server 193.92.150.3 194.219.227.2)

My laptop and the router cannot resolve DNS names.

Hall of Fame Super Blue

Re: ADSL connection (DNS)

Where did you get these DNS server IP addresses from ?

Jon

New Member

Re: ADSL connection (DNS)

I set them up manually at the running configuration. These DNSs are provided from my ISP.

Hall of Fame Super Blue

Re: ADSL connection (DNS)

Can you actually connect to a website by using it's IP address ?

Jon

New Member

Re: ADSL connection (DNS)

I was told to try:

ip name-server x.x.x.x x.x.x.x (DNS server for your ISP)

I will let you know after configuring it.

1374
Views
0
Helpful
6
Replies
CreatePlease to create content