Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

ADSL over PPPOE Configuration

HI All,

I ISP gave PPPOE broad band line, they gave one Mode, I have changed the modem mode in bridge mode and I have configured the PPPOE in cisco router it working fine. Now I am trying to install ADSL wic card in cisco router 1842 cisco router, Please any one give me the sample configuration for ATM interface for PPPOE. I have the dialer Details . Thanks in advance .

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: ADSL over PPPOE Configuration

Hello Thiru,

the config of the ATM ADSL interface for PPPoE over ATM can be:

interface ATM0/0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

interface Dialer2

description PPPoverATM

ip address negotiated

encapsulation ppp

dialer pool 2

dialer-group 2

!

use the right VPI/VCI as per provider specs

the pool-number must point to the number in the dialer config.

Define the dialer list

Hope to help

Giuseppe

6 REPLIES
Hall of Fame Super Silver

Re: ADSL over PPPOE Configuration

Hello Thiru,

the config of the ATM ADSL interface for PPPoE over ATM can be:

interface ATM0/0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

interface Dialer2

description PPPoverATM

ip address negotiated

encapsulation ppp

dialer pool 2

dialer-group 2

!

use the right VPI/VCI as per provider specs

the pool-number must point to the number in the dialer config.

Define the dialer list

Hope to help

Giuseppe

Community Member

Re: ADSL over PPPOE Configuration

Hi Giuseppe,

Thanks a lot , I asked the vpi/vci value, Already I am having the pap username and password , Let you inform you once I done this.

Thiru

Community Member

Re: ADSL over PPPOE Configuration

I Got the this following details from ISP and I have configured the same .

VPI = 8

VCI= 35

encapsulation =VC MUX

PPPOE/PPPOA

Router Configuration ,

interface ATM0/0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

nterface Dialer1

ip unnumbered Loopback1

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap

ppp pap sent-username ******** password ********

end

But still the internet link not coming up. Then I have connected the modem through E0 interface and I configured

nterface FastEthernet0/1

description --> To internet

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

That time I am able to access the router

Community Member

Re: ADSL over PPPOE Configuration

please any help me for this

Hall of Fame Super Silver

Re: ADSL over PPPOE Configuration

Hello Thiru,

in the second case you have connected a Fas port to an external modem ?

the modem could be doing simple bridging of PPPoE frames over the ATM PVC.

to emulate what the modem does you need

interface Ethernet0

no ip address

no ip directed-broadcast

bridge-group 1

!

interface ATM0

no ip address

no ip directed-broadcast

no ip mroute-cache

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux

!

bundle-enable

bridge-group 1

hold-queue 224 in

!

bridge 1 protocol ieee

But this would be fine with PPPoE running on PC.

see

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080094474.shtml

You may need a different config instead of the one I had suggested in previous post.

To be able to have PPPoE client over ATM interface all on the router:

follow the next link:

http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_example09186a0080094475.shtml

the key point is:

interface ATM0.1 point-to-point

pvc 8/35

enc aal5mux

pppoe-client dial-pool-number 1

there are many variations as you can see.

Hope to help

Giuseppe

Community Member

Re: ADSL over PPPOE Configuration

now its working thanks a lot

1421
Views
0
Helpful
6
Replies
CreatePlease to create content