Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Advertising local host routes in BGP?

I have a situation where I'm trying to advertise only 4 host routes from a /24 network to my BGP neighbors.
As an example,

#R1
interface g0/0
ip addr 1.1.1.2 255.255.255.0
standby ip 1.1.1.1

router bgp 1
network 1.1.1.4 mask 255.255.255.255
network 1.1.1.5 mask 255.255.255.255
network 1.1.1.7 mask 255.255.255.255
network 1.1.1.9 mask 255.255.255.255

With a single router, a static route to the interface worked fine..

ip route 1.1.1.4 255.255.255.255 g0/0
ip route 1.1.1.5 255.255.255.255 g0/0
ip route 1.1.1.7 255.255.255.255 g0/0
ip route 1.1.1.9 255.255.255.255 g0/0

When adding a redundant router, things initially work as well..

#R2
interface g0/0
ip addr 1.1.1.3 255.255.255.0
standby ip 1.1.1.1

router bgp 1
network 1.1.1.4 mask 255.255.255.255
network 1.1.1.5 mask 255.255.255.255
network 1.1.1.7 mask 255.255.255.255
network 1.1.1.9 mask 255.255.255.255

ip route 1.1.1.4 255.255.255.255 g0/0
ip route 1.1.1.5 255.255.255.255 g0/0
ip route 1.1.1.7 255.255.255.255 g0/0
ip route 1.1.1.9 255.255.255.255 g0/0

The issue arises when R1 fails, R2 has a CEF routing loop..

Troubleshooting Cisco Express Forwarding Routing Loops
Document ID: 26083
http://www.cisco.com/en/US/partner/tech/tk827/tk831/technologies_tech_note09186a00800cdf2e.shtml

The link says the solution is to point the statics to the next hop; which I can't, as they are local.

Is there another way to advertise these host routes?

I've been trying to use inject-maps, but my own routers are the route source, and it doesn't appear to work.

Ideas?

Everyone's tags (1)
4 REPLIES
Cisco Employee

Re: Advertising local host routes in BGP?

Hi,

When you say R1 fail, do you mean the chassis is down, or interface down? What problem did you see after R1 fail?

HTH,

Lei Tian

New Member

Re: Advertising local host routes in BGP?

Lei Tian,

Thanks for the reply.

The actual sequence of failure was the SPA card in the router R1, which holds all of the interfaces in question.  So the R1 was unreachable.

The problem we saw was that some of the host routes (but not all of them) were unreachable..  Strange CEF behaviour, but documented in that link from Cisco...

Cisco Employee

Re: Advertising local host routes in BGP?

I see, after SPA card fail, you see loop between R1 and R2? How R1, R2 and hosts connect to eachother? Can you post a simple topology for this setup?

HTH,

Lei Tian

New Member

Re: Advertising local host routes in BGP?


upstream peer            upstream peer
    |                        |
-------------------------------------------
   |                        |
  R1 (1.1.1.2)         R2 (1.1.1.2)
   |  g0/0                  |   g0/0
-------------------------------------------
                 |
            host (1.1.1.5)

2067
Views
0
Helpful
4
Replies