Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

After connecting second PPPoE 1802 restarts

Hallo,

I would like to ask you for help.

have two ADSl connections in future in load balancing.

The 1802 have 1x ADSL integraded port and 1x FE0 WAN port.

Each port works well.

After EF0 is modem with PPP bridge so 1802 make PPPoE autentication as Dialer 1 and ADSL Dialer 0, this is same ISP with same setting only user name and pass differs.

When I start with ADSL or EF0 as first and then connect second connection it synchtronyze DSL and after some small Flash rom acces (something read) it restart whole 1802.

The syslog says

2010/01/22    10:26:32,96    M            %link-3-updown: interface atm0, changed state to up           
2010/01/22    10:26:32,96    M            %lineproto-5-updown: line protocol on interface atm0, changed state to up           
2010/01/22    10:26:35,87    M            %dialer-6-bind: interface vi4 bound to profile di0           
2010/01/22    10:26:36,86    M            %link-3-updown: interface virtual-access4, changed state to up           
2010/01/22    10:26:42,95    M            %lineproto-5-updown: line protocol on interface virtual-access4, changed state to up

and then nothing.

IOS 15.0(1)M1

!
interface ATM0
no ip address
no ip redirects
no ip unreachables
ip flow ingress
no atm ilmi-keepalive
!
!
interface ATM0.1 point-to-point
description $ES_WAN$
no ip redirects
no ip unreachables
ip flow ingress
pvc 8/48
  pppoe-client dial-pool-number 1
!
!

interface FastEthernet0
description $ETH-WAN$
no ip address
no ip redirects
no ip unreachables
ip flow ingress
zone-member security out-zone
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 2
!

interface Dialer0
description $FW_OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nbar protocol-discovery
ip flow ingress
ip flow egress
ip ips sdm_ips_rule in
ip ips sdm_ips_rule out
zone-member security out-zone
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname dslXXXX
ppp chap password 0 XXX
ppp pap sent-username dslXXXX password 0 XXX

!
!
interface Dialer1
description $FW_OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nbar protocol-discovery
ip flow ingress
ip flow egress
ip nat outside
ip ips sdm_ips_rule in
ip ips sdm_ips_rule out
no ip virtual-reassembly
zone-member security out-zone
encapsulation ppp
dialer pool 2
dialer-group 2
ppp authentication chap pap callin
ppp chap hostname adYYY
ppp chap password 0 YYY
ppp pap sent-username adYYY password 0 YYY
no cdp enable

Thank for help

Urbanek

6 REPLIES
Hall of Fame Super Silver

Re: After connecting second PPPoE 1802 restarts

Hello Urbanek,

this is clearly a configuration generated by SDM.

I would try removing some commands:

int dialer 0

no ip ips sdm_ips_rule in

no ip ips sdm_ips_rule out

no ip flow ingress

no ip flow egress

do the same on dialer1

save config and retry

you can also post a sh ver, sh stack and dir /all to see if a crashinfo file has been written

if a crashinfo file is present you can take it by simply using the more command and you can log it in the telnet session

Hope to help

Giuseppe

New Member

Re: After connecting second PPPoE 1802 restarts

Hallo Giuseppe,

thank you for answer, disable IPS I done before but forget to write here but after restart it loads IPS again, in case of Netflow I tryed it now without success.

now dialers looks

  !
interface Dialer0
description $FW_OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly
zone-member security out-zone
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname dslXXX
ppp chap password 0 XXX
ppp pap sent-username dslXX password 0 XXX
!
!
interface Dialer1
description $FW_OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nbar protocol-discovery
ip nat outside
no ip virtual-reassembly
zone-member security out-zone
encapsulation ppp
dialer pool 2
dialer-group 2
ppp authentication chap pap callin
ppp chap hostname adYYY
ppp chap password 0 YYY
ppp pap sent-username adYYY password 0 YYY
no cdp enable
!

Sh ver

Router#show version
Cisco IOS Software, C180X Software (C180X-ADVIPSERVICESK9-M), Version 15.0(1)M1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Wed 02-Dec-09 13:29 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YH12, RELEASE SOFTWARE (fc1)

Router uptime is 7 minutes
System returned to ROM by address error at PC 0x80778F6C, address 0x36C at 13:59:01 PCTime Fri Jan 22 2010
System image file is "flash:c180x-advipservicesk9-mz.150-1.M1.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 1802W (MPC8500) processor (revision 0x400) with 354304K/38912K bytes of memory.
Processor board ID FCZ123112CE, with hardware revision 0000

9 FastEthernet interfaces
1 ISDN Basic Rate interface
1 ATM interface
1 Virtual Private Network (VPN) Module
2 802.11 Radios
125184K bytes of ATA CompactFlash (Read/Write)


License Info:

License UDI:

-------------------------------------------------
Device#   PID                   SN
-------------------------------------------------
*0        CISCO1802W-AG-E/K9    FCXXXXXXXXXX

Configuration register is 0x2102

there are crashinfo but with 0 long las full is from today morninig when it crash too but not with disabled IPS and netflow. Looks that crashes are so fast that not have time to write

000056: *Jan 22 09:47:44.100 PCTime: %LINK-3-UPDOWN: Interface ATM0, changed state to up
000057: *Jan 22 09:47:45.184 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to up
000058: *Jan 22 09:47:56.068 PCTime: %DIALER-6-BIND: Interface Vi4 bound to profile Di0
000059: *Jan 22 09:47:56.272 PCTime: %LINK-3-UPDOWN: Interface Virtual-Access4, changed state to up
000060: *Jan 22 09:47:58.080 PCTime: %IPS-6-ENGINE_BUILDS_STARTED:  09:47:58 PCTime Jan 22 2010
000061: *Jan 22 09:47:58.084 PCTime: %IPS-6-ENGINE_BUILDING: atomic-ip - 373 signatures - 1 of 16 engines
000062: *Jan 22 09:47:58.944 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access4, changed state to up

09:47:58 PCTime Fri Jan 22 2010: Unexpected exception to CPU: vector 1400, PC = 0x80778F10, LR = 0x8041CDF0

-Traceback= 0x80778F10z 0x8041CDF0z 0x8041EAACz 0x80147C2Cz 0x8014AAC0z 0x800FB2ECz 0x8001AD6Cz 0x8001AD6Cz 0x800FB3A8z 0x80B34A24z 0x80B34A34z 0x823B3F3Cz 0x823B1CC0z 0x823B1D08z 0x823B1E94z 0x8239CDD0z

CPU Register Context:
MSR = 0x00029220  CR  = 0x84008088  CTR = 0x81958408  XER   = 0x00000000
R0  = 0x80778EF0  R1  = 0x84AED2D0  R2  = 0xFFEB1F58  R3    = 0x84BFF6F4
R4  = 0x84AED2F0  R5  = 0x00000001  R6  = 0x00000014  R7    = 0x00000000
R8  = 0x00000000  R9  = 0x00000001  R10 = 0x84210000  R11   = 0x0000000D
R12 = 0x00000000  R13 = 0xFFEB37F4  R14 = 0x00000640  R15   = 0x84AED2E0
R16 = 0x83EE0000  R17 = 0x8041C570  R18 = 0x00000000  R19   = 0x00000000
R20 = 0x88733FA8  R21 = 0x0000000C  R22 = 0x84C00390  R23   = 0x84BFF6F4
R24 = 0x00000000  R25 = 0x84BFF6F4  R26 = 0x15A614CE  R27   = 0x868FEF04
R28 = 0x0000002E  R29 = 0x00000021  R30 = 0x84BFFB5C  R31   = 0x84A7563C

more in file

New Member

Re: After connecting second PPPoE 1802 restarts

Hall of Fame Super Gold

Re: After connecting second PPPoE 1802 restarts

Insisting on opening a new bug was the right choice.

Looking the the crash location it may not be a fundamental issue and hopefully can be resolved soon.

New Member

Re: After connecting second PPPoE 1802 restarts

Bug is closed, after submitting more logs there was found problem.

1802 have not changable ATM card and there was same MAC as FE0 MAC, so when second PPPoE starts it make error and it restart 1802.

The surprise was for me and Cisco too that on same device is same MAC on two other interfaces.

The workaround is by CLI mac-address XXX.XXXX.XXXX and chage ATM MAC to other.

Hall of Fame Super Gold

Re: After connecting second PPPoE 1802 restarts

Good to know, thanks.

1809
Views
0
Helpful
6
Replies