Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

%ALIGN-3-SPURIOUS: & %ALIGN-3-TRACE: -Traceback=

Dear All,

For last few days I am getting the following log to my Cisco 1841 Router.

%ALIGN-3-SPURIOUS: Spurious memory access made at 0x61656290 reading 0x4

%ALIGN-3-TRACE: -Traceback= 0x61656290 0x61655528 0x614FA270 0x614FA254 0x0 0x0 0x0 0x0

%ALIGN-3-TRACE: -Traceback= 0x616562D4 0x61655528 0x614FA270 0x614FA254 0x0 0x0 0x0 0x0

As per Cisco:

%ALIGN-3-SPURIOUS: Spurious memory access made at [hex] reading [hex]

A spurious access occurs when a process attempts to read from the lowest region of memory. This portion of memory is reserved and should never be accessed. An attempted read operation to this region of memory is usually caused by the return of a nonexisting value to a function in the software.

Recommended Action: The system has detected the illegal access and was able to correct it without a system failure. This condition indicates a software failure. To take advantage of recent fixes, upgrade your system to the latest Cisco IOS software release in your release train. If this message recurs, enter the show log, show alignment and show tech-support commands, contact your Cisco technical support representative, and provide the representative with the gathered information.

%ALIGN-3-TRACE: -Traceback= [hex] [hex] [hex] [hex] [hex] [hex] [hex] [hex]

This tracing message provides information about a previous ALIGN error.

Recommended Action: Copy the error message exactly as it appears on the console or in the system log, contact your Cisco technical support representative, and provide the representative with the gathered information.

The same has been informed to Cisco and also the router has fully replaced. But after replacing the same is reflecting to router log.

Additional Details:

IOS : System image file is "flash:c1841-advsecurityk9-mz.124-3d.bin" and c1841-advsecurityk9-mz.124-1a.bin (with the both we are getting the same log)

Memory alignment:

1841#sh alignment

Alignment data for:

1841 Software (C1841-ADVSECURITYK9-M), Version 12.4(3d), RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Compiled Tue 18-Apr-06 19:27 by alnguyen

No alignment data has been recorded.

Total Spurious Accesses 2, Recorded 2

Address Count Traceback

4 1 0x61656290 0x61655528 0x614FA270 0x614FA254

94 1 0x616562D4 0x61655528 0x614FA270 0x614FA254

SIL-CHATTISGARH-B'PUR-1841#

Any suggestion?

22 REPLIES
Hall of Fame Super Silver

Re: %ALIGN-3-SPURIOUS: & %ALIGN-3-TRACE: -Traceback=

Hello Goutam,

you should think of an IOS upgrade.

However, the sh alignment tells that there have been only two spurios accesses both recorded.

If this happens other times go for IOS upgrade.

Actually, we have some routers on branch offices complaining of something similar and they are still working.

if you don't notice any issue for users and traffic you can plan the upgrade quietly.

Hope to help

Giuseppe

Re: %ALIGN-3-SPURIOUS: & %ALIGN-3-TRACE: -Traceback=

Hello Giuseppe,

I am also thinking so. I have searched the same with "Cisco Bug Tool" and suggesting to upload c1841-advsecurityk9-mz.124-22.YB.bin. Lets see after upgrading the same.

Thanks for Help.

Regards

Goutam

New Member

I´ve the same problem: Jul 27

I´ve the same problem:

 

Jul 27 22:37:42: %ALIGN-3-SPURIOUS: Spurious memory access made at 0x41CDEBB0 reading 0x14
Jul 27 22:37:42: %ALIGN-3-TRACE: -Traceback= 41CDEBB0 41CE2498 41FBB1D0 424B106C 42739324 42731E78 42B77CCC 00000000
Jul 27 22:37:42: %ALIGN-3-TRACE: -Traceback= 41CDEBB4 41CE2498 41FBB1D0 424B106C 42739324 42731E78 42B77CCC 00000000
Jul 27 22:37:42: %ALIGN-3-TRACE: -Traceback= 41CDEBC8 41CE2498 41FBB1D0 424B106C 42739324 42731E78 42B77CCC 00000000
Jul 27 22:37:42: %ALIGN-3-TRACE: -Traceback= 408F26A0 41CDEBF8 41CE2498 41FBB1D0 424B106C 42739324 42731E78 42B77CCC
Jul 27 22:37:42: %ALIGN-3-TRACE: -Traceback= 41CDEBF8 41CE2498 41FBB1D0 424B106C 42739324 42731E78 42B77CCC 00000000
Jul 27 22:37:42: %ALIGN-3-TRACE: -Traceback= 41CE1718 41CE24BC 41FBB1D0 424B106C 42739324 42731E78 42B77CCC 00000000
Jul 27 22:37:42: %ALIGN-3-TRACE: -Traceback= 41CE171C 41CE24BC 41FBB1D0 424B106C 42739324 42731E78 42B77CCC 00000000
Jul 27 22:37:42: %ALIGN-3-TRACE: -Traceback= 41CE1730 41CE24BC 41FBB1D0 424B106C 42739324 42731E78 42B77CCC 00000000
Jul 27 22:37:42: %ALIGN-3-TRACE: -Traceback= 408F26A0 41CE1760 41CE24BC 41FBB1D0 424B106C 42739324 42731E78 42B77CCC
Jul 27 22:37:42: %ALIGN-3-TRACE: -Traceback= 41CE1760 41CE24BC 41FBB1D0 424B106C 42739324 42731E78 42B77CCC 00000000


CISCO-cat6509#sh alignment
Alignment data for:
s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(33)SXJ3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Compiled Mon 16-Apr-12 16:12 by prod_rel_team

No alignment data has been recorded.

Total Spurious Accesses 35, Recorded 10

 Address  Count  Traceback
      14      5  0x41CDEBB0 0x41CE2498 0x41FBB1D0 0x424B106C
                 0x42739324 0x42731E78 0x42B77CCC
      10      5  0x41CDEBB4 0x41CE2498 0x41FBB1D0 0x424B106C
                 0x42739324 0x42731E78 0x42B77CCC
       4      5  0x41CDEBC8 0x41CE2498 0x41FBB1D0 0x424B106C
                 0x42739324 0x42731E78 0x42B77CCC
      20      5  0x408F26A0 0x41CDEBF8 0x41CE2498 0x41FBB1D0
                 0x424B106C 0x42739324 0x42731E78 0x42B77CCC
       0      5  0x41CDEBF8 0x41CE2498 0x41FBB1D0 0x424B106C
                 0x42739324 0x42731E78 0x42B77CCC
      14      2  0x41CE1718 0x41CE24BC 0x41FBB1D0 0x424B106C
                 0x42739324 0x42731E78 0x42B77CCC
      10      2  0x41CE171C 0x41CE24BC 0x41FBB1D0 0x424B106C
                 0x42739324 0x42731E78 0x42B77CCC
       4      2  0x41CE1730 0x41CE24BC 0x41FBB1D0 0x424B106C
                 0x42739324 0x42731E78 0x42B77CCC
      20      2  0x408F26A0 0x41CE1760 0x41CE24BC 0x41FBB1D0
                 0x424B106C 0x42739324 0x42731E78 0x42B77CCC
       0      2  0x41CE1760 0x41CE24BC 0x41FBB1D0 0x424B106C
                 0x42739324 0x42731E78 0x42B77CCC

New Member

I am having the same problem

I am having the same problem too with my Cisco 2821

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 15.1(4)M,

Nov 3 08:40:33.255: %ALIGN-3-CORRECT: Alignment correction made at 0x401B321Cz reading 0x3F003719
*Nov 3 08:40:33.255: %ALIGN-3-TRACE: -Traceback= 0x401B321Cz 0x402D6650z 0x402D68C8z 0x400726ECz 0x4019B9A4z 0xFFFF6620z 0xFFFF6620z 0xFFFF6620z

Hall of Fame Super Gold

The advice is the same as in

The advice is the same as in previous posts in this thread. An alignment error is a software issue. And a traceback is always an indication of a software issue. So you have two indications of software problems in the version of code that you are running. To fix the problem you need to change to a different version of software on your router.

HTH

Rick

New Member

Hi Rick,

Hi Rick,

But anyway the router is working with the configuration we set there will be any other issue if I will let this message appearing?

thanks for your response

Regards,

Jason

Hall of Fame Super Gold

Jason

Jason

You have indications of some sort of problem in the software version that you are running. But it appears that the impact of the problem is very small. In that case you can certainly just continue to run with the software that you currently have.

HTH

Rick

New Member

Hi Rick,

Hi Rick,

but it something weird for me about this router during the time of configuration and after saving the config, this messages is not appearing only when i connected it and put it on live environment

Regards,

Jason

Hall of Fame Super Gold

Jason

Jason

I believe that there is a simple explanation for what you observe. First let us remember something that was included in the original post "A spurious access occurs when a process attempts to read from the lowest region of memory." So the question becomes: when does this process execute? I suggest that whatever this process is that it does not execute during configuration and saving the config but does execute in response to something that happens when connected to the live environment.

HTH

Rick

New Member

Hi Rick,

Hi Rick,

ah okay.

btw can you take a look with the sh alignment result unlike from the first message from the thread for their router there is Spurious Access from their router but for me it is showing : 

No spurious memory references have been recorded.

Instead:

No spurious memory references have been recorded.

please see at the attached file

Hall of Fame Super Gold

Ok in some detail your issue

Ok in some detail your issue is slightly different from the ones mentioned in previous posts. They report spurious memory access and you report alignment correction. I am not qualified to explain the differences between these messages. But you are reporting tracebacks as were the original posts. And a traceback is always a sign of a software problem. So your version of software is experiencing software failures of some sort. My advice does not change. If you want to solve the problem that you are experiencing you need to change the version of software that you are running. But if the software issue is very low impact then you may want to continue to run the version of software that you currently are running.

HTH

Rick

New Member

Hi Rick,

Hi Rick,

Thank you very much for your advise I've learned a lot from your thoughts and in technical view.

btw i'm planning to change the router hoping that the problem will solved but i'm worrying that it is in the same IOS version heheheh

Regards,

Jason

Hall of Fame Super Gold

Jason

Jason

Good luck with replacing the router. If you replace the router with one running exactly the same version then it is likely that you will continue to receive the tracebacks. But if the impact is low then it should be ok. Let us know how things are working after you replace the router.

HTH

Rick

New Member

Rick,

Rick,

Hopefully we will not receive the same tracebacks.  But actually I haven't seen any big impact as of the moment because the router which is now receiving this message is still UP and this is the 4th day.

I hope Cisco is going to have some update tools to fix bugs like this in their IOS like windows update in Microsoft for fixing bugs instead of replacing its IOS version where like the device is in the remote places that the IT person needs to visit the area personally to change IOS version to fix bugs like this...heheheh

Actually we have the IOS version which is 12.4 which is working fine but the only problem we use this is because of the HWIC-2FE which is not detecting and we have to use it.

Regards,

Jason

New Member

Hi Rick

Hi Rick

My issue has been resolved after I replaced the router with IOS flash:c2800nm-advipservicesk9-mz.151-4.M12a.bin but I am now receiving the error as shown below but i check the VPN connection thru sh crypto isakmp sa

it is showing that my connection and active and the network behind it is connected to our HQ.  

Can i ask you about the message I am receiving from the router?

%CRYPTO-4-PKT_REPLAY_ERR: decrypt: replay check failed 

Regards,

Jason

Hall of Fame Super Gold

Jason

Jason

I am glad to know that replacing the router did resolve the issue with alignment and tracebacks. I have seen that error message when doing site to site VPN. The TAC indicated that this is frequently an indication that IPsec is seeing some packets out of order and is frequently caused by some issues in the provider networks. In my experience the error message is not having any impact on performance of the VPN. My advice is to not worry about this error message.

HTH

Rick 

New Member

Rick,

Rick,

Yup I don't see any issue as of the moment I tried to ping HQ to Branch vice versa, I didn't see any time out as well as I have my HWIC-2FE worked which is our main goal.

Thank you very much Rick for sharing your knowledge and patience understanding.

Regards,

Jason Cantos

Hall of Fame Super Gold

Jason

Jason

I am glad to know that your VPN is working. The replay check failed message is an aggravation but does not impact performance.

You are welcome. Thank you for the kind words. I am glad to share what I have learned and happy to know that it is appreciated.

HTH

Rick  

New Member

Hi Rick

Hi Rick

I noticed with our router which is having some issue bootstrap version is different from IOS version.  Maybe this is causing the issue?

ROM: System Bootstrap ko which is Version 12.4(13r)T11, RELEASE SOFTWARE (fc1)

IOS Version 15.1(4)M, RELEASE SOFTWARE (fc1)

Regards,

Jason 

Hall of Fame Super Gold

Jason

Jason

It is common for the version of the bootstrap to be different from the version of running IOS. I very much doubt that the bootstrap version is causing any issue.

It is possible to update the IOS of a router or switch remotely. Being physically at the device is convenient but in most situations it is not a requirement.

HTH

Rick

New Member

Hi Rick,

Hi Rick,

Oh thank  you i thought it is causing the problem.  I have arranged different router with different ios version (c2800nm-advipservicesk9-mz.151-4.M12a) from the previous (c2800nm-advipservicesk9-mz.151-4.M) which is giving alignment issue.

I hope this new IOS can give us resolution hahahaha.. 

Actually I don't have any issue with the old IOS version it was working with all my branch routers except for this branch which we requires HWIC-2FE module and it is not appearing in this IOS version (c2800nm-advipservicesk9-mz.124-22.T).  

That is why I was forced to upgrade IOS.

Regards, 

Jason

Hall of Fame Super Gold

Jason

Jason

Thanks for the update. I hope that the router running  151-4.M12a will solve your problem. After you change the routers please let us know how the new router is doing.

HTH

Rick

4591
Views
40
Helpful
22
Replies
CreatePlease to create content