Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

arp problem

I don't know why, but sometime the router take ip addresses which are in the same subnet to its interface.the conflict appear with the host which normally have this ip address.

These are fastethernet 0/0 configuration:

interface FastEthernet0/0

ip address 196.202.235.2 255.255.255.192 secondary

ip address 196.202.233.2 255.255.255.240

ip nat outside

duplex half

no keepalive

no cdp enable

!

interface Cable4/0

ip address 196.202.233.193 255.255.255.224 secondary

ip address 192.168.3.1 255.255.255.0 secondary

ip address 10.3.1.254 255.255.255.0 secondary

ip address 10.3.2.254 255.255.255.0 secondary

ip address 196.202.233.197 255.255.255.252 secondary

ip address 196.202.235.129 255.255.255.192 secondary

ip address 10.3.3.254 255.255.255.0 secondary

ip address 10.2.6.254 255.255.255.0 secondary

ip address 196.202.233.201 255.255.255.252 secondary

ip address 131.107.20.254 255.255.255.0 secondary

ip address 196.202.233.129 255.255.255.192

There are i route configuration:

ip route 0.0.0.0 0.0.0.0 196.202.233.1

ip route 10.2.5.223 255.255.255.255 196.202.235.1

ip route 10.2.5.225 255.255.255.255 196.202.235.1

ip route 141.122.218.0 255.255.255.128 196.202.233.5

ip route 141.122.218.192 255.255.255.224 192.168.3.20

ip route 192.168.2.20 255.255.255.255 196.202.233.5

ip route 195.24.215.16 255.255.255.248 196.202.235.1

ip route 195.24.215.26 255.255.255.255 196.202.235.1

ip route 196.202.232.5 255.255.255.255 196.202.235.1

ip route 196.202.232.81 255.255.255.255 196.202.235.1

ip route 196.202.232.134 255.255.255.255 196.202.235.1

ip route 196.202.232.139 255.255.255.255 196.202.235.1

ip route 196.202.232.161 255.255.255.255 196.202.235.1

ip route 196.202.232.225 255.255.255.255 196.202.235.1

ip route 196.202.233.160 255.255.255.248 196.202.233.202

ip route 196.202.233.168 255.255.255.248 196.202.233.198

ip route 196.202.235.8 255.255.255.255 10.3.3.2

ip route 196.202.235.192 255.255.255.248 196.202.233.202

There are show arp on mac address of router:

uBR-7246-YDE#sh arp | include 0002.4b15.8800

Internet 196.202.233.2 - 0002.4b15.8800 ARPA FastEthernet0/0

Internet 196.202.235.8 - 0002.4b15.8800 ARPA FastEthernet0/0

Internet 196.202.235.2 - 0002.4b15.8800 ARPA FastEthernet0/0

Normally de ip address 196.202.235.8 is not assigned to router.

Any suggest will be appreciated.

Best regards

1 REPLY
New Member

Re: arp problem

The primary and secondary network ranges are different connected networks. By default, proxy arp is enabled :

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/np1_r/1rprt2/1ripadr.htm#1020409

So that might explain why the router answers arp requests for addresses which don't belong to it.

Try

conf t

int fast0/0

no ip proxy-arp

end

clear arp

And see if the router still exhibits this behavior.

HTH,

Marcel

212
Views
0
Helpful
1
Replies
CreatePlease to create content