Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

P Y
New Member

ASA Routing

I am trying to get my ASA5505 setup correctly and am having difficulty. I am able to get the device to ping the outside interface and the inside interface and i can ping the internet 8.8.8.8 from the ASA. On the client, i am able to ping the inside interface, but am unable to ping the outside interface or the internet 8.8.8.8. What am i missing?..... Configuration and Show Route below.

THANKS

: Saved

:

ASA Version 8.2(5)

!

hostname ciscoasa

enable password XXXXXXXXXXXX encrypted

passwd XXXXXXXXXXX encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.200.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 1.2.3.164 255.255.255.248

!

ftp mode passive

pager lines 24

logging asdm informational

mtu inside 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

route outside 0.0.0.0 0.0.0.0 1.2.3.161 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.200.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 192.168.200.5-192.168.200.254 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny

  inspect sunrpc

  inspect xdmcp

  inspect sip

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:c8f39f7d8756f8815b922397d01ee475

: end

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is 1.2.3.161 to network 0.0.0.0

C    1.2.3.160 255.255.255.248 is directly connected, outside

C    192.168.200.0 255.255.255.0 is directly connected, inside

S*   0.0.0.0 0.0.0.0 [1/0] via 1.2.3.161, outside

1 ACCEPTED SOLUTION

Accepted Solutions

Re: ASA Routing

The ASA, isn't going to let you ping the outside interface IP, from a client on the inside interface.

Try putting in the following command under class inspection_default

'inspect icmp'

Then try and ping 8.8.8.8 from a host off of the inside. By adding the 'inspect icmp', under the class-map inspection_default, it should allow ICMP Echo Replies to come back through the ASA, without configuring an ACE in your ACL, since by looking at the configuration, you have no access-lists applied to the inside and outside interface.

2 REPLIES

Re: ASA Routing

The ASA, isn't going to let you ping the outside interface IP, from a client on the inside interface.

Try putting in the following command under class inspection_default

'inspect icmp'

Then try and ping 8.8.8.8 from a host off of the inside. By adding the 'inspect icmp', under the class-map inspection_default, it should allow ICMP Echo Replies to come back through the ASA, without configuring an ACE in your ACL, since by looking at the configuration, you have no access-lists applied to the inside and outside interface.

P Y
New Member

Re: ASA Routing

Thanks. That worked!

104
Views
0
Helpful
2
Replies