Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ASR 1002 rommon upgrade issue

Hi to all,

I need advice how issue with rommon upgrade on our ASR 1002 device can be resolved.

Issue:
We tried to upgrade IOS on our ASR device by upgrading firstly rommon and then IOS.
After upgrading rommon, route processor remained with old rommon.

 

We have done this IOS ASR upgrade twice without any issues on similar devices.
We are using ATT lab approved versions of software:
- asr1000rp1-adventerprisek9.V151_3_S2_SR617255895_2.bin
- asr1000-rommon.150-1r.S.pkg

Current running IOS on ASR device:
asr1000rp1-advipservicesk9.02.06.00.122-33.XNF.bin

We tried also upgrading just route processor with same result (R0 08011017 12.2(33r)XNC):

r1#sh platform
Chassis type: ASR1002           

Slot      Type                State                 Insert time (ago)
--------- ------------------- --------------------- -----------------
0         ASR1002-SIP10       ok                    2d01h        
 0/0      4XGE-BUILT-IN       ok                    2d01h        
 0/1      SPA-2X1GE-V2        ok                    2d01h        
R0        ASR1002-RP1         ok, active            2d01h        
F0        ASR1000-ESP5        ok, active            2d01h        
P0        ASR1002-PWR-AC      ok                    2d01h        
P1        ASR1002-PWR-AC      ok                    2d01h       

Slot      CPLD Version        Firmware Version                       
--------- ------------------- ---------------------------------------
0         07120202            15.0(1r)S                          
R0        08011017            12.2(33r)XNC                       
F0        07091401            15.0(1r)S   

 

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


HW used:

r1#sh inv
NAME: "Chassis", DESCR: "Cisco ASR1002 Chassis"
PID: ASR1002           , VID: V02, SN: FOX1402G3YX

NAME: "module F0", DESCR: "Cisco ASR1000 Embedded Services Processor, 5Gbps"
PID: ASR1000-ESP5      , VID: V02, SN: JAE14110DV9

NAME: "Power Supply Module 0", DESCR: "Cisco ASR1002 AC Power Supply"
PID: ASR1002-PWR-AC    , VID: V01, SN: ART1403U05J

NAME: "Power Supply Module 1", DESCR: "Cisco ASR1002 AC Power Supply"
PID: ASR1002-PWR-AC    , VID: V01, SN: ART1404U050

NAME: "module 0", DESCR: "Cisco ASR1002 SPA Interface Processor 10"
PID: ASR1002-SIP10     , VID: V02, SN: JAE14110OM6

NAME: "SPA subslot 0/1", DESCR: "2-port Gigabit Ethernet Shared Port Adapter"
PID: SPA-2X1GE-V2      , VID: V01, SN: SAL16127T9E

NAME: "subslot 0/1 transceiver 0", DESCR: "GE SX"
PID: SFP-GE-S            , VID: 06  , SN: AGM1620P1R1   

NAME: "subslot 0/1 transceiver 1", DESCR: "GE T"
PID: N/A                 , VID: E   , SN: MTC16160BV3   

NAME: "SPA subslot 0/0", DESCR: "4-port Gigabit Ethernet Shared Port Adapter"
PID: 4XGE-BUILT-IN     , VID: V00, SN: N/A      

NAME: "subslot 0/0 transceiver 0", DESCR: "GE T"
PID: N/A                 , VID: E   , SN: MTC1347042S   

NAME: "subslot 0/0 transceiver 1", DESCR: "GE T"
PID: N/A                 , VID: E   , SN: MTC134704EK   

NAME: "subslot 0/0 transceiver 2", DESCR: "GE T"
PID: N/A                 , VID: E   , SN: MTC1525049K   

NAME: "subslot 0/0 transceiver 3", DESCR: "GE T"
PID: N/A                 , VID: E   , SN: MTC16160DV8   

NAME: "module R0", DESCR: "Cisco ASR1002 Route Processor 1"
PID: ASR1002-RP1       , VID: V02, SN: JAE141200L8

 

I have not found any similar issue so I would really appreciate any kind of advice.

 

Thanks

2 REPLIES
Hall of Fame Super Gold

The command to upgrade the

The command to upgrade the ROMmon on an ASR is upgrade rom-monitor filename flash:blah.bin all.

Community Member

Hi,

Hi,

Thanks for reply.

I used upgrade rom-monitor filename bootflash:asr1000-rommon.150-1r.S.pkg all

and I also did this separately for RP - R0.

But ASR returns common message:

ROMMON upgrade complete.

But the result was RP still on 12.2(33r)XNC.

248
Views
0
Helpful
2
Replies
CreatePlease to create content