Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ASR1001, Portchannel, Vlans, vrf and ospfv2

Hello,

I wants to bundle 2 of the ASR1001 interfaces to a Portchannel using lacp.
In this portchannel we wants to use vlans and vrf and ospfv2.
So the ASR 1001 should behave like a switch with a portchannel with several vlans on it.
So the resulting config will look like this on the asr1001

!
ip vrf a
rd 1:1
ip vrf b
rd 2:1
!
interface GigabitEthernet1/0/0
no ip address
negotiation auto
channel-group 1
!
interface GigabitEthernet1/0/1
no ip address
negotiation auto
channel-group 1
!
interface Port-channel1
!
interface Port-channel1.10
ip vrf forwarding a
ip address 10.0.10.1 255.255.255.0
encapsulation dot1Q 10
ip ospf 1 area 10
ip ospf multi-area 11
!
interface Port-channel1.20
ip vrf forwarding a
ip address 10.0.20.1 255.255.255.0
encapsulation dot1Q 20
ip ospf 1 area 20
ip ospf multi-area 21
!
router ospf 1 vrf a
network 10.0.10.0 0.0.0.255 area 0
!
router ospf 1 vrf b
network 10.0.20.0 0.0.0.255 area 0

I searched the web, but i did not find any examples, which confirms, this will work this way.

I have only found this document, which goes into this direction:
http://www.cisco.com/en/US/docs/ios-xml/ios/lanswitch/configuration/xe-3s/asr1000/lnsw-flow-portchannel-load.html
or this one, not sure for which platform this was written:
http://www.cisco.com/en/US/docs/ios/lanswitch/configuration/guide/lsw_cfg_gecvlan_ps9587_TSD_Products_Configuration_Guide_Chapter.html

I can not test it anywhere at the moment, and i want to decide, if this router is usable for this scenario or not.

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

ASR1001, Portchannel, Vlans, vrf and ospfv2

Hi,

I confirm that the ASR1K device can be used to implement the above configuration.


***********Plz do rate this post if you found it helpful*************************


Thanks & Regards,


Vignesh R P

2 REPLIES

ASR1001, Portchannel, Vlans, vrf and ospfv2

Hi,

I confirm that the ASR1K device can be used to implement the above configuration.


***********Plz do rate this post if you found it helpful*************************


Thanks & Regards,


Vignesh R P

New Member

ASR1001, Portchannel, Vlans, vrf and ospfv2

Hi,

Meanwhile i have found a ASR1k for testing. It works indeed. Some syntaxerrors in the config, but technicaly it works.

Regards

2709
Views
5
Helpful
2
Replies
CreatePlease login to create content