Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Assigning IP address range on VLANs

I would like to dynamically assign a 10.1.1.0 /26 network to VLAN 1 on my DHCP server, is it possible to do this on the Cisco ASA 5500 or should I do this only on the server?

Regards,

1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Assigning IP address range on VLANs

Hi Chris,

This should be possible. .

Looks like maximum number of DHCP client addresses varies depending on the license.Below links shows how to enable DHCP service on ASA.

http://www.cisco.com/c/en/us/td/docs/security/asa/asa82/configuration/guide/config/dhcp.html#wp1115485

Hope that helps

Regards

Najaf

Please rate when applicable or helpful !!!

2 REPLIES
New Member

Assigning IP address range on VLANs

Searching on the web, found this:

DHCP Router Config

conft# interface fa0/0

conft# ip address 200.1.1.2 255.255.255.0

conft# no shutdown

(config)# ip dhcp excluded-address 172.16.1.1 172.16.1.9

(config)# ip dhcp excluded-address 172.16.2.1 172.16.2.9

(config)# ip dhcp pool DATA

(dhcp-config)# network 172.16.2.0 255.255.255.0

(dhcp-config)# default-router 172.16.2.1

(dhcp-config)# dns-server 4.2.2.2

(dhcp-config)# exit

(config)# ip dhcp pool VOICE

(dhcp-config)# network 172.16.1.0 255.255.255.0

(dhcp-config)# default-router 172.16.1.1

(dhcp-config)# option 150 ip 172.16.1.1

(dhcp-config)# exit

(config)# ip route 172.16.1.0 255.255.255.0 200.1.1.1

(config)# ip route 172.16.2.0 255.255.255.0 200.1.1.1

Gold

Assigning IP address range on VLANs

Hi Chris,

This should be possible. .

Looks like maximum number of DHCP client addresses varies depending on the license.Below links shows how to enable DHCP service on ASA.

http://www.cisco.com/c/en/us/td/docs/security/asa/asa82/configuration/guide/config/dhcp.html#wp1115485

Hope that helps

Regards

Najaf

Please rate when applicable or helpful !!!

123
Views
0
Helpful
2
Replies
CreatePlease login to create content