Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Asynchronous Interfaces

Hi Guys,

Please help with the following situation I am facing. I am implementing dial-up back up solution for DSL link. When the DSL link is down, the backup line comes up, meaning line protocol is up and traffic up to the router.

The issue is the dynamic routing does not work, all the routes are lost as soon as the backup line comes up. EIGRP is the routing protocol running on the router.

What is your thought guys? Thanks in advance.

5 REPLIES

Re: Asynchronous Interfaces

can you show me your configuration...?

how you configure backup... and what you have publish in routing protocol?

regards

Devang

Community Member

Re: Asynchronous Interfaces

Could this statement be the source of my problem since I using EIGRP. I found this on the Cisco website in a article on Configuring Asynchronous Interfaces and Lines.

"The async dynamic routing command routes IP packets on an asynchronous interface, which permits

you to enable the Interior Gateway Routing Protocol (IGRP), Routing Information Protocol (RIP), and

Open Shortest Path First (OSPF) routing protocols for use when the user makes a connection using the

ppp or slip EXEC commands. The user must, however, specify the /routing keyword at the SLIP or PPP

command line."

I will appreciate feeback on this.

Community Member

Re: Asynchronous Interfaces

Following is the configuration;

Branch office Router

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

interface FastEthernet0

description --------------------> NE LAN

ip address 192.9.x.x.255.255.0

speed auto

full-duplex

!

interface Serial0

description NE <--------------> Head Office

bandwidth 64

ip unnumbered FastEthernet0

ip directed-broadcast

encapsulation ppp

backup delay 180 180

backup interface Async2

compress stac

!

interface Async2

bandwidth 64

ip unnumbered FastEthernet0

encapsulation ppp

dialer in-band

dialer enable-timeout 10

dialer string 226301

dialer redial interval 30 attempts 10 re-enable 300

dialer-group 1

async mode interactive

compress stac

ppp chap hostname xxnort

ppp chap password xxx

!

router eigrp 145

network 192.9.20.0

network 192.9.200.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

no ip http server

dialer-list 1 protocol ip permit

- - - - - -- -- - - - -- -- --- -- - - - - -- - - - -

HQ Office Router part of the configuration

interface Group-Async1

bandwidth 56

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression

dialer in-band

dialer idle-timeout 600

dialer-group 1

async mode interactive

no peer default ip address

ppp authentication chap

ppp ipcp mask 255.255.255.0

ppp ipcp route default

group-range 34 48

routing dynamic

!

router eigrp 145

network 192.9.200.0

no auto-summary

!

router eigrp 100

network 192.9.198.0

auto-summary

!

ip local pool DIALIN 192.9.200.218 192.9.200.225

ip classless

ip route 192.168.2.0 255.255.255.0 192.212.200.1

------------------------------------------------------

I hope this help with troubleshooting.

Gold

Re: Asynchronous Interfaces

Since you are using IP unnumbered and have not included all the interfaces in your post its hard to say exactly what the issues is. Without all the addresses its hard to say if EIGRP will even form neighbors.

Verify that show EIGRP neighbor has a neighbor both when running on the serial line and on the backup.

Unless EIGRP is injecting a default route you will lose your default route when the serial line goes down since you route to the serial line. If you want to continute to use static put a second default static route in with a higher metric pointing to the dialup. This will allow you to still have a default route when the serial line is down.

Ip unnumbered tends to be a lot harder to troubleshoot. If your lan connection goes down you really won't know what the problem is since it will appear the WAN connection went down. Unless there is a reason not to I would eventually change this to use private addresses for your point to point. It makes configuration so much easier and you can just not advertise the private addresses if it will cause routing issues elsewhere in the network.

Re: Asynchronous Interfaces

Hi,

Since there is no issue with the Back-up interface config, we can safely shift our investigation to analyse whats wrong with the EIGRP Routing.

May I request you to paste the debug IP EIGRP events

whenever the Backup interface has kicked in.

Kindly rate if it helps.

Kind Regards,

Wilson Samuel

241
Views
0
Helpful
5
Replies
CreatePlease to create content