Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ATM link erroring

we've been working to isolate what has been causing the errors on the WAN.It has been tested to the DSU clean.

Can please someone check if there's any possible issue with the config?It's a

DS3 link.

Thanks

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

enable password cisco

!

voice-card 0

dspfarm

!

no aaa new-model

ip subnet-zero

ip cef

!

!

no ip domain lookup

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description

ip address 176.3.1.1 255.255.255.0

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface ATM1/0

mtu 1500

bandwidth 5000

no ip address

load-interval 30

atm scrambling cell-payload

no atm ilmi-keepalive

!

interface ATM1/0.1 point-to-point

description

ip address 172.32.1.2 255.255.255.0

pvc 2/33

vbr-nrt 5000 4000 100

oam-pvc manage 0

encapsulation aal5snap

!

!

router eigrp 110

redistribute connected

redistribute static

network 172.32.1.0 0.0.0.255

default-metric 64 100 250 250 1500

no auto-summary

!

ip http server

ip classless

!

!

access-list 1 permit 172.*.*.* 0.0.0.255

access-list 1 permit 172.*.*.* 0.0.0.255

access-list 1 permit 172.*.*.* 0.0.0.255

no cdp run

!

snmp-server community

snmp-server community

snmp-server host 10.*.*.*

snmp-server host 130.*.*.*

!

!

!

!

!

!

line con 0

exec-timeout 5 0

password

logging synchronous

login

line aux 0

exec-timeout 0 0

password

logging synchronous

login

modem InOut

transport input all

flowcontrol hardware

line vty 0 4

access-class 1 in

exec-timeout 5 0

password

logging synchronous

login

!

ntp clock-period 17207680

ntp server 172.31.10.2

!

end

2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

Re: ATM link erroring

Hi!

SFP mismatches mean a mismatch with LR / SR ( long-range/ short range ) etc. Did you try using an attuneor ? If you dont have it right now, try fitting in the cables loosely. Pull them out so that the link is just up ( dont insert the cable tightly. Sometimes the problem could arise due to a short cable length causing more power (light) to be transmitted saturating the rx interface. The best way to verify this problem is to measure the power recieved in the other end of the cable and checking whether it satisfies the power criteria for the interfaces. I donot remember the exact values ( have to be searched ).

Regards,

Niranjan

Hall of Fame Super Gold

Re: ATM link erroring

Hi, the point it that loopback alone is not enough sometime.

For the circuit to test clean, you need a bert testing with either controller loopback, or physical (tx to rx with cable).

Do this first, any serious telco must be able to do a bert testing.

17 REPLIES
Silver

Re: ATM link erroring

What is the config on the other side?

What are the errors seen?

Is the MTU on the other side too set to 1500, as the default mtu on ATM is not 1500.

Can you give the outputs of

sh int atmxxxx

sh controllers atm xxxx

sh atm int atm xxxx

Thanks,

Niranjan

Community Member

Re: ATM link erroring

Niranjan,

thank you for the assistance.

The other side's MTU is also 1500

here's the output

#sh controllers ATM1/0.1

Interface ATM1/0 is up

Hardware is RS8234 ATM DS3

LANE client MAC address is 0011.9355.3290

hwidb=0x82DEE034, ds=0x82DEF820

RS8234 base 40800000, ds 82DEF820, PM5346 base 40C00000, slave base 40C00000

SBDs - avail 2047, guaranteed 0, unguaranteed 2047, starved 0 rbds 4098

Seg VCC SCH access timeout 0

Seg VCC table 4080DD80, Shadow Seg VCC Table 82E1B2A4, VCD Table 82E312D0

Schedule table 40818D80, Shadow Schedule table 82E382FC, Size FC1

RSM VCC Table 4094F180, Shadow RSM VCC Table 82F3FCB0

VPI Index Table 4084C700, VCI Index Table 4084F180

Bucket2 Table 4082C900, Shadow Bucket2 Table 82E3C22C

MCR Limit Table 4082CD00, Shadow MCR Table 82E3DE58

ABR template 4082CF00, Shadow template 827FC748

RM Cell RS Queue 4084D180

RBD OIR array 82DF2598, HBD OIR array 82DF0598

LECID Table 4084CF00, Host LECID Table 82DF6F68, LECID Table Bitmask 0

Queue TXQ Addr Pos StQ Addr Pos

0 UBR 40848F00 0 079B4F80 0

1 UBR PLUS 40849300 0 079B5780 0

2 UBR TUN1 40849700 0 079B5F80 0

3 UBR TUN2 40849B00 0 079B6780 0

4 UBR TUN3 40849F00 0 079B6F80 0

5 ABR 4084A300 0 079B7780 0

6 VBR NRT 4084A700 97 079B7F80 96

7 VBR RT 4084AB00 0 079B8780 0

8 VBR/ABR TUN1 4084AF00 0 079B8F80 0

9 VBR/ABR TUN2 4084B300 0 079B9780 0

10 VBR/ABR TUN3 4084B700 0 079B9F80 0

11 SIG 4084BB00 0 079BA780 0

12 CBR 4084BF00 0 079BAF80 0

13 VPD 4084C300 0 079BB780 0

Queue FBQ Addr Pos RSQ Addr Pos

0 OAM 4095B180 255 079BC040 0

1 UBR 4095C180 0 079BD040 0

2 UBR PLUS 4095D180 0 079BE040 0

3 UBR TUN1 4095E180 0 079BF040 0

4 UBR TUN2 4095F180 0 079C0040 0

5 UBR TUN3 40960180 0 079C1040 0

6 ABR 40961180 0 079C2040 0

7 VBR NRT 40962180 240 079C3040 16

8 VBR RT 40963180 0 079C4040 0

9 VBR/ABR TUN1 40964180 0 079C5040 0

10 VBR/ABR TUN2 40965180 0 079C6040 0

11 VBR/ABR TUN3 40966180 0 079C7040 0

12 SIG 40967180 0 079C8040 0

13 CBR 40968180 0 079C9040 0

Community Member

Re: ATM link erroring

PCI bus err 0, DMA fifo full err 0, RSM parity err 0

RSM sync err 0, RSM/SEG Q full err 0, RSM overflow err 0

RSM stat Q full err 0, no free buff Q err 0, RSM ignore rbd CPI count 0

RSM ignore rbd CPI&PAD count 0, RSM ignore rbd abort count 0

RSM ignore rbd unknown count 0, pdu_check flag 0x0, error flag 0x0

SEG stat Q full err 0, SEG underflow err 0

Framer Chip Type PM7345

Framer Chip ID 0x20

Framer State RUNNING

--More-- Defect Status NO ERRORS

Loopback Mode NONE

Clock Source INTERNAL (but the source of this clock is derived from LINE)

DS3 Scrambling ON

Framing DS3 C-bit direct mapping

TX cells 77718531

TX bytes 4119082143

Last output time 3d15h

RX cells 38572497

RX bytes 3244131389

Last input time 3d15h

Line Code Violations (LCV) 172811929

DS3: F/M-bit errors 2699395

DS3: parity errors 419

DS3: path parity errors 319

DS3/E3: G.832 FEBE errors 28499419

T3/E3: excessive zeros 172707266

uncorrectable HEC errors 82

idle/unassigned cells dropped 0

LCV errored secs 2637

DS3: F/M-bit errored secs 2645

DS3: parity errored secs 12

DS3: path parity errored secs 12

T3/E3: excessive zeros errored secs 2637

DS3/E3: G.832 FEBE errored secs 3040

uncorrectable HEC errored secs 9

LCV error-free secs 311244

DS3: F/M-bit error-free secs 311236

DS3: parity error-free secs 313869

DS3: path parity error-free secs 313869

T3/E3: excessive zeros error-free secs 311244

DS3/E3: G.832 FEBE error-free secs 310841

uncorrectable HEC error-free secs 313872

Community Member

Re: ATM link erroring

PM 7345 registers (base 0x40C00000):

cfgr 0x00, ier 0x08, isr 0x00, ctlr 0x00,

imrr 0x21, dlcr 0xF8, rboc_cier 0x38, rboc_isr 0x3F,

t3frmr_cfgr 0x01, t3frmr_ier 0x03, t3frmr_isr 0x00, t3frmr_statr 0x20,

rfdl_cfgr 0x84, rfdl_esr 0x80, rfdl_statr 0x87, rfdl_datar 0x87,

pmon_pmr 0x00, pmon_iesr 0x03, pmon_lcvec0r 0x00, pmon_lcvec1r 0x00,

pmon_fbeec0r 0x00, pmon_fbeec1r 0x00, pmon_sezdc0r 0x00, pmon_sezdc1r 0x00,

pmon_peec0r 0x00, pmon_peec1r 0x00, pmon_ppeec0r 0x00, pmon_ppeec1r 0x00,

pmon_febeec0r 0x00, pmon_febeec1r 0x00, t3tran_cfgr 0x07, t3tran_diagr 0x00,

xfdl_cfgr 0xC0, xfdl_isr 0xC2, xfdl_txdatar 0xC0, xboc_coder 0xFF,

splr_cfgr 0x00, splr_ier 0x00, splr_isr 0x00, splr_statr 0x02,

splt_cfgr 0x00, splt_ctlr 0x00, splt_diagr 0x00, splt_f1r 0x00,

cppm_locmr 0xFC, cppm_copmr 0xF0, cppm_b1ec0r 0x00, cppm_b1ec1r 0x00,

cppm_feec0r 0x00, cppm_feec1r 0x00, cppm_febec0r 0x00, cppm_febec1r 0x00,

cppm_hcsec0r 0x00, cppm_hcsec1r 0x00, cppm_iucc0r 0xFF, cppm_iucc1r 0xFF,

cppm_rcc0r 0x4D, cppm_rcc1r 0x01, cppm_tcc0r 0x03, cppm_tcc1r 0x0E,

rxcp_ctlr 0x2C, rxcp_frcr 0x01, rxcp_iesr 0x00, rxcp_iucph1r 0x00,

rxcp_iucph2r 0x00, rxcp_iucph3r 0x00, rxcp_iucph4r 0x01, rxcp_iucmh1r 0xFF,

rxcp_iucmh2r 0xFF, rxcp_iucmh3r 0xFF, rxcp_iucmh4r 0xFF, rxcp_upcph1r 0x00,

rxcp_upcph2r 0x00, rxcp_upcph3r 0x00, rxcp_upcph4r 0x00, rxcp_upcmh1r 0xFF,

rxcp_upcmh2r 0xFF, rxcp_upcmh3r 0xFF, rxcp_upcmh4r 0xFF, rxcp_hcscsr 0xFC,

rxcp_lctctr 0xB4, txcp_ctlr 0xA4, txcp_iesr 0x18, txcp_iucph1r 0x00,

txcp_iucph2r 0x00, txcp_iucph3r 0x00, txcp_iucph4r 0x01, txcp_iucph5r 0x52,

txcp_iucpr 0x00, e3frmr_foptr 0x00, e3frmr_moptr 0x00, e3frmr_fier 0x00,

--More-- e3frmr_fiisr 0x01, e3frmr_meier 0x00, e3frmr_meiir 0x00, e3frmr_mesr 0x00,

e3tran_foptr 0x00, e3tran_sdoptr 0x03, e3tran_bip8emr 0x00, e3tran_maoptr 0x00,

ttb_ctlr 0x04, ttb_ttisr 0x00, ttb_iar 0x00, ttb_idr 0x00,

ttb_eptlr 0x00, ttb_ptlcsr 0x00, sffpcsr 0x31, pcr 0x30,

Community Member

Re: ATM link erroring

here's the sh run at the other side......

version 12.2

service timestamps debug datetime localtime show-timezone

service timestamps log datetime localtime show-timezone

service password-encryption

!

hostname

!

enable secret

!

ip subnet-zero

!

!

no ip domain-lookup

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description

ip address 192.168.80.2 255.255.255.0

speed 10

full-duplex

no cdp enable

!

interface ATM1/0

mtu 1500

no ip address

load-interval 30

atm scrambling cell-payload

atm framing cbitplcp

no atm ilmi-keepalive

!

interface ATM1/0.1 point-to-point

description

bandwidth 5000

ip address 172.32.1.1 255.255.255.0

pvc 1/32

vbr-nrt 5000 4000 100

oam-pvc manage 0

encapsulation aal5snap

!

!

!

router eigrp 110

redistribute rip

network 172.32.1.0 0.0.0.255

network 172.32.2.0 0.0.0.255

default-metric 64 100 250 250 1500

no auto-summary

!

router rip

version 2

redistribute static

redistribute eigrp 110

network 192.168.80.0

default-metric 1

no auto-summary

!

ip classless

ip route 176.3

ip http server

!

no cdp run

snmp-server community

snmp-server community

snmp-server enable traps tty

snmp-server host

snmp-server host

!

dial-peer cor custom

!

!

!

!

line con 0

exec-timeout 5 0

password

logging synchronous

login

line aux 0

exec-timeout 0 0

password

logging synchronous

login

modem InOut

transport input all

flowcontrol hardware

line vty 0

access-class 1 in

exec-timeout 0 0

password

logging synchronous

login

line vty 1 4

access-class 1 in

exec-timeout 5 0

password

logging synchronous

login

!

ntp clock-period 17208108

ntp server ******

end

Silver

Re: ATM link erroring

Line Code Violations (LCV) 172811929 <<<<

DS3: F/M-bit errors 2699395 <<<

DS3: parity errors 419

DS3: path parity errors 319

DS3/E3: G.832 FEBE errors 28499419 <<<<<

T3/E3: excessive zeros 172707266 <<<<<

Have you checked the power on the line? Can you use a attinuator and check? Check for the interface type/ SFP mismatches.

check for the power recieved and if it is saturating the other interface.

this is a good pointer :

http://www.cisco.com/en/US/products/hw/modules/ps2033/products_tech_note09186a00801087d0.shtml

Regards,

Niranjan

Community Member

Re: ATM link erroring

Niranjan,

thank you very much??

can you be please a little more specific??

SFP mismatches???

what could be suspected on this issue??specifically..

Is there way to have it fixed by changing some

configs??

Thanks a lot...

Silver

Re: ATM link erroring

Hi!

SFP mismatches mean a mismatch with LR / SR ( long-range/ short range ) etc. Did you try using an attuneor ? If you dont have it right now, try fitting in the cables loosely. Pull them out so that the link is just up ( dont insert the cable tightly. Sometimes the problem could arise due to a short cable length causing more power (light) to be transmitted saturating the rx interface. The best way to verify this problem is to measure the power recieved in the other end of the cable and checking whether it satisfies the power criteria for the interfaces. I donot remember the exact values ( have to be searched ).

Regards,

Niranjan

Community Member

Re: ATM link erroring

Niranjan,

thank you verymuch for the advise....

We'll try working on it with your advise...

Hall of Fame Super Gold

Re: ATM link erroring

Hi, your DS3 interface being of the electrical type does not use optical module or cables.

The errors seen are likely due to a faulty circuit and you should have the SP fix it.

Hope this helps, please rate post if it does!

Community Member

Re: ATM link erroring

Mr. Bevilacqua,

thank you very much for the advise.

How can you tell by looking at my outputs

that they are electrical type or not optical module or cables...

I'm sorry, I'm not that technical...

You mean to say the electrical signals are not too strong or low which has been probably causing the errors??

We tested it again last night for 4 hours...

Up to DSU, it was clean....it's already very critical...

I would appreciate if you would be able to give me more advise and maybe more specific...

Again, thank you

Hall of Fame Super Gold

Re: ATM link erroring

E3/T3 are always electrical, with coaxial BNC connectors. How long is the cable to the DSU, perhaps the singal is too "hot" and you could try an attenuator inline.

Community Member

Re: ATM link erroring

DS3 cable is just 1m.

We shut down the LAN port and did the ping test the other night, it was OK.But when we

started to run the traffic, the ping drops started again.

We've been observing AAL5 length violations on the CE.

We're running out of options...

Is the attenuator a good option?

If the signal is too hot, why do we have it clean when we have the LAN port shutdown.

Thank you very much for assistance..

Hall of Fame Super Gold

Re: ATM link erroring

Hi, circuits may show clean but start giving trouble as soon traffic is present.

Search for "bnc inline attenuator", you don't need the expensive ones, anything will do.

That will not fix the issue if the circuit is indeed faulty. To prove this you would need telco do a bert testing, comparing results with DSU loopback and router controller loopback.

Community Member

Re: ATM link erroring

thank you very much for the assistance.

does it make sense that we're tested it clean

from the carrier node with a remote loop from our CE for hours, and still we did not see anything suspicious.No cell drops at the carrier's switch.

Is there any concrete explanation why those stong/weak signal caused errors were'nt pick

up by our previous tests...

They just started throwing questions at me now...I suspected in the beginning of the stong signals, I just did not have enough knowledge to explain and convince them...

Hall of Fame Super Gold

Re: ATM link erroring

Hi, the point it that loopback alone is not enough sometime.

For the circuit to test clean, you need a bert testing with either controller loopback, or physical (tx to rx with cable).

Do this first, any serious telco must be able to do a bert testing.

Community Member

Re: ATM link erroring

thank you very much for the help...

190
Views
0
Helpful
17
Replies
CreatePlease to create content