Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ATM problems on IOS upgrade

Hi all,

I want to upgrade my 7200 ios from the image c7200-is-mz.121-14.E10.bin

to the newer c7200-is-mz.123-20.bin and the problem I'm facing is that

after i boot with the 12.3 all of the ATM interfaces remain down down.

I wonder if newer image require some extra command to get the atm interfaces

up and running.

As I boot with my old 12.1 everything go up again

I paste the configuration concerning the ATM interface,

ima group ,PVC and the show int atm .

Thanks in advance for any advice.

Regards,

Marco.

!

interface ATM2/0

no ip address

scrambling cell-payload

framing crc4adm

ima-group 1

!

interface ATM2/1

no ip address

scrambling cell-payload

framing crc4adm

ima-group 1

!

interface ATM2/ima1

mtu 1500

bandwidth 8000

no ip address

no atm auto-configuration

no atm ilmi-keepalive

!

interface ATM2/ima1.111 point-to-point

ip address

pvc 10/111

ubr 1536

oam-pvc manage

encapsulation aal5snap

!

!

interface ATM2/ima1.121 point-to-point

ip address

pvc 10/121

ubr 1536

oam-pvc manage

encapsulation aal5snap

!

!

interface ATM2/ima1.131 point-to-point

ip address

pvc 10/131

ubr 1536

oam-pvc manage

encapsulation aal5snap

!

****** with 12.3 IOS the interface is down

ATM2/0 is down, line protocol is down

Hardware is IMA PA

MTU 4470 bytes, BW 1920 Kbit, DLY 20000 usec,

reliability 0/255, txload 0/255, rxload 1/255

Encapsulation UNKNOWN, loopback not set

Encapsulation(s): AAL5

511 maximum active VCs, 0 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

0 carrier transitions

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

***** with the 12.1 IOS the interface is UP and the keepalive set is shown.

7200B#show int atm2/0

ATM2/0 is up, line protocol is up

Hardware is IMA PA

MTU 4470 bytes, BW 1920 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation UNKNOWN, loopback not set

Keepalive set (10 sec)

Encapsulation(s): AAL5

512 maximum active VCs, 0 current VCCs

VC idle disconnect time: 300 seconds

1 carrier transitions

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

1 REPLY

Re: ATM problems on IOS upgrade

Hello Marco,

try and set the keepalive manually on your ATM interface:

interface ATM2/0

--> keepalive 10

I am not sure why, but in 12.3, this might be the default (no keepalive on the interface)...

HTH,

GNT

118
Views
0
Helpful
1
Replies
CreatePlease to create content