Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

auto negotiate

Hi All,

we really faced a strange issue today. We had Cisco 878 and a firewall behind it. PPPoE was configured on the Firewall and the Cisco was configured in bridge mode.

The problem was : Firewall was only able to dial PPPoE when the negotiation was set to 10mbps halfduplex

                           Firewall when set to auto negotiate it would set itself to 100Mbps full duplex but can not dial PPPoE

Resolution: we disabled the spanning tree on vlan 1

Config :

!        

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

bridge-group 1

pvc 8/35

  encapsulation aal5snap

!

interface Vlan1

no ip address

no ip route-cache

bridge-group 1

bridge-group 1 spanning-tree disabled

!

Question: why disabling the spanning tree on bridge group 1 on vlan 1 resolved the issue.

Your quick resonse is appreciated.

Regards,

Ravindra

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

auto negotiate

Ravindra,

I do not see any reason why disabling the STP on the bridge-group should resolve the issue. The only thing I can currently think of is that with STP, it may take 30 seconds for the individual port to become Forwarding. If your PPPoE experiments were performed too hastily, they may have failed because of the ports needing more time to go over Listening and Learning into Forwarding.

Was the bridge-group command available only on SVI and not on physical switchports?

Best regards,

Peter

2 REPLIES
Cisco Employee

auto negotiate

Ravindra,

I do not see any reason why disabling the STP on the bridge-group should resolve the issue. The only thing I can currently think of is that with STP, it may take 30 seconds for the individual port to become Forwarding. If your PPPoE experiments were performed too hastily, they may have failed because of the ports needing more time to go over Listening and Learning into Forwarding.

Was the bridge-group command available only on SVI and not on physical switchports?

Best regards,

Peter

New Member

auto negotiate

Hi Peter,

I think that is what we saw. the firewall is trying to reconnect to the PPPoE and it times out after 30 seconds, in the mean time the STP does not come up and it fails.

But still once the port is in forwarding state, it should allow to send the traffic through it. However it failed.

But after disabling it worked fine.

Regards,

Ravindra

343
Views
0
Helpful
2
Replies
CreatePlease to create content