Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Auto QoS on Metro Ethernet with 2911 Routers

Hi all,

We use a somewhat unique Metro Ethernet WAN, in which all links are 12Mbps, point to point metro ethernet links, but connected between two 2911 ISR G2 routers, rather than switches.  These routers are connected to 3750 stacks on the LAN side.

We are setting up Cisco VoIP, and while all of our LAN switches have the proper Auto QoS statements ("auto qos voip cisco-phone" on access ports, and "auto qos voip trust" on trunk ports, including the ports connecting to the router), it does not appear that any of these settings can be applied to the router's gigabit ethernet interfaces.  A separate VLAN has been set up for our voice subnet already at our pilot site. 

My research thus far appears to indicate that auto QoS cannot be applied to ethernet interfaces on a router in general.  Our carrier does not strip or filter out any qos markings, but setting up switch-to-switch connections is not currently feasible in the scope of the project right now.

Am I simply out of luck with using Auto QoS in our current topology?  Is there a way to trunk voice traffic, with the QoS mrakings from the switch, through the router itself?

Thank you for any help.

  • WAN Routing and Switching
Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

Re: Auto QoS on Metro Ethernet with 2911 Routers

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

You're off to a good start.

If your logical bandwidth is only 12 Mbps, you probably should shape for that and use a subordinate policy to prioritize your VoIP.  (Actually, if you can, you might consider running both interfaces physically at 10 Mbps - QoS works a bit better with the physical bandwidth of an interface rather than using a shaper.)

I would also recommend enabling FQ in class-default, for all your other non-VoIP traffic, and for traffic-like VoIP, you normally use LLQ.

E.g.

policy-map ShapeMetroE

class class-default

!you may need to shape lower than nominal 12 Mbps to allow for L2 overhead

!I've set to 10 Mbps to insure shaper controls bandwidth

!so we can insure priority treatment for VoIP

shape average 10000000

service-policy VoIP

policy-map VoIP

class VOIP

priority percent 30

class class-default

fair-queue

int g0/1

service-policy output ShapeMetroE

tx-ring-limit 3 !shouldn't be needed with a shaper - but if you do set interface to 10 Mbps

3 REPLIES
Cisco Employee

Re: Auto QoS on Metro Ethernet with 2911 Routers

Hi Mike,

You don't really need QoS on the LAN facing interface. The router trust QoS setting by default. However, you should config QoS on the metro-E interface, and you need to use H-QoS on that interface.
http://www.cisco.com/en/US/docs/ios-xml/ios/qos_hrhqf/configuration/15-mt/qos-hrhqf.html

HTH,
Lei Tian

Sent from Cisco Technical Support iPhone App

New Member

Re: Auto QoS on Metro Ethernet with 2911 Routers

Thank you, I figured it would be a little more involved than Auto QoS.

So, given a Cisco Call Manager System, and Cisco 2911 Routers with Metro Ethernet circuits between them, would something similar to the following configuration (done on my lab router) be the way to go?  I arbitrarily picked 30 percent of a link as the bandwidth.

I attempted to match the class-map of VOIP to VLAN 120, but it did not like that when I ultimatley applied it to Gig0/1.  Thus, I've changed it to match the RTP protocol.

!

class-map match-all VOIP

  description Voice QoS Class Map

match protocol rtp audio

!

policy-map VoIP

class VOIP

  bandwidth percent 30

!

!

!

interface GigabitEthernet0/0

description DATA VLAN

ip address 10.10.10.1 255.255.0.0

duplex auto

speed auto

!

interface GigabitEthernet0/0.120

description VOICE VLAN

encapsulation dot1Q 120

ip address 10.120.0.1 255.255.0.0

!

interface GigabitEthernet0/1

description METRO ETHERNET

ip address 10.40.1.1 255.255.255.0

duplex auto

speed auto

service-policy output VoIP

!

!

end

Super Bronze

Re: Auto QoS on Metro Ethernet with 2911 Routers

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

You're off to a good start.

If your logical bandwidth is only 12 Mbps, you probably should shape for that and use a subordinate policy to prioritize your VoIP.  (Actually, if you can, you might consider running both interfaces physically at 10 Mbps - QoS works a bit better with the physical bandwidth of an interface rather than using a shaper.)

I would also recommend enabling FQ in class-default, for all your other non-VoIP traffic, and for traffic-like VoIP, you normally use LLQ.

E.g.

policy-map ShapeMetroE

class class-default

!you may need to shape lower than nominal 12 Mbps to allow for L2 overhead

!I've set to 10 Mbps to insure shaper controls bandwidth

!so we can insure priority treatment for VoIP

shape average 10000000

service-policy VoIP

policy-map VoIP

class VOIP

priority percent 30

class class-default

fair-queue

int g0/1

service-policy output ShapeMetroE

tx-ring-limit 3 !shouldn't be needed with a shaper - but if you do set interface to 10 Mbps

1967
Views
4
Helpful
3
Replies
This widget could not be displayed.