Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

automatic WAN fail-over

Looking for the right solution for automatic WAN failover for a small office that has T1 and DSL WAN connections.

I understand that route metrics can be used to switch connections if an interface physical fails, but is there anyway to achieve the same goal if something further upstream on one of the connections fails?

I'm looking for something a little more robust than interface-down fail-over and any suggestions would be appreciated. I am concerned with outbound only traffic, so no need to worry about inbound.

thanks.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: automatic WAN fail-over

Hi,

You can go for reliable static route object tracking if your ISP allows you to do so.

Please check the following link.

http://www.cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html

HTH, Please rate if it does.

-amit singh

Purple

Re: automatic WAN fail-over

Here's a config I have used successfully to achieve this:

Replace with an IP that you can ping through your main link - preferably the ISP side of the WAN link address.

interface Ethernet 0/0

description Primary Link

ip address 10.1.1.1 255.0.0.0

!

interface Serial0:1

description Backup Link

ip address 192.168.1.1 255.0.0.0

!

rtr 1

type echo protocol ipIcmpEcho

timeout 1000

frequency 3

threshold 2

!

rtr schedule 1 life forever start-time now

!

track 100 rtr 1 reachability

!

access list 101 permit icmp any host echo

!

route map LOCAL_POLICY permit 10

set ip next-hop 10.1.1.254

set interface null0

!

ip local policy route-map LOCAL_POLICY

!

ip route 0.0.0.0 0.0.0.0 10.1.1.254 track 100

ip route 0.0.0.0 0.0.0.0 192.168.1.254 254

Hope that helps - pls rate the post if it does.

Paresh

12 REPLIES
New Member

Re: automatic WAN fail-over

Try Cisco OER option

Re: automatic WAN fail-over

Hi,

You can go for reliable static route object tracking if your ISP allows you to do so.

Please check the following link.

http://www.cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html

HTH, Please rate if it does.

-amit singh

New Member

Re: automatic WAN fail-over

If I'm reading this right it is just what I'm looking for:

Basically an ICMP ping test to a specified host/gateway, which if fails the routing table is updated to use the back up link.

I have to reread again to make sure I have this right and if so will rate accordingly.

Thanks!

Purple

Re: automatic WAN fail-over

Here's a config I have used successfully to achieve this:

Replace with an IP that you can ping through your main link - preferably the ISP side of the WAN link address.

interface Ethernet 0/0

description Primary Link

ip address 10.1.1.1 255.0.0.0

!

interface Serial0:1

description Backup Link

ip address 192.168.1.1 255.0.0.0

!

rtr 1

type echo protocol ipIcmpEcho

timeout 1000

frequency 3

threshold 2

!

rtr schedule 1 life forever start-time now

!

track 100 rtr 1 reachability

!

access list 101 permit icmp any host echo

!

route map LOCAL_POLICY permit 10

set ip next-hop 10.1.1.254

set interface null0

!

ip local policy route-map LOCAL_POLICY

!

ip route 0.0.0.0 0.0.0.0 10.1.1.254 track 100

ip route 0.0.0.0 0.0.0.0 192.168.1.254 254

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: automatic WAN fail-over

Sir,

I am desperately looking for a solution for auto fallback from Ethernet to Dialer, since Ethernet never goes down with the help of floating static route dialer doesn't fire. When I was going thru your post, I think it would work for me a great instant.

I tried to implement this solution at one of location where Ethernet connectivity thru Radio is primary and ISDN is backup. The site having router 1721 and the ios is c1700-advsecurityk9-mz.123-5e.bin

But, In the router "rtr" commands doesn't support.

Can you pls tell me which IOS version support all the commands mentioned in your post.

I hope you understood my question.

Thanks in Advance

rgds,

Hardik..

Purple

Re: automatic WAN fail-over

Hi Hardik,

YOu might want to upgrade to at least 12.3(11)T - all of the feature sets in those releases support reliable static route backup...

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: automatic WAN fail-over

Thanks for your answer,

I am still having one problem !!

Let me explain the scenario. At my central side, Router ----> Ethernet Radio ----->

This Ethernet Radio is point to multipoint. Multiple locations are statically routed from central router towards Ethernet Radio.

I can apply above configuration(mentioned in post) to one of my far Radio's, What kind of configuration should i put to my central Router ? Since the router is having diff. subnets for diff far end Routers. Also I understand "ip local policy" can be applied only one time in a router. will it work without ip local policy ??

rgds,

Hardik..

Purple

Re: automatic WAN fail-over

Hi Hardik,

You can certainly use the reliable static route feature at the central in your case. Instead of tracking default routes, associate a different tracking object with each of your static routes. For your local policy, you can use something like the following:

route map LOCAL_POLICY permit 10

match ip address 101

set ip next-hop 10.1.1.254

set interface null0

!

access-list 101 permit ip any

access-list 101 permit ip any

access-list 101 permit ip any

...

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: automatic WAN fail-over

Thanks yet again !!

I will implement the same and will post the response.

rgds,

Hardik..

New Member

Re: automatic WAN fail-over

sorry some correction

Following cisco 1721 ios supports rtr command

c1700-entbasek9-mz.124-5.bin

New Member

Re: automatic WAN fail-over

Dear Sir,

I Really like your solution.

but i want to know two more things.

I tell you my scenario :

my commectivity is primary : Ethernet

Secondary : ISDN

my Ethernet remote site to first my Customer end Radio Device & then to POP Radio & from this it terminated to my router.

All are configured with static route.

Please replay me..

Thanks in Advance.

Yogesh

New Member

Re: automatic WAN fail-over

hi,

Amit is right, but when you are using FR based WAN FR- End to End keep alive (EEK) will help you.

for more details.....

http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a0080087a58.html

NOTE:plz vote if this helps.

Regards,

Akhtar

170
Views
33
Helpful
12
Replies
CreatePlease login to create content