Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Avaya IP phone and Cisco switch config

All,

    i am trying to find the best practice for setting up Avaya IP phones on a cisco network. In my experience in the Cisco VOIP world we would use the switchport voice vlan # due to the fact that cisco understands CDP. However, Avaya would use LLDP therefore two things would need to be considered:

1.  does the switch support CDP?

2.   would Switchport voice vlan # propagate to the phone once connected?

any insights would be appreciated it.

thanks,

JP

Everyone's tags (6)
7 REPLIES

Avaya IP phone and Cisco switch config

We have Avaya IP phones as well and Cisco 2960 switches.  Here is an example of port configuration:

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 2 4

mls qos srr-queue output cos-map queue 4 threshold 2 1

mls qos srr-queue output cos-map queue 4 threshold 3 0

mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47

mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7

mls qos queue-set output 1 threshold 1 138 138 92 138

mls qos queue-set output 1 threshold 2 138 138 92 400

mls qos queue-set output 1 threshold 3 36 77 100 318

mls qos queue-set output 1 threshold 4 20 50 67 400

mls qos queue-set output 2 threshold 1 149 149 100 149

mls qos queue-set output 2 threshold 2 118 118 100 235

mls qos queue-set output 2 threshold 3 41 68 100 272

mls qos queue-set output 2 threshold 4 42 72 100 242

mls qos queue-set output 1 buffers 10 10 26 54

mls qos queue-set output 2 buffers 16 6 17 61

mls qos

!

interface GigabitEthernet1/0/5

switchport access vlan 136

switchport trunk native vlan 136

switchport trunk allowed vlan 136,160

switchport mode dynamic desirable

switchport voice vlan 160

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

spanning-tree portfast

New Member

Avaya IP phone and Cisco switch config

User port: for example being connected to interface 1 on the switch. The user population is on VLAN 11

VoiceVlan: VLAN 12

Interface g0/1:  Trunk port to another switch on the network.

Interface f0/1

Switchport mode access

Switchport access vlan 11

switchport voice vlan 12

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 1,11,12 and etc ( the voice VLAN will also have to be added to the trunk list)

switchport mode trunk

   i would not need the switchport trunk native vlan correct?   Avaya should be using option 176 or 242 and i can create a custom string for the L2Q and L2QVLAN. please advice.

Avaya IP phone and Cisco switch config

My trunks are configured like this:

interface GigabitEthernet1/0/49

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

end

!

interface GigabitEthernet1/0/50

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

end

Yes you will have to add the Voice VLAN if you are securing the trunks that way.  And we are using DHCP option 242

Avaya Phones and most other

CDP is cisco propriety LLDP is an open standard; Avaya Phones and most other IP phone suppliers support LLDP.

New Member

Hello. Will this also work

Hello. Will this also work with a Cisco 4507R+E?

Avaya IP phone and Cisco switch config

Oh and certain show CDP neighbor does not show the Avaya IP phones.

New Member

Avaya IP phone and Cisco switch config

User port: for example being connected to interface 1 on the switch. The user population is on VLAN 11

VoiceVlan: VLAN 12

Interface g0/1:  Trunk port to another switch on the network.

Interface f0/1

Switchport mode access

Switchport access vlan 11

switchport voice vlan 12

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 1,11,12 and etc ( the voice VLAN will also have to be added to the trunk list)

switchport mode trunk

   i would not need the switchport trunk native vlan correct?   Avaya should be using option 176 or 242 and i can create a custom string for the L2Q and L2QVLAN. please advice.

18786
Views
0
Helpful
7
Replies
CreatePlease login to create content