Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Back to Back T1 config help

I have 2 routers, a 3640 with a t1 interface and a 2524 with a t1 interface. I made a back to back cable so that I could try to configure a test connection between the 2 routers. When I get them all turned on and configured I see the interfaces registered as Up/Down and I see alot of interface resets. Attached are the 2 configs... any ideas would be greatly appreciated.

2524 config:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

!

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

bandwidth 1500000

ip address 192.168.1.2 255.255.255.0

no fair-queue

service-module t1 timeslots 1-24

!

interface Serial1

no ip address

shutdown

!

ip http server

ip classless

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

3640 Config:

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

!

memory-size iomem 20

ip subnet-zero

!

!

!

ip audit notify log

ip audit po max-events 100

!

call rsvp-sync

!

!

!

!

!

!

controller T1 1/0

framing esf

clock source internal

linecode b8zs

channel-group 1 timeslots 1-24

!

controller T1 1/1

framing sf

linecode ami

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface FastEthernet1/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0:1

bandwidth 1500000

ip address 192.168.1.1 255.255.255.0

!

ip classless

no ip http server

!

!

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

Thanks everyone,

LR

2 REPLIES
Green

Re: Back to Back T1 config help

A T1 crossover cable should be a UTP / Cat5(5e, 6) with pins 1&2 --> 4&5 on each end.

Like:

1 -->>4

2 -->>5

4 -->>1

5 -->>2

Make sure the cable is terminated properly and done well; een though the data rate is significantly less than Fast Ethernet, the signaling scheme for serial is sensitive to cable quality.

If you're talking about something like a 60pin --> 60 pin back-to-back cable, make sure you have the DCE end going to the router with the DCE role (and DTE to the DTE-side router). There (should be) are labels on each end of the cable to identify which end is which.

You can also do a "sh controllers" which should tell you what the router thinks the cable is.

Good Luck

Scott

Silver

Re: Back to Back T1 config help

Off the 2524 router I see no framing and coding. if it is default it may not show it, however just need to ask if it was set for ESF/B8ZS. Also I see the clocking is set for Internal on one rouer and the other should be set for external timing. Again it may be default and may not be shown on the config. Also a show controllers will show any layer 1 errors (Red alarm, Yellow Alarm, etc...) Maybe your T-1 crossover cable is faulty...Just some items to check....

107
Views
0
Helpful
2
Replies
CreatePlease to create content