Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

bandwidth limiting

Hi Guys,

hope this finds you all well.

I have a 3845 Router with three connected interfaces, one to my WAN, one to my LAN and another to my wifi zone. I want to limit the amount of WAN bandwidth the WIFI zone can take to say a max of one third and not restrict WAN bandwidth from the LAN at all.

Is this possible?

Thanks,

Paul

7 REPLIES

bandwidth limiting

Hi Paul ,

You can use CAR on the interface to Wifi zone.

Interface x/y

rate-limit input ...

rate-limit output ...

or CB policing

policy-map WIFI-IN

class class-default

   police cir 20000

policy-map WIFI-OUT

class class-default

   police cir 20000

int x/x

service-policy WIFI-IN in

service-policy WIFI-OUT out

Dan

New Member

bandwidth limiting

Hi Dan,

thanks for the reply. I'd like to keep this as simple as possible so here goes;

So assuming my wan bandwidth is 50meg and I want to limit wifi to 1/4 (12.5meg) of this then on my wifi interface I do the following:

int gi 0/0

rate-limit input 12500000 ( bits per sec )

rate-limit output 12500000

So now wifi connected via gi 0/0 can only download a max of 12.5meg/sec and the same for uploading.

Is this correct?

Thanks again,

Paul

bandwidth limiting

Hi Paul ,

I suppose that you have also some traffic from WIFI to LAN is that correct.

Because with this configuration you will limit all the traffic from WIFI

Dan

New Member

bandwidth limiting

Hi Dan,

I see your point. Is there a better solution?

Thanks,

Paul

Re: bandwidth limiting

Yes , using CAR with access-list , and dening the traffic from WIFI to LAN.

rate-limit input access-group 100

rate-limit output access-group 101

ip access-list extended 100

deny ip wifi-net lan-net

permit ip any any

ip access-list extended 101

deny ip lan-net wifi-net

permit ip any any

Dan

New Member

Re: bandwidth limiting

Hi Dan,

so it doesn't matter about wifi to lan traffic. Here is the config I'm using:

rate-limit output 3000000 562500 1125000 conform-action transmit exceed-action drop

rate-limit input 3000000 562500 1125000 conform-action transmit exceed-action drop

How does it look to you?

I don't really understand the "Normal burst bytes" and "Maximum burst bytes" terms but I followed a post and calculated these as follows:

Normal burst bytes = configured rate/8 * 1.5 seconds

Maximum burst bytes = configured rate * 2

Am I limiting the bandwidth up and down to 3meg?

Thanks,

Paul

Re: bandwidth limiting

Hi Paul,

Yes. You are using the recommanded values. Normal burst amoung of traffic in bytes send on each time interval ( 1.5 seconds ). Maximum burst is the exceeded traffic. You can disable this by setting Maximum burst to the Normal burst value. Even like this you have exceed-action drop.

Yes using those values you are limiting the traffic to 3mbps. You can check your rate-limiting with show interface Fa0/0 rate-limit

Dan

664
Views
0
Helpful
7
Replies
CreatePlease to create content