Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Basic BGP config PLZ help me

HI eveyone. I am perparing myself for CCNP. I am trying to do basic BGP config. but i am not able to do EBGP config with loopback interfaces.

R3(6100)------------------------>R4(5500)----------------------R5(6500)

R4(config)#int loop 4

R4(config-if)#ip address 4.4.4.4 255.255.255.255

R5(config)#int loop 5

R5(config-if)#ip address 5.5.5.5 255.255.255.255

Step 2 – Created static routes on each router to the new addresses


R4(config)#ip route 5.5.5.5 255.255.255.255 10.1.45.1

R5(config)#ip route 4.4.4.4 255.255.255.255 10.1.45.2

!--- By adding static route.

Step 3 – Configure BGP neighbors using eBGP multihop

R4(config)#router bgp 5500

R4(config-router)#neighbor 5.5.5.5 remote-as 6500

R4(config-router)#neighbor 5.5.5.5 update-source loopback 4

R4(config-router)#neighbor 5.5.5.5 ebgp-multihop 2

!--- Allows eBGP neighbor relationship with an IP address (loopback 5) 2 hops away

R5(config)#router bgp 6500

R5(config-router)#neighbor 4.4.4.4 remote-as 5500

R5(config-router)#neighbor 4.4.4.4 update-source loopback 5

R5(config-router)#neighbor 4.4.4.4 ebgp-multihop 2

In my BGP routing table, I got RIB failure for 5.5.5.5 and 4.4.4.4 loopback entry. In sh routing route, i can see 5.5.5.5 and 4.4.4.4 connected via static rotues. So there is rib failure in BGP. loopbacks are not learing route via BGP.  if i change AD on static route with AD 255 then route come into BGP and no more RIB failure. but still EBP ping doesnt work from internal router R3 to R5 because there is no static route.

Please help me. I am stuck here. As i can see in book and CBT nuggets that we use static routes and EBP multihop between EBP neigbhour. then network can ping. in my case if routing table has static route then RIB failure. if loopback with BGP then still nuthing work.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Basic BGP config PLZ help me

harjeet,

I'm not sure this is the problem but routers 4 and 5 are next to each other, thus not multiple hops away????

Tony

11 REPLIES
New Member

Basic BGP config PLZ help me

harjeet,

I'm not sure this is the problem but routers 4 and 5 are next to each other, thus not multiple hops away????

Tony

New Member

Basic BGP config PLZ help me

Hi tony

  R4-R5 are next to each other. but they are not directly connected BGP neighbours because they are connected via loopback ebgp config. so you have to use command ebgp multihop on EBGP config. i have posted all topology with detail below under cadet alain profile.

New Member

Re: Basic BGP config PLZ help me

do u have physical interfaces configured?

Sent from Cisco Technical Support iPhone App

Purple

Basic BGP config PLZ help me

Hi,

don't worry about the rib-failure, it simply means that the BGP table tried to inject this prefix into the RIB table but as it was learned via another protocol with a better AD, it couldn't.

To verify your eBGP peering between loopbacks: sh ip bgp summary and you should see a number at the far right side.

if you change your static route AD it means this route is not believable so it won't get installed in the RIB, don't do this as you need L3 connectivity to bring up your BGP peering.

Concerning R3 to R5: the first condition for a BGP prefix to be advertised and also to be installable in the RIB table is the next-hop must be reachable , you can verify it with the sh ip bgp output which should have a > sign on the far left side.

We don't have full BGP config here as there is no network or redistribute command so which prefix are you advertising?

for a ping from r3 to r5, you must advertise the r3-r4 subnet on r3 and the r4-r5 subnet on r5 because pinging from r3 will source the packet from r3-r4 interface.

So post following on all 3 routers:

- sh run | s bgp

- sh ip bgp summ

-sh ip bgp

-sh ip route

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Basic BGP config PLZ help me

HI Alain

  Thanks for reply. Sorry i didnt explain you whole  topology before. I am using GNS3 IOS 3600, I saw EBGP config with  loopback on cbt nugget video (Jeremy Cioara) and same on BSCI book. They  configured EBP connection with loopback ip address rather than directly  connected physical interfaces ip addresses. I did same as cbt.

R3----------(IBGP 6500)---------R2-----------(EBGP 6100)--------------R6      (TOPOLOGY)

There is EBGP connection between R2--R6 (EBGP 6100)  with loopback neighbors. According to lab, I configured static routes  between R2--R6 routers because loopbacks are not directly connected.  also i put command EBGP multihop 4.

FOr IBGP 6500 connection i have configured R3--R2 routers. config below

(R2)

interface Loopback3

ip address 2.2.2.2 255.255.255.0

router bgp 6500

  no synchronization

  bgp log-neighbor-changes

  network 2.2.2.0 mask 255.255.255.0

  neighbor 3.3.3.3 remote-as 6500

  neighbor 3.3.3.3 update-source Loopback3

  neighbor 3.3.3.3 next-hop-self

ip route 6.6.6.0 255.255.255.0 Serial1/1

(R3)

interface Loopback3

ip address 3.3.3.3 255.255.255.0

router bgp 6500

no synchronization

bgp log-neighbor-changes

network 3.3.3.0 mask 255.255.255.0

neighbor 2.2.2.2 remote-as 6500

neighbor 2.2.2.2 update-source Loopback3

For EBGP config R2----R6 are configured

(R2)

router bgp 6500

neighbor 6.6.6.6 remote-as 6100

neighbor 6.6.6.6 ebgp-multihop 4

neighbor 6.6.6.6 update-source Loopback3

(R6)

interface Loopback6

ip address 6.6.6.6 255.255.255.0

router bgp 6100

no synchronization

bgp log-neighbor-changes

network 6.6.6.0 mask 255.255.255.0

network 30.0.0.0 mask 255.255.255.0    -----------also loopback (30.0.0.1)

neighbor 2.2.2.2 remote-as 6500

neighbor 2.2.2.2 ebgp-multihop 4

neighbor 2.2.2.2 update-source Loopback6

ip route 2.2.2.0 255.255.255.0 Serial1/1

==========================================================

After all this configuration, it should work as i saw in jermay's video. but mine is not working.

There is sucessful ping between R2--IBGP--R3 and R2--EBGP--R6. but i cant ping from R3---R6.

R_3#sh ip bgp

BGP table version is 7, local router ID is 40.0.0.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*>i2.2.2.0/24       2.2.2.2                  0    100              0     i         -----  (IBGP route)

*> 3.3.3.0/24       0.0.0.0                  0               32768      i

*>i6.6.6.0/24       2.2.2.2                  0    100      0            6100  i  ------(EBGP route)

*>i10.0.0.0/24      2.2.2.2                  0    100      0            i

*>i30.0.0.0/24      2.2.2.2                  0    100      0           6100  i -------(EBGP advertised route)

*> 40.0.0.0/24      0.0.0.0                  0               32768     i

R_3#ping 6.6.6.6

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R_3#ping 30.0.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 30.0.0.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

==========================================================

R_6#sh ip bgp

BGP table version is 18, local router ID is 30.0.0.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

r> 2.2.2.0/24       2.2.2.2                  0             0         6500    i ----------(Rib failure)

*> 3.3.3.0/24       2.2.2.2                                0          6500   i

*> 6.6.6.0/24       0.0.0.0                  0                        32768 i

*> 10.0.0.0/24      2.2.2.2                  0             0        6500   i

*> 30.0.0.0/24      0.0.0.0                  0                       32768 i

*> 40.0.0.0/24      2.2.2.2                                0         6500   i

R_6#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R_6#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/23/32 ms

================================================================

R_2#sh ip bgp

BGP table version is 14, local router ID is 20.0.0.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 2.2.2.0/24       0.0.0.0                  0                  32768   i

*>i3.3.3.0/24       3.3.3.3                  0    100                0   i

r> 6.6.6.0/24       6.6.6.6                  0                         0  6100 i -------(Rib failure)

*> 10.0.0.0/24      0.0.0.0                  0                 32768   i

*> 30.0.0.0/24      6.6.6.6                  0                        0   6100 i

*>i40.0.0.0/24      3.3.3.3                  0    100               0   i

I can see BGP didnt inject route in routing table on R2--R6 because AD is good on static routes.

R_2#sh ip route

20.0.0.0/24 is subnetted, 1 subnets

C       20.0.0.0 is directly connected, Loopback2

     6.0.0.0/24 is subnetted, 1 subnets

S       6.6.6.0 is directly connected, Serial1/1 -----------static routes

     172.17.0.0/30 is subnetted, 1 subnets

R_3#traceroute 6.6.6.6

Type escape sequence to abort.

Tracing the route to 6.6.6.6

  1 172.16.2.1 20 msec 32 msec 20 msec (ip address of R2 interface directly connected to R3)

  2  *  *  *

Please advise me, why my network is not working. i did same as i saw in  CBT. Exactly same. Network is not pinging from R3--R6 and there is rib  failure on EBGP. I cant go ahead untill i fix this. i tried my best to explain it. if you need any info please ping me. waiting for reply.

Regards

harjeet

New Member

Basic BGP config PLZ help me

Harjeet,

think you were a bit early with the ratings, but I think you'll find you'll have a better result if you do an extended ping and use the source interface of the loopback.

Tony

New Member

Basic BGP config PLZ help me

HI tony

Thanks buddy, I could able to make extended ping from R3 to R6.

Now I could also make normal ping as well. what i did. In BGP table i added directly connected interfaces ip address of (R6, R2, R3). so when i ping from R3 to R6. R6 knows source ip address of packet which is R3 physical interfcae ip address. R6 can find source address in BGP routing table.

Bit still there is RIB failure in my EBGP connection because of static route. do you think this network is successfull in real world. when i remove static route between EBGP routers R2 -- R6 then i lost EBGP connectivity. then EBP goes to active state. 

New Member

Basic BGP config PLZ help me

Harjeet,

I think that Cadet Alain, response earlier in the thread spelt it out well, in regards to the RIB errors. It looks like it works to me, in that the loopback associated with the 30.0.0.1 also found it's way into R3 routing table. The only way that was going to happen is if BGP between R2 and R6 was working.

To make it real you might like to put filters on R6 to prevent  the 30.0.0.0 network from being sent to the AS6500 or maybe on the R2 to do the same thing.

Tony.

Basic BGP config PLZ help me

harjeet,

why would you need to advertise the loopbacks into BGP. You learn them via IGP or static routes to have NLRI reachability. once you are able to ping the loop back interfaces from each neigbor then you establish the BGP peering.

in regards to R3, you can have a BGP peering with R4 and then maybe you can advertise a couple of prefixes into BGP there and you should see them on R4 and R5.just make sure to have the next-hop self configured apprpriately

HTH

Kishore

Purple

Basic BGP config PLZ help me

Hi Kishore,

from the original post it seems all BGP peerings are eBGP so there's no need for next-hop-self.

Regards.

Alain

Don't forget to rate helpful posts.

Basic BGP config PLZ help me

True dat. just went blind for a while there..not enuff sleep alain

433
Views
0
Helpful
11
Replies
CreatePlease login to create content