Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

basic cisco 1800 config with cable/dsl modem

im not very familiar with routers/switch .. so need basic help.

i have a cisco 1800 router that i need to connect to calbe modem that is running in bridge mode.

all i was given by isp is ip address. gateway / mask

can i connect the 1800 directly to the cable modem or do i need a home router that would give ip address to the router interface?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: basic cisco 1800 config with cable/dsl modem

add this

ip dhcp exclude address 192.168.1.1 192;168.1.10

connect console to your router and then insert fa 0/1 cable in your laptop and enable

debug dhcp

debug ip dhcp server packet

show ip dhcp binding

Jawad

Jawad
13 REPLIES
Hall of Fame Super Gold

basic cisco 1800 config with cable/dsl modem

You can connect it directly.

If you do not have experience with cisco routers, get someone that has it, that will save you much time loss and frustration.

Otherwise for home use get a linksys router that is easy to to setup with GUI.

New Member

Re: basic cisco 1800 config with cable/dsl modem

thanks but ,,from what i gather its a simple config.. anybody else. .can help..     

dsl modem > (netgear modem doing natting/dhcp) >  1841 > WLC 2504

im just looking help configuring 1841.. thanks    

Re: basic cisco 1800 config with cable/dsl modem

Why u want to use 1841 all things are working fine.

What your plan the we can guide you better.

Jawad

Jawad
New Member

basic cisco 1800 config with cable/dsl modem

well

this is a new setup along with wlc,

not for home. i can get wlc support from cisco ,but they wont support router as its not under contract

so at the moment only modem and netgear router is working.

i was told wlc needs a layer 3 device to connect to modem. (so i found a old 1841 sitting around )

thus need to configure it.    

basic cisco 1800 config with cable/dsl modem

Make it simple

just give ips to router interfaces

enabling ip routing

also

give default router to netgear modem

ip route 0.0.0.0 0.0.0.0 (netgear Modem IP)

Jawad

Jawad
New Member

Re: basic cisco 1800 config with cable/dsl modem

, thanks for the help

i got the following config. am i correct in assuming, if i connect a laptop to f0/1 port with crossover, it should get an ip and show be able to get on the net without issue?  (cause i am not).. what do you think. he problem is i have the wlc 2504 connected to f0/1, however when i connect ap to wlc poe port they dont get ip.. (wlc is configured with routers f0/1 address as dhcp server address.

config below

Router#show run

Building configuration...

Current configuration : 1105 bytes

!

! Last configuration change at 19:25:56 UTC Thu Aug 15 2013

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

ip source-route

!

!

!

!

ip dhcp pool DHCP

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 64.59.144.90 64.59.150.136

!

!

ip cef

multilink bundle-name authenticated

!

!

license udi pid CISCO1841 sn FHK11462610

!

!

!

!

!

!

interface FastEthernet0/0

ip address

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

ip forward-protocol nd

!

!

no ip http server

ip nat inside source list

!

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

Router#

Re: basic cisco 1800 config with cable/dsl modem

sorry i didnot get your point

u mean it not working if u are connecting your pc to fa 0/1

if that the case

mentioned above u were telling u have isp modem that responsible for natting dhcp (am i rite or wrong)

hav u connected that to your router.

if you have connected to that to your router what that modem lan ip and wan ip.

second

ping

184.70.21.165

r u able to ping that......

leave wlc rite now start for scratch.

Jawad

Jawad
New Member

Re: basic cisco 1800 config with cable/dsl modem

i am getting 1841 to do natting (isp modem is working in bridged mode  (dpc3825)

""

ip nat inside source list 100 interface FastEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 184.70.21.165

""

this is working fine, as i can ping 8.8.8.8 from both 1841 and wlc, however problem im having is dhcp side of the config...

none of the device are getting dhcp ip address. if i connect a laptop to f0/1  (crossover) shouldn't it get a ip from router and be able to get on the net     ? as per statement below?   

"

ip dhcp pool DHCP

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 64.59.144.90 64.59.150.136

!

"

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

??

the issue here is the ap connected to wlc aren't getting ip from 1841, ... i dont see anything wrong with my config (pasted above)...

Re: basic cisco 1800 config with cable/dsl modem

when u attached your pc to fa 0/1 r u getting ip address

Jawad

Jawad
New Member

Re: basic cisco 1800 config with cable/dsl modem

no.. I'm not..

Re: basic cisco 1800 config with cable/dsl modem

add this

ip dhcp exclude address 192.168.1.1 192;168.1.10

connect console to your router and then insert fa 0/1 cable in your laptop and enable

debug dhcp

debug ip dhcp server packet

show ip dhcp binding

Jawad

Jawad

Re: basic cisco 1800 config with cable/dsl modem

Also your configuration seems ok

run this command

show ip interface bried

if u see both interface are administrative down then

go under each interface

interface fa 0/1

no shut

intface fa 0/0

no shut

***Do Rate Helpful Posts***

Jawad

Jawad
New Member

Re: basic cisco 1800 config with cable/dsl modem

it worked

think maybe i was missing below, i didnt exclude 1.1 add. could that be..

ip dhcp exclude address 192.168.1.1 192;168.1.10

i have it connected to wlc and ap via a switch. everything is working now. thanks Jawad.

1852
Views
0
Helpful
13
Replies
CreatePlease to create content