Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Basic EIGRP neighborship

Hello All,

In my experiment with EIGRP on a hub and spokes topology with three routers, i realized that once i configured one of the spokes to have neighbor (nei X.X.X.X int- name) relation with the hub, the second spoke is totally cut off from reaching even the hub's loopback address.

In order to ascertain what went wrong i went further to experiment the same on an Ethernet network, unfortunately i got the same result....have i done anything wrong or this is the normal behaviour of EIGRP?.

Unlike RIP where i was able to determined the types of updates on an interface by interface basis.

Your help to clarify my concerns shall be greatly appreciated.

Regards

7 REPLIES

Re: Basic EIGRP neighborship

No !!! this is not normal behaviour of EIGRP.

Definitely something is wrong with the configuration or interfaces.

Can you attach the config of all 3 routers. ??

New Member

Re: Basic EIGRP neighborship

Hello,

Thanks for the great response.

Here is the outputs as demanded. I hope it can help you to help me further?.

THE HUB ROUTER (R1)

interface Loopback0

ip address 1.0.0.1 255.0.0.0

interface Ethernet0/0

ip address 10.0.0.1 255.0.0.0

router eigrp 1

network 0.0.0.0

no auto-summary

neighbor 10.0.0.2 Ethernet0/0

THE SPOKE WITH NEIGHBORSHIP (R2)

interface Loopback0

ip address 2.0.0.2 255.0.0.0

interface Ethernet0/0

ip address 10.0.0.2 255.0.0.0

router eigrp 1

network 0.0.0.0

no auto-summary

neighbor 10.0.0.1 Ethernet0/0

THE SECOND SPOKE (R3)

interface Loopback0

ip address 3.0.0.3 255.0.0.0

!

interface FastEthernet0/0

ip address 10.0.0.3 255.0.0.0

router eigrp 1

network 0.0.0.0

no auto-summary

Re: Basic EIGRP neighborship

Hi newnetman,

Have you already tried adding this on the HUB router:

neighbor 10.0.0.3 Ethernet 0/0

Cheers:

Istvan

New Member

Re: Basic EIGRP neighborship

Hello Istan,

I did not add the neighbor statement on the hub for (R3) because that was exactly what i wanted to see the outcome of.

My aim was to see (R1)the hub send unicast update to (R2) while it send multicast update to (R3), as this was possible with RIP, isn't it possible with EIGRP?.

Thank you once again,

Re: Basic EIGRP neighborship

So what do we conclude here - when you configure a specific EIGRP neighbor and you include an interface name in the command, EIGRP then prevents that interface from forming dynamic neighborships? All other neighbors with Layer 2 connections through that same interface must be statically configured?

New Member

Re: Basic EIGRP neighborship

hello Sir,

Many thanks for clarifying my. I wonder then why the experimental question asked me to crate a neighborship with one of the spokes with the hub. Could that be to prevent the second spoke from the network, except for it directly connected interface to the hub?.

Thanks a million once again for the help

New Member

Re: Basic EIGRP neighborship

http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a008012dac4.shtml#ten

Note this part...

"The ideal behavior of this command is for EIGRP to start sending EIGRP packets as unicast packets to the specified neighbor, but not stop sending and receiving multicast packets on that interface. Since the command does not behave as intended, the neighbor command should be used carefully, understanding the impact of the command on the network."

191
Views
4
Helpful
7
Replies
CreatePlease to create content