Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

basic mpls VPN operation

Hi
I am trying to set up a basic lab on gns to have some hands on mpls VPN environment
I created an ISP cloud running OSPF and mpls between all the P and PE routers.
On the PE routers I created loop backs representing diff customers on different VRFs.
I am running bgp on the PE routers and can see the other side route learned via BGP. When I say other side I mean the other end PE has exactly the same set up with loopbacks in the respective VRFs. So say on one PE I have VRF A with lo1 and ip 192.168.1.1/24 and the other end has lo1 in VRF A with ip 192.168.2.1/24.

Now when I do sh ip route VRF A on one PE, I do see the other route learnt via bgp.

Now the issue is for some reason I cannot ping the other end. I can ping my local ip only.
I ran trace but it doesn't show any ip at all, all asterisks only.

I have a feeling I am missing something here.... I will send snapshot of the config very soon but I thought atleast I can put in the description of the issue.

Let me know if you have any suggestion in the meanwhile I get back with config details.

Reg
Mohit

Sent from Cisco Technical Support iPad App

8 REPLIES
New Member

basic mpls VPN operation

have you redistributed the routes???

Silver

basic mpls VPN operation

Could you post here the configs?

I suppose you configured MP-BGP VPNV4 between the PE's (from the /32 loopbacks which are known by the IGP) and LDP is working in the cloud.

Best Regards,

Jose.

New Member

Re: basic mpls VPN operation

Hi guys

Sorry for the late reply.
I did fixed the problem late last night so did not get time to send the config out.

I still need to confirm what were the root cause and would let you know here.
However, just a quick Q, how is the below different to each other?
Address-family vpnv4
And
Address-family vpnv4 unicast

I do remember missing the unicast keyword when I activate neighbour for the mp VPN.....looking at the config guide it shows the keyword used.

You reckon that may cause the issue?

Cheers,
Mohit



Sent from Cisco Technical Support iPad App

Cisco Employee

Re: basic mpls VPN operation

Hi Mohit,

Only unicast is enabled by default. So "address-family vpnv4" and "address-family vpnv4 unicast" are equivalent.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: basic mpls VPN operation

hi all,

thanks everyone for your inputs.

the reason the pings were not working was cos one of the interfaces on the P router was missing "mpls ip".

Now i can ping all the way through from one loopback (vrf A) on the PE to the other loopback (vrf A) on the other PE.

the thing which I am not able to dissect is when I execute this command below:

          R5#sh bgp vpnv4 unicast all

        Network          Next Hop            Metric LocPrf Weight Path

     Route Distinguisher: 65000:1

         *>i192.168.4.0      4.4.4.4                  0    100      0 ?

     Route Distinguisher: 65001:1 (default for vrf A)

     *>i192.168.4.0      4.4.4.4                  0    100      0 ?

     *> 192.168.5.0      0.0.0.0                  0         32768 ?

...................................why I see 192.168.4.0 at two places?

the config of the two PE is below for reference sake:

*******************************R4 (one PE)********************************

ip vrf A

rd 65000:1

route-target export 1:1

route-target import 1:1

ip vrf B

rd 65000:2

route-target export 1:2

route-target import 1:2

router bgp 65000

no synchronization

bgp log-neighbor-changes

neighbor 5.5.5.5 remote-as 65000

neighbor 5.5.5.5 update-source Loopback1

no auto-summary

!

address-family vpnv4

  neighbor 5.5.5.5 activate

  neighbor 5.5.5.5 send-community extended

exit-address-family

!

address-family ipv4 vrf B

  redistribute connected

  no synchronization

exit-address-family

!

address-family ipv4 vrf A

  redistribute connected

  no synchronization

exit-address-family

*******************************R5 (second PE)********************************

ip vrf A

rd 65001:1

route-target export 1:1

route-target import 1:1

ip vrf B

rd 65001:2

route-target export 1:2

route-target import 1:2

router bgp 65000

no synchronization

bgp log-neighbor-changes

neighbor 4.4.4.4 remote-as 65000

neighbor 4.4.4.4 update-source Loopback1

no auto-summary

!

address-family vpnv4

  neighbor 4.4.4.4 activate

  neighbor 4.4.4.4 send-community extended

exit-address-family

!

address-family ipv4 vrf B

  redistribute connected

  no synchronization

exit-address-family

!

address-family ipv4 vrf A

  redistribute connected

  no synchronization

exit-address-family

*************************************************************************************

Thanks,

Regards,

Mohit

Silver

basic mpls VPN operation

If mpls ip was missing on one device, LDP was not working there and the LSP was broken at that point.

The reason for this:

R5#sh bgp vpnv4 unicast all

        Network          Next Hop            Metric LocPrf Weight Path

     Route Distinguisher: 65000:1

         *>i192.168.4.0      4.4.4.4                  0    100      0 ?

     Route Distinguisher: 65001:1 (default for vrf A)

     *>i192.168.4.0      4.4.4.4                  0    100      0 ?

     *> 192.168.5.0      0.0.0.0                  0         32768 ?

Is because you have two different VPNv4 routes. Remember that VPNv4 routes are the 32 bit IPv4 prefix + 64 bit Route Distinguisher, which makes the prefixes unique in the cloud. As you have applied a different RD in each PE, you see the VPNv4 route coming from the other PE with the RD 65000:1 and the same IPv4 prefix with the RD of the local PE 650001:1.

Hope this helps,

Jose.

New Member

Re: basic mpls VPN operation

Hi Jose

That makes sense.
So what's the best practice in this kind of setup where I am simulating both sides of PEs sharing the same VRF are part of the same company?
I have a feeling that the RD value should be the same for them.
Thanks once again.
Regards
Mohit

Sent from Cisco Technical Support iPhone App

Silver

basic mpls VPN operation

It depends. Most common approach in SP is to assign the RD per PE, not per VPN. Simplest approach is to assign the RD per VPN. One of the advantages of using the RD per PE is that the same IPv4 prefix will be different (VPNv4) in the cloud and you could achieve load sharing as the RR will propagate both routes as in fact they are different. If you are using the same RD in the VPN, it will just advertise the best one. On the other hand, the memory consumption will be higher in the RD per PE case.

Hope this helps,

Jose.

294
Views
0
Helpful
8
Replies
CreatePlease login to create content