Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Basic QoS Question

Hello All,

I have the following QoS policy setup in my lab and was wondering why am I seeing output drops on the WAN interface FE 0/1, when FTP'n a large file across my simulated WAN (4Mbps 250ms).  Is this a normal behavior when you're sending a large file across WAN? I don't have the protected traffic running when I'm FTP'n so I'm not sure why I would be seeing output drops on the WAN interface. When the policy is removed from the WAN interface, I don't get the output drops anymore, only happens when it's enabled.

\

QoS Config:

access-list 170 remark **** Silver Traffic ****
access-list 170 remark ** Deny Fragments **
access-list 170 deny   ip any any fragments
access-list 170 remark ** CITRIX **
access-list 170 permit tcp any any eq 1494
access-list 170 permit tcp any any eq 2598
access-list 170 permit tcp any eq 2598 any
access-list 170 remark ** Terminal Services **
access-list 170 permit tcp any any eq 3389
access-list 170 permit tcp any eq 3389 any
access-list 170 remark ** TELNET **
access-list 170 permit tcp any any eq telnet
access-list 170 permit tcp any eq telnet any

class-map match-any Silver
match ip precedence 3
match ip dscp cs3
class-map match-any App_Traffic
match access-group 170


policy-map LAB_WAN-child
class Silver
    bandwidth 800
class class-default
    fair-queue
     random-detect
policy-map LAB_WAN
class class-default
    shape average 4096000
  service-policy LAB_WAN-child
policy-map LAB_LAN
class App_Traffic
  set ip dscp cs3
class class-default


interface FastEthernet0/1
description *** P2P to labrem01r ***
ip address 172.16.205.189 255.255.255.252
ip flow ingress
load-interval 30
duplex full
speed 100
no cdp enable
service-policy output LAB_WAN

interface FastEthernet4/0
description *** P2P to labcorewan-x1r ***
ip address 172.16.205.186 255.255.255.252
ip flow ingress
load-interval 30
duplex full
speed 100
service-policy input LAB_LAN

  • WAN Routing and Switching
7 REPLIES
Cisco Employee

Re: Basic QoS Question

How much FTP traffic are you pushing through? Your FTP traffic is in the default-class in the child policy, and when you push more than 4MB of traffic (shaped in the parent class), the QoS policy will kick in and start RED (random-detect) to slow down the TCP traffic. I think this is pretty normal. You can try and remove the random-detect command and see if it still dropping packets.

Regards,

jerry

New Member

Re: Basic QoS Question

Hi Jerry,

Thanks for the response. I'm testing with a 100MB+ file just to see if I can fill the pipe using WAAS for wan optimization. The throughput I'm seeing is around 2.0-2.9Mbps, able to achieve 3.9Mbps without QoS and no output drops. I've tried it without random-detect and still seeing output drops. I'm wondering what would be the appropriate settings when using Cisco WAAS in your environment. The WAAS offers the ability to fill the pipe regardless of your latency. I don't want the QoS to start dropping any packets to lower the performance unless the protected traffic is matched first.

Cisco Employee

Re: Basic QoS Question

Where did you see the drop? from show policy-map int f0/1 (please post the output)?

You can use the FTP to fill your 4MB pipe, and how does your WAAS  traffic classified? In the Silver class? QoS policy will kick in when there is  congestion, and your silver class will guarentee 800K of traffic.

Regards,

jerry

New Member

Re: Basic QoS Question

The WAAS is not doing anything with QoS, default it's set to leave the DSCP markings alone (copy).

labcore01r# show int fas 0/1
FastEthernet0/1 is up, line protocol is up
  Hardware is i82543 (Livengood), address is 0013.6071.4206 (bia 0013.6071.4206)
  Description: *** P2P to labrem01r ***
  Internet address is 172.16.205.189/30
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 5/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:00, output hang never
  Last clearing of "show interface" counters 01:02:03
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 13317
  Queueing strategy: Class-based queueing
  Output queue: 18/1000/0 (size/max total/drops)
  30 second input rate 120000 bits/sec, 168 packets/sec
  30 second output rate 2276000 bits/sec, 199 packets/sec
     252080 packets input, 22166441 bytes
     Received 1949 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     306249 packets output, 429745492 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     69 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
labcore01r#

labcore01r#show policy-map int fas 0/1
FastEthernet0/1

  Service-policy output: LAB_WAN

    Class-map: class-default (match-any)
      7421 packets, 10686778 bytes
      30 second offered rate 1617000 bps, drop rate
127000 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/552/0
      (pkts output/bytes output) 6869/9866466
      shape (average) cir 4096000, bc 16384, be 16384
      target shape rate 4096000

      Service-policy : LAB_WAN-child

        Class-map: Silver (match-any)
          123 packets, 6847 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 3
            123 packets, 6847 bytes
            30 second rate 0 bps
          Match: ip dscp cs3 (24)
            0 packets, 0 bytes
            30 second rate 0 bps
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 123/6847
          bandwidth 800 kbps

        Class-map: class-default (match-any)
          7298 packets, 10679931 bytes
          30 second offered rate 1616000 bps, drop rate 127000 bps
          Match: any
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops/flowdrops) 0/552/0/552
          (pkts output/bytes output) 6746/9859619
          Fair-queue: per-flow queue limit 16
labcore01r#

Cisco Employee

Re: Basic QoS Question

labcore01r# show int fas 0/1
FastEthernet0/1 is up, line protocol is up
  Hardware is i82543 (Livengood), address is 0013.6071.4206 (bia 0013.6071.4206)
  Description: *** P2P to labrem01r ***
  Internet address is 172.16.205.189/30
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 5/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:00, output hang never
  Last clearing of "show interface" counters 01:02:03
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 13317
  Queueing strategy: Class-based queueing
  Output queue: 18/1000/0 (size/max total/drops)
  30 second input rate 120000 bits/sec, 168 packets/sec
  30 second output rate 2276000 bits/sec, 199 packets/sec
     252080 packets input, 22166441 bytes
     Received 1949 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     306249 packets output, 429745492 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     69 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
labcore01r#

labcore01r#show policy-map int fas 0/1
FastEthernet0/1

  Service-policy output: LAB_WAN

    Class-map: class-default (match-any)
      7421 packets, 10686778 bytes
      30 second offered rate 1617000 bps, drop rate
127000 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/552/0
      (pkts output/bytes output) 6869/9866466
      shape (average) cir 4096000, bc 16384, be 16384
      target shape rate 4096000

      Service-policy : LAB_WAN-child

        Class-map: Silver (match-any)
          123 packets, 6847 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 3
            123 packets, 6847 bytes
            30 second rate 0 bps
          Match: ip dscp cs3 (24)
            0 packets, 0 bytes
            30 second rate 0 bps
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 123/6847
          bandwidth 800 kbps

        Class-map: class-default (match-any)
          7298 packets, 10679931 bytes
          30 second offered rate 1616000 bps, drop rate 127000 bps
          Match: any
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops/flowdrops) 0/552/0/552
          (pkts output/bytes output) 6746/9859619
          Fair-queue: per-flow queue limit 16
labcore01r#

The output in RED indicates the drop is coming from your child policy's class-default. the flowdrops is really indicate the tail drop where the queue has more than 64 packets and start dropping packets.

You might want to check out this link for more info.

http://www.cisco.com/en/US/products/hw/routers/ps341/products_tech_note09186a0080af893d.shtml


HTH,

jerry

New Member

Re: Basic QoS Question

So it looks like the WAAS is always going to send burst of traffic out to the WAN by design, the QoS policy is going to drop excessive burst in traffic by its design. I know it doesn't get dropped without QoS and I'm able to fill the pipe to 3.9 close to 4Mbps. The question is how to apply QoS policy with the WAAS and still be able to fill the pipe to achieve maximum bandwidth. I've tested QoS without WAAS and I don't get the output drops but I'm not able to fill the pipe due to the high latency on the WAN link. Can you find out if this is correct when it comes to QoS and WAAS or is there a design guideline to follow with this type of design setup?

Thanks so much for your assistance.

Cisco Employee

Re: Basic QoS Question

I suggest you to check with the WAAS forum on this since I think there is a command to disable the bursty behavior at the WAAS.

Regards,

jerry

487
Views
0
Helpful
7
Replies
This widget could not be displayed.