Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Basic question on going from static to BGP

Hello, can you pleae help me with this:

Imagine I currently have a 4507 layer 3 switch configured with static routes, functional. Routing configuration is pasted below. Sketch is attached.

Goal:Instead of using a static route to  reach the 7206XVR Corporate router, I want to use BGP (so that way in the future I can provide failover using a secondary site). Note that the static route in blue is pointing to a firewall. I believe I should leave 10.1.55.192 intact as an ip static route and do not include it in BGP. I just want to make sure I am not going to break it though.

So my question is, if I want to make sure I will include all routes into this BGP connection and do not leave networks behind when going from static to dynamic BGP routing, in addition to examining the below do you typically study the content of 'show ip route' as well on gw5? Based on the entry in red below, I would do this on my gw5. Please let me know if this makes sense:

gw5:

router bgp 100

description corporate site1-br-gw

neighbor 10.1.47.193 remote-as 65111

network  10.1.0.0 255.255.0.0

(later need to work on local-pref to set site1 as preferred)

begin current actual config on 4507 gw5----------------------------------

!
router ospf 1
router-id 10.1.255.15
log-adjacency-changes
area 0.0.0.0 authentication message-digest
area 0.0.0.1 authentication message-digest
redistribute static metric 50 metric-type 1 subnets
passive-interface Vlan3
passive-interface Vlan4
passive-interface Vlan40
network 10.1.7.64 0.0.0.63 area 0.0.0.0
network 10.1.47.192 0.0.0.15 area 0.0.0.0
network 10.1.47.208 0.0.0.15 area 0.0.0.1
network 10.1.60.44 0.0.0.3 area 0.0.0.0
network 10.1.60.56 0.0.0.3 area 0.0.0.0
network 10.1.60.60 0.0.0.3 area 0.0.0.0
network 10.1.60.64 0.0.0.3 area 0.0.0.0
network 10.1.60.68 0.0.0.3 area 0.0.0.0
network 10.1.60.88 0.0.0.3 area 0.0.0.0
network 10.1.60.96 0.0.0.3 area 0.0.0.0
network 10.1.60.104 0.0.0.3 area 0.0.0.0
network 10.1.60.108 0.0.0.3 area 0.0.0.0
network 10.1.60.128 0.0.0.3 area 0.0.0.0
network 10.1.60.132 0.0.0.3 area 0.0.0.0
network 10.1.60.136 0.0.0.3 area 0.0.0.0
network 10.1.60.144 0.0.0.3 area 0.0.0.0
network 10.1.60.152 0.0.0.3 area 0.0.0.0
network 10.1.60.176 0.0.0.3 area 0.0.0.1
network 10.1.255.15 0.0.0.0 area 0.0.0.0
default-information originate metric-type 1
!
ip route 10.1.55.192 255.255.255.248 10.1.55.217 track 1
ip route 0.0.0.0 0.0.0.0 10.1.47.193
ip route 10.1.0.0 255.255.0.0 Null0 254

no ip http server
no ip http secure-server
!
--end

3 REPLIES
Hall of Fame Super Blue

Re: Basic question on going from static to BGP

Marlon

Could you post a .jpg instead of a .vsd ?

Jon

Community Member

Re: Basic question on going from static to BGP

I saved it as 2003. I hope that works for you.

I did not manage to save it as .jpg and conserve fonts visible.

Community Member

Re: Basic question on going from static to BGP

Here is the jpeg.

223
Views
0
Helpful
3
Replies
CreatePlease to create content