Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Basic Static Route Question

We have a 1605 that we are trying the following:

Our ISP is providing a DSL circuit with a single public IP address 69.xx.xx.130.

We would like to assign that address to ethernet1 and then configure ethernet0 with an internal ip address 10.0.0.1. The gateway for the DSL is 69.xx.xx.1

So we set up the two interfaces successfully and can ping each of the interfaces, ip routing is running however we can see to get traffic from the private side to the ISP gateway.

We have tried the following:

ip route 69.xx.xx.0 255.255.255.0 69.xx.xx.1

ip route 10.0.0.0 255.0.0.0 69.xx.xx.1

ip route 0.0.0.0 0.0.0.0 eth1

All with no luck.

Thanks in advance,

Brian

2 REPLIES
Hall of Fame Super Silver

Re: Basic Static Route Question

Before he posted it here Brian posted this same question on the LAN Routing and Switching forum where it has received a couple of responses. I suggest that any discussion of this question be consolidated in the LAN forum.

HTH

Rick

Re: Basic Static Route Question

Hello Brian,

make sure your configuration looks like this. You do not need a static route to Ethernet 1, since the interface is directly connected:

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

logging queue-limit 100

no logging console

enable secret 5 yyyy

enable password xxxx

!

ip subnet-zero

no ip domain lookup

!

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

no ip proxy-arp

ip nat inside

no ip route-cache

no ip mroute-cache

!

interface Ethernet1

no ip address

no ip proxy-arp

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication pap callin

ppp pap sent-username aaaa@bbbb.com password 0 zzzzz

!

access-list 1 permit 10.1.1.0 0.0.0.255

ip nat inside source list 1 interface Dialer1 overload !

dialer-list 1 protocol ip permit

!

ip route 0.0.0.0 0.0.0.0 Dialer1

line con 0

line vty 0 4

login

!

end

If you cannot get your router to work with this configuration, can you post the one you have so far ?

Regards,

GNT

114
Views
0
Helpful
2
Replies