Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Best multilink setup? (2)T1s

I have a customer who is about to come online using 2 T1s in multilink. He sent me his configuration to look over. I am not sure why he is setting up multilink in this manner. Here is the relevant config:

interface Loopback0

ip address 192.168.1.42 255.255.255.252

!

interface Serial0/0

no ip address

encapsulation ppp

pulse-time 1

ppp multilink

!

interface Serial 0/1

no ip address

encapsulation ppp

pulse-time 1

ppp multilink

!

interface Virtual-Template1

ip unnumbered Loopback0

ppp multilink

!

ip route 0.0.0.0 0.0.0.0 192.168.1.41

Typically I see multilink setup as:

interface Multilink1

ip address 192.168.1.42 255.255.255.252

ppp multilink

ppp multilink links maximum 2

ppp multilink links minimum 1

ppp multilink group 1

!

interface Serial0/0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial0/1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

ip route 0.0.0.0 0.0.0.0 192.168.1.41

I was wondering which was the better multilink setup? Is my customer on to something I am not aware of or way off base?

Thanks,

Josh

  • WAN Routing and Switching
6 REPLIES

Re: Best multilink setup? (2)T1s

Hi

AFAIK we deploy configs related to virtual templates when dial in from the remote locations.

Virtual templates are logical interfaces similar to multilink interface but it can be applied dynamically based on the requirement.

As a general practice for bundling 2 T1s its multilink interface the best option being followed at present..

I would prefer u to suggest the pros/cons involved and the best operational excercise which can be availed with general multilink interface bundling..

regds

New Member

Re: Best multilink setup? (2)T1s

Thanks for everyone's reply. I have made my recommendations to my customer regarding the multilink setup. I had another customer sometime back who setup multilink with virtual-template but it seemed to cause them problems trying to bring the logical interface up. Hopefully they will just go with the more conventional setup, but it's their choice now.

Thanks,

Josh

New Member

Re: Best multilink setup? (2)T1s

Hi Josh

The config that your client has provided seems to be missing the command "multilink virtual-template"

Apart from that everything looks ok to me..

I too reckon that your method makes more sense in this scenario as we do not actually require a v-template as the dialled end is not an access server.

In your method, the multilink logical interface serves as the bundle master where as in your client's method, the virtual-access interface will be doing the job.

Hence, in your method, the NCP and hence the other characteristics of the connection will be negotiated by the multilink interface..similar to the above.

So I cannot think of any pros and cons.

Ideas, thoughts anyone ?

cheers

Arav

New Member

Re: Best multilink setup? (2)T1s

Josh,

I have two point-to-point T1 circuits bundled to a Multilink interface just as you have described above in your "typcial setup" configuration. It works great in our environment; the only catch was I needed to supply the clocking on one end since the carrier doesn't provide clocking in a point-to-point environment.

-m2

New Member

Re: Best multilink setup? (2)T1s

hi,

here i give the working config from cisco site. which uses the virtual templete.

hostname RouterA

!

!

username RouterB password your_password

ip subnet-zero

multilink virtual-template 1

!

interface Virtual-Template1

ip unnumbered Ethernet0

ppp authentication chap

ppp multilink

!

interface Serial0

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial1

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial2

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial3

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Ethernet0

ip address 10.17.1.254 255.255.255.0

!

router rip

network 10.0.0.0

!

end

Router B Configuration

hostname RouterB

!

!

username RouterB password your_password

ip subnet-zero

multilink virtual-template 1

!

interface Virtual-Template1

ip unnumbered Ethernet0

ppp authentication chap

ppp multilink

!

interface Serial0

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial1

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial2

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial3

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Ethernet0

ip address 10.17.2.254 255.255.255.0

!

router rip

network 10.0.0.0

!

end

New Member

Re: Best multilink setup? (2)T1s

Hi Matt,

Just curious to know what you meant when you said 'since the carrier doesn't provide clocking in a point-to-point environment.'

Clocking is indispensable in any serial communication setup and it is provided by the DCE (Serv Provider) equipment.

I'm inclined to think that it was an one off instance with your provider alone and it has got nothing to do with this kind of a config/setup.

Let us know what you think.

cheers

Arav

344
Views
0
Helpful
6
Replies