Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Between netmasks Configuring Cisco 2800

OLa Partners.

I am having many doubts on how to configure netmasks between two home Router cisco deforms who gains access to a subnet that is connected to the tip of the other home Router. What protocols netmasks should I use to allow this connection? The home Router are already connected via serial as can be seen in the topology sent. I can ping the Gateway 1 Gateway 2.

Hugs
Tiago  Eduardo Zacarias

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: Between netmasks Configuring Cisco 2800

Hello Tiago,

unless you are using RIPv1 or IGRP that are classful routing protocols (that means they don't carry the subnet mask in routing updates) you are free to use different subnet masks in the two LAN subnets that can be different also of the subnet mask used on the serial link.

Example:

let's use major network 192.168.16.0.

We can divide this with a /26 subnets creating 4 blocks

192.168.16.0/26

192.168.16.64/26

192.168.16.128/26

192.168.16.192/26

we can further divide first subnet in two /27 subnets

192.168.16.0/27

192.168.16.32/27

we can get a /30 from last block

192.168.16.248/30

Lan segment1:

192.168.16.32/27

serial link: 192.168.16.248/30

Lan segment 2: 192.168.16.128/26

So we are using three different subnet masks for subnets of the same major network Class C 192.168.16.0.

This is called variable length subnet mask.

A dynamic routing protocol can support a scenario like this if in its routing updates it carries the subnet mask of each IP subnet.

let's consider RIPv2

R1:

int eth0/0

desc lan segment 1

ip address 192.168.16.33 255.255.255.224

no shut

int ser0/0

ip address 192.168.16.249 255.255.255.252

router rip

version 2

network 192.168.16.0

R2:

int eth0/0

desc lan segment 2

ip address 192.168.16.129 255.255.255.192

no shut

int ser0/0

ip address 192.168.16.250 255.255.255.252

router rip

version 2

network 192.168.16.0

Hope  to help

Giuseppe

Silver

Re: Between netmasks Configuring Cisco 2800

In the eigrp 100 config you are announcing the 20.0.0.0 network on both sides.

From the client side you do not have 20.0.0.0, you are using 10.0.0.0 so you will need to announce the 10 network from the client.

So the EIGRP needs to be reversed.

Router 1

eigrp 100

network 20.0.0.0

Client

eigrp 100

network 10.0.0.0

7 REPLIES
New Member

Re: Between netmasks Configuring Cisco 2800

Hi Tiago,

Can u brief more, as which protocol you are using and what subnet you have configured for the network connected in the other end, as per my understanding if you were able to ping Gateway 1 and Gateway2 from both the routers, then you need to advertize the subnet under the protocol, just correct me if I'm wrong.

Jana

Hall of Fame Super Silver

Re: Between netmasks Configuring Cisco 2800

Hello Tiago,

unless you are using RIPv1 or IGRP that are classful routing protocols (that means they don't carry the subnet mask in routing updates) you are free to use different subnet masks in the two LAN subnets that can be different also of the subnet mask used on the serial link.

Example:

let's use major network 192.168.16.0.

We can divide this with a /26 subnets creating 4 blocks

192.168.16.0/26

192.168.16.64/26

192.168.16.128/26

192.168.16.192/26

we can further divide first subnet in two /27 subnets

192.168.16.0/27

192.168.16.32/27

we can get a /30 from last block

192.168.16.248/30

Lan segment1:

192.168.16.32/27

serial link: 192.168.16.248/30

Lan segment 2: 192.168.16.128/26

So we are using three different subnet masks for subnets of the same major network Class C 192.168.16.0.

This is called variable length subnet mask.

A dynamic routing protocol can support a scenario like this if in its routing updates it carries the subnet mask of each IP subnet.

let's consider RIPv2

R1:

int eth0/0

desc lan segment 1

ip address 192.168.16.33 255.255.255.224

no shut

int ser0/0

ip address 192.168.16.249 255.255.255.252

router rip

version 2

network 192.168.16.0

R2:

int eth0/0

desc lan segment 2

ip address 192.168.16.129 255.255.255.192

no shut

int ser0/0

ip address 192.168.16.250 255.255.255.252

router rip

version 2

network 192.168.16.0

Hope  to help

Giuseppe

New Member

Re: Between netmasks Configuring Cisco 2800

Hello Partners.

My solution was to create the dropping routes with EIGRP for their respective segments that wish to access it if i put ping the gateway for any cisco router works beauty but if ping Gateway 1 to Gateway2 or Gateway2 to Gateway1 can not access, so I can ping Interface FastEthernet segment that is in the home Router how to proceed to solve this problem? be problems Jumping netmasks?

Silver

Re: Between netmasks Configuring Cisco 2800

Can you provide a bit more detail?

For example.

Router 1 config and Router 2 config and what you want to do and what is not working.

Do not share confidential information but in order to help we need to know what you have and what you are trying to do.

New Member

Re: Between netmasks Configuring Cisco 2800

Hello,

And the next, I want to accomplish communication with according to the topology of the image sent with the following scenario. Access Gateway 1 Gateway 2 Gateway 2, or access by Gateay 1 .. Have access to 2 segments of the home Router atraz understand? follows below the configuration of home Router.

Router 1

Version 12.4
no service password-encryption
!
hostname Central
!
!
enable secret 5 $ 1 $ $ merr jLqbUbMQEAg0Ta6dPkp7A0
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0 / 0
ip address 20.0.0.1 255.0.0.0
duplex auto
speed auto
!
interface FastEthernet0 / 1
ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
ip address 200.200.200.1 255,255,255,252
clock rate 125000
!
interface Serial0/3/1
ip address
shutdown
!
interface Vlan1
ip address
shutdown
!

router eigrp 100
network 10.0.0.0
network 200.200.200.0 0.0.0.3
auto-summary
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

Router 2

version 12.4
no service password-encryption
!
hostname cliente
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.0.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 200.200.200.2 255.255.255.252

clock rate 125000
!
interface Serial0/1/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 100
network 20.0.0.0 0.0.0.255
network 200.200.200.0 0.0.0.3
auto-summary

!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

So the scenario would be that the servers are with the gateway set to the ip of the Router FastEthernet interface that will make the netmasks for the other thread.
If aguem can help me I am grateful! Thanks

Silver

Re: Between netmasks Configuring Cisco 2800

In the eigrp 100 config you are announcing the 20.0.0.0 network on both sides.

From the client side you do not have 20.0.0.0, you are using 10.0.0.0 so you will need to announce the 10 network from the client.

So the EIGRP needs to be reversed.

Router 1

eigrp 100

network 20.0.0.0

Client

eigrp 100

network 10.0.0.0

New Member

Re: Between netmasks Configuring Cisco 2800

Hi

Thank you beautiful could help solve this problem. very good this forum thanks for the help even friends!!
And a happy new year to all!

Att
Tiago  Eduardo Zacarias

1127
Views
0
Helpful
7
Replies