Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BFD support for 2800 3800

Hi,

I'm trying to get the bfd feature working between a 2821 and a 3845. Checking out the feature navigator shows it available in 12.4 (15)T14.

After loading an ipbase image I am able to configure bgp neighbours with bfd no problem. However, when I try to configure the Gig interfaces there are no bfd commands??

A parser dump shows the commands should be there but they aren't. Also there are no show commands or debug.

Going back to read the release notes there is  a worrying little snippet that mentions that bfd isn't supported on all platforms or interfaces! Not very helpful.

So the question is can somebody recommend an IOS that actualy works.

Many thanks

Bob

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: BFD support for 2800 3800

Hello Rohit,

Actually, the BFD is supported on selected ISR routers. I have just verified that using a 2811 series router running C2800NM-ADVIPSERVICESK9-M, Version 15.0(1)M3 IOS version. The BFD on a FastEthernet interface coupled with EIGRP runs just fine:

Router#show run int fa0/0
Building configuration...

Current configuration : 136 bytes
!
interface FastEthernet0/0
ip address 10.0.1.3 255.255.255.0
duplex auto
speed auto
bfd interval 50 min_rx 50 multiplier 3
!
end

Router#show run | section router eigrp
router eigrp 1
bfd all-interfaces
network 10.0.0.0
Router#show ip eigrp nei
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.0.1.2                Fa0/0             10 00:05:25    4   200  0  2
Router#show bfd nei

NeighAddr                         LD/RD    RH/RS     State     Int
10.0.1.2                           1/1     Up        Up        Fa0/0
Router#show bfd nei de

NeighAddr                         LD/RD    RH/RS     State     Int
10.0.1.2                           1/1     Up        Up        Fa0/0
Session state is UP and using echo function with 50 ms interval.
OurAddr: 10.0.1.3
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 10
Holddown (hits): 0(0), Hello (hits): 1000(335)
Rx Count: 338, Rx Interval (ms) min/max/avg: 1/1000/875 last: 404 ms ago
Tx Count: 337, Tx Interval (ms) min/max/avg: 1/1892/876 last: 676 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: EIGRP
Uptime: 00:04:55
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             Multiplier: 10              - Length: 24
             My Discr.: 1                - Your Discr.: 1
             Min tx interval: 1000000    - Min rx interval: 1000000
             Min Echo interval: 50000
Router#

Bob, according to the Cisco Feature Navigator, the BFD in IPBASE image is supported only in 12.4(15)T and 12.4(15)T1 (as if included only by mistake ). In the ADVIPSERVICES I have been using, the BFD seems to be supported since 12.4(15)T onwards.

Best regards,

Peter

5 REPLIES
New Member

Re: BFD support for 2800 3800

Hi Bob,

Currently BFD is not supported on any IOS versions for the 2800 or 3800 Series routers. Please refer to this link:

http://www.cisco.com/en/US/docs/ios/12_0s/feature/guide/fs_bfd.html

BFD feature is was only available on the 12000,10000 Series Routers.. In Cisco IOS Release 12.4(11)T, this feature was  introduced on Cisco 7200 series, Cisco 7600 series, and Cisco 12000  series routers.

Cisco Employee

Re: BFD support for 2800 3800

Hello Rohit,

Actually, the BFD is supported on selected ISR routers. I have just verified that using a 2811 series router running C2800NM-ADVIPSERVICESK9-M, Version 15.0(1)M3 IOS version. The BFD on a FastEthernet interface coupled with EIGRP runs just fine:

Router#show run int fa0/0
Building configuration...

Current configuration : 136 bytes
!
interface FastEthernet0/0
ip address 10.0.1.3 255.255.255.0
duplex auto
speed auto
bfd interval 50 min_rx 50 multiplier 3
!
end

Router#show run | section router eigrp
router eigrp 1
bfd all-interfaces
network 10.0.0.0
Router#show ip eigrp nei
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.0.1.2                Fa0/0             10 00:05:25    4   200  0  2
Router#show bfd nei

NeighAddr                         LD/RD    RH/RS     State     Int
10.0.1.2                           1/1     Up        Up        Fa0/0
Router#show bfd nei de

NeighAddr                         LD/RD    RH/RS     State     Int
10.0.1.2                           1/1     Up        Up        Fa0/0
Session state is UP and using echo function with 50 ms interval.
OurAddr: 10.0.1.3
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 10
Holddown (hits): 0(0), Hello (hits): 1000(335)
Rx Count: 338, Rx Interval (ms) min/max/avg: 1/1000/875 last: 404 ms ago
Tx Count: 337, Tx Interval (ms) min/max/avg: 1/1892/876 last: 676 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: EIGRP
Uptime: 00:04:55
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             Multiplier: 10              - Length: 24
             My Discr.: 1                - Your Discr.: 1
             Min tx interval: 1000000    - Min rx interval: 1000000
             Min Echo interval: 50000
Router#

Bob, according to the Cisco Feature Navigator, the BFD in IPBASE image is supported only in 12.4(15)T and 12.4(15)T1 (as if included only by mistake ). In the ADVIPSERVICES I have been using, the BFD seems to be supported since 12.4(15)T onwards.

Best regards,

Peter

New Member

Re: BFD support for 2800 3800

Thanks for that Peter,

That'll will save me many hours I'm sure. I couldn't make head nor tale of the documentation as one thing would say it was supported the next it might (not) be and the third it wasn't?

I think I might play safe and just use your version.

Bob

New Member

Re: BFD support for 2800 3800

Hi Peter,

Thank you for the update. I tried the 15.0.1M3 image under Advanced Enterprises but that did not accept the command " bfd all-interfaces" under BGP for a 3845 Router. Strange, that Advanced IP Services works. I will give it a try today with Advanced IP Services and would post an update.

Thanks,

Rohit

Cisco Employee

Re: BFD support for 2800 3800

Hello Rohit,

 I tried the 15.0.1M3 image under Advanced Enterprises but that did not 
accept the command " bfd all-interfaces" under BGP for a 3845 Router

Neither does the ADVIPSERVICESK9 15.0(1)M3 for me but I would be actually suprised if it did support this command in the BGP configuration. For BGP, the BFD is activated on a per-neighbor basis using the neighbor fall-over bfd command, not on a per-interface basis. See:

http://www.cisco.com/en/US/docs/ios/12_2sr/12_2sra/feature/guide/srbgpbfd.html

The bfd all-interfaces should be supported under IGP protocols (EIGRP, OSPF, IS-IS).

Best regards,

Peter

2484
Views
0
Helpful
5
Replies
CreatePlease login to create content