Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP Adj Flapping-Cisco887 ADSL&GRE

Hello everyone,

We're deploying a brand new network for a customer. We've got problems on several ADSL links: we're having repetitive BGP Adj connect/disconnect problems.
On these links I've identified around 2% packet loss....with a scheme like this one: !!!!!!.....!!!!!
Provider confirmed a 2% ATM cells loss on the links but they offer no service guarantee for that...
We use C887 routers with IOS 15.1.1. ADSL+GRE. Provider use Huawei DSLAMs.

Is there any "config solution" to that problem? Big chance we'll get packet losses on these ADSL links from time to time... I can't afford the bgp sessions to flap like this...
Do you think I should increase the hellos value with the following command line:  neighbor ip_address advertisement-interval seconds ?
If so, I know that I have to enter the same values on both sides of the session (C887 <------> ASR1002)....but I don't want this to apply to all my different BGP sessions on the core router (ASR-1002F).....Below part of the conf and part of a debug.
Thanks in advance for your help!

K

interface Loopback1
ip address 172.27.10.56 255.255.255.255
!
interface Tunnel10
ip vrf forwarding VRFA
ip address 10.40.2.114 255.255.255.252
ip pim sparse-mode
ip tcp adjust-mss 1300
tunnel source 172.27.10.56
tunnel destination 172.27.0.56
!
interface ATM0
no ip address
  atm ilmi-keepalive
pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1

interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname sitexx@nis.zz.com
ppp chap password xxxxxxxxxxxx
no cdp enable
!
router bgp 65001
template peer-session AS65000
  remote-as 65000
  password xxxxxxxxx
  ebgp-multihop 3
  update-source Dialer0
  timers 5 15
exit-peer-session
!
template peer-session TEST-AS65000
  remote-as 65000
  password xxxxxxxxxxxxxx
  ebgp-multihop 3
  update-source Tunnel10
  timers 5 15
exit-peer-session
!
bgp log-neighbor-changes
neighbor 172.25.254.254 inherit peer-session AS65000
!
address-family ipv4
  no synchronization
  redistribute connected route-map CON-IN-BGP-GLOBAL
  neighbor 172.25.254.254 activate
  no auto-summary
exit-address-family
!
address-family ipv4 vrf VRFA
  no synchronization
  network 172.30.208.16 mask 255.255.255.240
  neighbor 10.40.2.113 inherit peer-session TEST-AS65000
  neighbor 10.40.2.113 activate
exit-address-family
============================
Sep 23 10:57:51.069: BGP: ses global 172.25.254.254 (0x860FF0EC:1) Keep alive timer fired.
.Sep 23 10:57:51.069: BGP: 172.25.254.254 KEEPALIVE requested (bgp_keepalive_timer_expired)
.Sep 23 10:57:51.069: BGP: ses global 172.25.254.254 (0x860FF0EC:1) service keepalive IO request.
.Sep 23 10:57:51.069: BGP: 172.25.254.254 KEEPALIVE write request serviced in BGP_IO
.Sep 23 10:57:52.093: %BGP-5-ADJCHANGE: neighbor 172.25.254.254 Down BGP Notification sent
.Sep 23 10:57:52.093: %BGP-3-NOTIFICATION: sent to neighbor 172.25.254.254 4/0 (hold time expired) 0 bytes
.Sep 23 10:57:52.093: %BGP_SESSION-5-ADJCHANGE: neighbor 172.25.254.254 IPv4 Unicast topology base removed from session  BGP Notification sent
.Sep 23 10:58:00.641: BGP: 172.25.254.254 passive KEEPALIVE write request serviced in BGP_IO
.Sep 23 10:58:00.641: BGP: 172.25.254.254 passive service 2 read request in BGP_IO
.Sep 23 10:58:00.641: BGP: 172.25.254.254 passive service 2 read request in BGP_IO
.Sep 23 10:58:00.641: BGP: 172.25.254.254 passive KEEPALIVE requested (rcv_open)
.Sep 23 10:58:00.641: BGP: ses global 172.25.254.254 (0x860FF0EC:0) pas service keepalive IO request.
.Sep 23 10:58:00.641: BGP: 172.25.254.254 passive KEEPALIVE write request serviced in BGP_IO
.Sep 23 10:58:00.693: BGP: 172.25.254.254 passive KEEPALIVE write request serviced in BGP_IO

1 REPLY
New Member

Re: BGP Adj Flapping-Cisco887 ADSL&GRE

K ,

Please share the sh int dsl a0 and sh caller output.

Sumit

720
Views
0
Helpful
1
Replies