Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

BGP advertise route

Hi all,

Refering to below config. can router advertise 148.50.0.0/16 to outside, Since as i know, router can only advertise route

when the interface subnet mask is exactly match with subnet mask under router bgp xxx. But now the two subent mask are not

match (148.50.1.253/24, 148.50.0.0/16). So can router advertise 148.50.0.0/16 to outside

!

interface FastEthernet0/1

ip address 148.50.1.253 255.255.255.0

duplex auto

speed auto

!

router eigrp zzzz

redistribute bgp xxxx metric 1024 100 200 200 1500

network 140.50.0.0

network 148.50.0.0

network 172.16.0.0

no auto-summary

no eigrp log-neighbor-changes

!

router bgp xxxx

no synchronization

bgp log-neighbor-changes

network 10.100.0.0 mask 255.255.0.0

network 10.255.2.48 mask 255.255.255.252

network 140.50.0.0

network 148.50.0.0

neighbor 10.255.2.49 remote-as yyyy

neighbor 10.255.2.49 soft-reconfiguration inbound

no auto-summary

1 REPLY
Hall of Fame Super Silver

Re: BGP advertise route

Hello,

yes if one of the following actions is done

a) you enable auto-summary under router bgp

b) you create an aggregate for the net under router bgp but take care to have at least a component subnet in the BGP table

Hope to help

Giuseppe

116
Views
0
Helpful
1
Replies