Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP announce network

Hi all,

Refer to below config. can router announce network 148.50.0.0/16? As I know, In order to make

BGP to announce network, interface subnet mask should be exactly match with

subnet mask under router bgp. That is below router can't announce network 148.50.0.0/16.

Howerver, if interface fastethernet 0/1 change to ip address 148.50.1.253 255.255.0.0. then router can announce it.

Is it right ?

!

interface FastEthernet0/1

ip address 148.50.1.253 255.255.255.0

duplex auto

speed auto

!

router eigrp zzzz

redistribute bgp xxxx metric 1024 100 200 200 1500

network 140.50.0.0

network 148.50.0.0

network 172.16.0.0

no auto-summary

no eigrp log-neighbor-changes

!

router bgp xxxx

no synchronization

bgp log-neighbor-changes

network 10.100.0.0 mask 255.255.0.0

network 10.255.2.48 mask 255.255.255.252

network 140.50.0.0

network 148.50.0.0

neighbor 10.255.2.49 remote-as yyyy

neighbor 10.255.2.49 soft-reconfiguration inbound

no auto-summary

!

2 REPLIES

Re: BGP announce network

use

network 148.50.0.0 mask 255.255.255.0

and

http://www.cisco.com/en/US/docs/ios/12_2/iproute/command/reference/1rfbgp1.html#wp1017390

with summary-only option

New Member

Re: BGP announce network

Yes, Whatever prefix you advertise using network command in BGP should have an exact match in the local routing table as well, unless otherwise you have a summarise option.

Regards,

236
Views
0
Helpful
2
Replies
CreatePlease login to create content