Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

BGP configuration

Here is one for you BGP experts...

We are designing a multihomed network that connects two routers to two different ISP?s. My two routes will be running HSRP for redundancy between them. I would like to implement BGP for my WAN routing protocol. We have our own private class C address space and will be advertising three supernets out of that space, 206.224.196.0/22, 206.224.200.0/21 and 206.224.208.0/20 to ISPA and ISPB.

We are currently using four on those networks 206.224.223.0/24, 206.224.222.0/24, 206.224.221.0/24 and 206.224.196.0/24. The problem we are having is that we would like to send everything coming from 206.224.222.0/24 out to ISPA and only use ISPB for that network when ISPA goes down. The other two networks will be handled dynamically by BGP.

7 REPLIES
New Member

Re: BGP configuration

Hi,

1-can u explain, if 206.224.222.0/24 go through ISPA, what of remaining subnets, R they will go to both ISP's and perform any load balancing ?

2-Which router will have higher priorty in HSRP,is higer priorty router in HSRP ,connected to ISPA or ISPB?

Regards,

New Member

Re: BGP configuration

The remaining subnets will be controlled dynamically by BGP best route to ISPA or ISPB. RouterA is connected to both ISP?s. RouterB is only connected to ISPB. RouterA is the

New Member

Re: BGP configuration

If I understand what you are trying to accomplish correctly, you could to the following:

Setup HSRP for the subnet you want to send to ISPA to use priority on that router with interface tracking on the ISP connection.

For outbound advertisement to the ISP, you could do a conditional advertisement in BGP for the subnet. You would only advertise that subnet to ISP A--if ISP A is down you would then advertise to ISP B.

HTH.

Silver

Re: BGP configuration

Hi,

another way is to use OER for the specific prefix 206.224.222.0/24, then optimize the connection with ISPA.

more infos:

http://www.cisco.com/en/US/products/ps6599/products_white_paper09186a008036524d.shtml

HTH

Andrea

Re: BGP configuration

Friend,

You can use AS-path prepending to make sure the network has a better reachability via ISPA. To force your traffic via ISPA use PBR

A sample config

router bgp

network 206.242.196.0

network 206.224.223.0

network 206.224.222.0

neighbor remote-as

neighbor remove-private-AS

neighbor route-map ISPA-local-routes out

neighbor remote-as

neighbor remove-private-AS

neighbor route-map ISPB-local-routes out

route-map ISPA-local-routes permit 10

match ip address 1

set as-path prepend

route-map ISPA-local-routes permit 20

match ip address 2

route-map ISPB-local-routes permit 10

match ip address 2

set as-path prepend

!

route-map ISPB-local-routes permit 20

match ip address 1

!

access-list 1 permit 206.224.221.0 0.0.0.255

access-list 1 permit 206.224.223.0 0.0.0.255

access-list 1 permit 206.224.196.0 0.0.0.255

access-list 2 permit 206.224.222.0 0.0.0.255

int fa 0/0

Description " inside interface"

ip policy route-map ISP-Pref

route-map ISP-Pref permit 10

match ip address 2

set ip next-hop

HTH, rate if it does

Narayan

New Member

Re: BGP configuration

Thanks...

Also, is there anyway to control source address routing in BGP coming from my inside network?? I only want packets coming from my 206.224.222.0/24 to be routed out ISPA unless the link goes down. I understand I can use a prefix-list and deny it going out ISPB, but if ISPA goes down I would have to manually remove the deny statement... I was hoping to make it more dynamic.

New Member

Re: BGP configuration

you could achieve this by advertising the ip address of your network with a higher mask. by default if there are 2 equal paths, BGP advertises the prefixes with the higher mask. if needed you may also consider using BGP attributes such as weight or Local preference to achieve this.

219
Views
0
Helpful
7
Replies