Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

BGP confusion

Hi all,

I was helped yesterday with some routing protocol issues. going to an mpls network that will only allow BPG or static. I found a BGP config in this group but just wanted some clarification as i am new to the BGP world.

setup as follows:

internet

|

CE1 - - PE1- - - -PE2 - - -CE2

|

|

CE3- - internet

The internet connection at CE1 is our primary and the internet at CE3 is a backup.

the PE routers are handled by the provider, as i understand i see them an a logical router and nothing more.

my confusion is how the sites know that the backup internet at CE3 is to be used if connection is cut at CE1. i understand default routes and such, so am i to just let the provider know which is backup and they handle it? i was thinking of something like the following for a template for all CE routers:

interface Serial0/0

ip address x.x.x.x 255.255.255.252

!

router bgp 65000

neighbor <PE router> remote-as 65002

network <internal net> mask 255.255.255.0

redistribute connected

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 <PE router>

am i totally off base here with my thinking of BGP?

Thanks for any help.

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: BGP confusion

Hi,

I deliberately left out the network statements for CE1 and CE3. The only thing that needs to be advertised by these routers is the default route. You could advertise all the specific routes but there is little point in doing so.

Hope that helps - pls do rate the post if it does.

Paresh

7 REPLIES
Purple

Re: BGP confusion

Hi,

Q: " how the sites know that the backup internet at CE3 is to be used if connection is cut at CE1"

The answer to this question is that the sites will not know that this is the case. This is key to the way an MPLS VPN works. Since your spoke sites have only a single link to the network, they have no choice but to send all traffic over this link. Once the traffic reaches the PE, the PE makes a determination of where the traffic has to go. Therefore, when the connection to CE1 is cut, it is the PE that has to make the switch to CE3.

Your config for the spoke routers is fine except:

- you do not need to use 'redistributed connected' if you are going to be specifying the networks to be advertised using the 'network' command.

The config for your CE1 and CE3 routes will have to be slightly different:

router bgp 65001

neighbor remote-as 65002

neighbor route-map SetMed out

default-information originate

no auto-summary

!

ip route 0.0.0.0 0.0.0.0

!

access-list 1 permit 0.0.0.0 0.0.0.0

!

route-map SetMed permit 10

match ip address 1

set metric 100 ! use this at CE1 only

set metric 0 ! use this at CE3 only.

The use of different MED values will allow the PE to choose between the two default routes from CE1 and CE3

Hope that helps - pls rate the post if it does.

Paresh

Cisco Employee

Re: BGP confusion

I would rather recommend using as-path prepending on the CE3 side since many SP providers reset the incoming MED for incoming BGP updates for L3VPN services.

This way default route from CE1 would always be picked first and the one from CE3 would be picked in case CE1 stops sending its default route or if it goes away all together.

The config would look something like this on CE3:

route-map AS-prepend permit 10

match ip address 1

set as-path prepend 65001

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: BGP confusion

so if this is not used what exactly happens?

Cisco Employee

Re: BGP confusion

If you don't make sure that the default route from CE1 is always used as a primary, PEs in the core would select the default route from either CE1 or CE3 as the best path depending on the IGP distance to the PEs connected to CE1 and CE3.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: BGP confusion

Thank you for your reply, both of you.

pkhatri, a question about the config you posted. did you leave out the network statements because i had included them earlier? this cannot be the entire config without supplying the network correct? or are these the configs for the CE1 and CE3 and do not include the networks? just a little confusion on my part.

Thanks again.

Purple

Re: BGP confusion

Hi,

I deliberately left out the network statements for CE1 and CE3. The only thing that needs to be advertised by these routers is the default route. You could advertise all the specific routes but there is little point in doing so.

Hope that helps - pls do rate the post if it does.

Paresh

New Member

Re: BGP confusion

AH! lol I think i am coming around now...ha!

thanks so much for your help.

133
Views
8
Helpful
7
Replies
CreatePlease to create content