Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

BGP default route question

We are using BGP for only the default route in our multi homed enviroment.  We have EBGP peers established from the 2 sites to our wan routers.  Everything works fine except for the fact that we have peers that are spoked off of other peers.  The far end peer's default route change be changed to ISP 1 but traffic still follows the path of the upstream router to ISP 2.  We have tried the next-hop-self command but this appears to have no affect.  The far end peer shows the correct next hop for its traffic and it has that in the routing table.  Is this not possible to send the traffic from the downstream router out one isp and the router it attached to out another?

Thanks,

Joe

3 REPLIES

Re: BGP default route question

if you can post a diagram will be better to understand your topology

thank you

New Member

Re: BGP default route question

Here is a sample layout of the network.  The issue is we would like for Remote Data Center to use a different ISP connection than Remote Colo sees for its default route.  If I need to clarify anything in the drawing, please let me know.

Thanks,

Joe

Re: BGP default route question

do you mean the DataCenter recieves the Default rotue thrugh IBGP thorugh colo site , and yo want the datacneter sees this defaukt route from diffrent next hop or in other words when its forwarded to the colo its get forwarded to other next hop than the one used by colo ?

i think this is a bit tricky becuase routing works hop by hop if the datacneter forward the route route to the colo then colo will use its routing table to forward the traffic

i think you may try VRFs and vrfs route leaking

allthe config in colo router

the idea is to put the link connected to the datacenter in a vrf and other links in diffrent vrf and you you will use will use inport and export through route-target between vrfs but you can now controll what default route from what next hop you will use for the datacenter vrf

kets say the dataceneter VRF called DC and other called VRF1

ip vrf DC     -- datacnter VRF
rd 1:1
route-target export 1:1
route-target import 1:1
!
ip vrf VRF1   ---other lniks VRF
rd 2:2
export map DC              - ths map will xort all route Except the defult rouete to DC VRF
route-target export 2:2
route-target import 2:2
route-target import 1:1    --- thisto imort te rute from DC
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet1/0
ip vrf forwarding DC                      
ip address 10.1.1.1 255.255.255.0

!
interface FastEthernet1/1
ip vrf forwarding VRF1
ip address 192.168.1.1 255.255.255.0

!
interface FastEthernet2/0
ip vrf forwarding VRF1                         you can hae one llink conected to two BGPpeers in te sae subnet ( in this exmple i hav two diffrent interfaces
ip address 30.1.1.1 255.255.255.0

!
router eigrp 10
auto-summary
!
address-family ipv4 vrf VRF1               fo reirp oute with other sites
  network 0.0.0.0                   
  no auto-summary
  autonomous-system 10
exit-address-family
!
address-family ipv4 vrf DC                                --- eirp with D over DC f
  redistribute bgp 65002 metric 1 1 1 1 1       toredisrbute the bellow static deault route
  network 0.0.0.0
  no auto-summary
  autonomous-system 10
exit-address-family
!
router bgp 65002
no synchronization
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf VRF1
  redistribute connected
  neighbor 30.1.1.3 remote-as 65000
  neighbor 30.1.1.3 activate
  neighbor 192.168.1.2 remote-as 65001
  neighbor 192.168.1.2 activate
  no synchronization
exit-address-family
!
address-family ipv4 vrf DC
  redistribute connected
  redistribute static               --- this to inject the defalt route into bgp under DC VRF this will be used by Colo rotr under DC vrf toend the trafi according to this defaultroute stati entry
  redistribute eigrp 10
  neighbor 10.1.1.10 remote-as 65002
  neighbor 10.1.1.10 activate
  neighbor 10.1.1.10 default-originate             -- -thito inject defaulte to DC through BGP   
  no synchronization
exit-address-family
!
ip forward-protocol nd
ip route vrf DC 0.0.0.0 0.0.0.0 30.1.1.3     - efalte-route to be used ove e desidred next hop
no ip http server
no ip http secure-server
!
!
!
!
ip prefix-list DC seq 5 deny 0.0.0.0/0                 this to exort all routs to DC except the deautl becuase we need to use the stat route above
ip prefix-list DC seq 10 permit 0.0.0.0/0 le 32
logging alarm informational
!
!
!
route-map DC permit 10
match ip address prefix-list DC
set extcommunity rt  1:1 additive    -- set the reqired R t e sen b DC VRF
!
!

DC router:

R0#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.1.1 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet1/0
D    192.168.1.0/24 [90/30720] via 10.1.1.1, 00:00:01, FastEthernet1/0
     150.1.0.0/24 is subnetted, 1 subnets
C       150.1.1.0 is directly connected, Loopback0
     30.0.0.0/24 is subnetted, 1 subnets
D       30.1.1.0 [90/30720] via 10.1.1.1, 00:00:01, FastEthernet1/0
B*   0.0.0.0/0 [200/0] via 10.1.1.1, 00:01:00   -- this from clo inyour case

thisrepresent the colo router:

R1#show ip route vrf VRF1

Routing Table: VRF1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/156160] via 192.168.1.2, 00:08:32, FastEthernet1/1
     20.0.0.0/24 is subnetted, 1 subnets
D       20.1.1.0 [90/30720] via 192.168.1.2, 00:08:20, FastEthernet1/1
D    192.168.4.0/24 [90/30720] via 30.1.1.3, 00:00:39, FastEthernet2/0
     10.0.0.0/24 is subnetted, 1 subnets
B       10.1.1.0 is directly connected, 00:05:47, FastEthernet1/0
C    192.168.1.0/24 is directly connected, FastEthernet1/1
     150.1.0.0/24 is subnetted, 1 subnets
B       150.1.1.0 [20/156160] via 10.1.1.10 (DC), 00:05:47, FastEthernet1/0
     30.0.0.0/24 is subnetted, 1 subnets
C       30.1.1.0 is directly connected, FastEthernet2/0
B*   0.0.0.0/0 [20/0] via 192.168.1.2, 00:06:14       lo the next op of the defatl route and also other DC routes seenthugh bgp becuase ty are importe via VRF

bellw D VRF routing table

R1#show ip route vrf DC

Routing Table: DC
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 30.1.1.1 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet1/0
B    192.168.1.0/24 is directly connected, 00:06:40, FastEthernet1/1
     150.1.0.0/24 is subnetted, 1 subnets
D       150.1.1.0 [90/156160] via 10.1.1.10, 00:12:13, FastEthernet1/0
     30.0.0.0/24 is subnetted, 1 subnets
B       30.1.1.0 is directly connected, 00:06:40, FastEthernet2/0
S*   0.0.0.0/0 [1/0] via 30.1.1.3   the default route now is other peer based onthe static route above

now DC send the defaultroute to colo and colo will use DC vrf routing table and send it to 30.1.1.3

good luck

if helpful Rate

1423
Views
0
Helpful
3
Replies
CreatePlease to create content