Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP Dual ISP fallover issue

i am Dhinesh,
I have one problem in one of my Network setup.

In that location cisco1841 router with two ISP with BGP.

One ISP is BSNL BGP and another one is TATA BGP. Both ISP have a seperate BGP AS number.

BSNL is connected in serial port and TATA is connected in Fast ethernet port.

We  are using BSNL as primary and TATA as Backup.When BSNL  line is down  means it  takes route to TATA.

Butafter the BSNL line came means and it is not take  automatically switchover from TATA to BSNL.

what is the solution.


can any one help me.

5 REPLIES
Purple

BGP Dual ISP fallover issue

Hi,

are you using Provider independent addressing and your own AS ?

Can you post your config?

Regards.

Alain

Don't forget to rate helpful posts.
New Member

BGP Dual ISP fallover issue

This is My configuration

In this configuration how to get a fallover

Please send the configuration.

interface FastEthernet0/0

description ***** LOCAL LAN *****

ip address 10.10.70.100 255.255.254.0

ip accounting output-packets

ip flow ingress

ip virtual-reassembly

duplex auto

speed auto

keepalive 1000

interface FastEthernet0/1

description *** TATA WAN LINK ***

bandwidth 512

ip address 10.60.178.5 255.255.255.252

speed 100

full-duplex

keepalive 1000

interface Serial0/3/0

description *** BSNL WAN LINK ***

bandwidth 2048

ip address 192.168.48.7 255.255.255.252

encapsulation ppp

no keepalive

no fair-queue

router bgp 75001------>our own AS Number

no synchronization

bgp log-neighbor-changes

network 10.10.70.0 mask 255.255.254.0

neighbor 10.60.178.4 remote-as 4855---------->TATA AS Number

neighbor 10.60.178.4 soft-reconfiguration inbound

neighbor 10.60.178.4 route-map EBGP-TATAWAN out

neighbor 192.168.48.8 remote-as 9839------------>BSNL AS Number

neighbor 192.168.48.8 description ***EBGP Peer to BSNL***

neighbor 192.168.48.8 soft-reconfiguration inbound

neighbor 192.168.48.8 route-map EBGP-BSNLWAN out

no auto-summary

ip prefix-list BSNL-LANROUTES seq 10 permit 10.10.70.0/23

ip prefix-list TATA-LANROUTES seq 10 permit 10.10.70.0/23

route-map EBGP-BSNLWAN permit 10

match ip address prefix-list BSNL-LANROUTES

route-map EBGP-TATAWAN permit 10

match ip address prefix-list TATA-LANROUTES

New Member

BGP Dual ISP fallover issue

" I have one problem in one of my Network setup.

In that location cisco1841 router with two ISP with BGP."

Does this mean that you have your own pubic AS number (or an agreed private as with both ISPs), or are you using the neighbor xx.xx.xx.xx local-as option?

"

We  are using BSNL as primary and TATA as Backup.When BSNL  line is down  means it  takes route to TATA.

Butafter the BSNL line came means and it is not take  automatically switchover from TATA to BSNL.

what is the solution."

From the sounds of the issue it looks like you are not manipulating BGP at all, the easy way for you to do this would be to use Cisco Weight attribute on your primary link

Neighbor xx.xx.xx.xx weight

For growth I would recommend terminating each BGP connection on seperate routers establishing a iBGP session between them, and set the local preference on the BSNL router to anything higher that 100, this way you will get a AS wide AS exit preference

I would have a good read of this,

http://www.cisco.com/image/gif/paws/26634/bgp-toc.pdf

Cheers Neil

Regards Neil http://uk.linkedin.com/pub/neil-grant/20/5b0/267
New Member

BGP Dual ISP fallover issue

what weight value i give to primary link.

New Member

Re: BGP Dual ISP fallover issue

The default weight is 0, I usually increment by 100's

neighbor 192.168.48.8 weight 100.

Then

# clear ip bgp 192.168.48.8 soft in, this will refresh you BGP table.

Neil

Regards Neil http://uk.linkedin.com/pub/neil-grant/20/5b0/267
392
Views
0
Helpful
5
Replies
CreatePlease login to create content