Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

bgp in ASR and 3560

We are planning to replace 3560 running bgp with an ASR 1001. They are connected to a same switch which is then connected to our ISP.
 

My goal is to have them work independently.

I tried below configuration but 3560 stuck-in-active while the ASR routing table is populated with prefixes.

 

ASR

!
router bgp 54321
 bgp router-id 1.2.3.5
 bgp log-neighbor-changes
 network 1.2.3.0 mask 255.255.248.0
 neighbor 11.11.11.11 remote-as 55555
 neighbor 11.11.11.11 transport path-mtu-discovery
 neighbor 11.11.11.11 password 7 1231415151B1E5429203557
 neighbor 11.11.11.11 update-source g0/0/0.3333
 neighbor 11.11.11.11 soft-reconfiguration inbound
 neighbor 22.22.22.22 remote-as 44444
 neighbor 22.22.22.22 transport path-mtu-discovery
 neighbor 22.22.22.22 update-source g0/0/0.7777
 neighbor 22.22.22.22 soft-reconfiguration inbound
  no auto-summary

!

 

3560

!

!
router bgp 54321
 bgp router-id 1.2.3.4
 bgp log-neighbor-changes
 network 1.2.3.0 mask 255.255.248.0
 neighbor 11.11.11.10 remote-as 55555
 neighbor 11.11.11.10 transport path-mtu-discovery
 neighbor 11.11.11.10 password 7 1231415151B1E5429203557
 neighbor 11.11.11.10 update-source Vlan3333
 neighbor 11.11.11.10 soft-reconfiguration inbound
 neighbor 22.22.22.22 remote-as 44444
 neighbor 22.22.22.22 transport path-mtu-discovery
 neighbor 22.22.22.22 update-source Vlan7777
 neighbor 22.22.22.22 soft-reconfiguration inbound
  no auto-summary
!

 

Attached is the complete configuration.

 

Thanks,

Caren

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Hi Caren ,   Expanding subnet

Hi Caren ,

   Expanding subnet mask should be done simultaneously at both side (ISP & Yourside)  . Else you will loose existing connectivity.

When you expand subnet mask NID , BID everything get changes . 

Normally ISP set /30 for all WAN connectivity .

HTH

Sandy 

7 REPLIES

Hi , 

Hi , 

         I do see your both switch & router is holding same IP address , this cause IP duplication in LAN segment . 

You need expand your subnet mask on interface configuration . configure different IP address for switch & ASR1001

You should see %IP-4-DUPADDR: message on your log message .  

 

switch :

interface Vlan 3333
 description ISP Link 1
 ip address 11.11.11.9 255.255.255.252
!
interface Vlan7777
 description  ISP Link 2
 ip address 22.22.22.21 255.255.255.252

Router :

interface GigabitEthernet0/0/0.3333
 description ISP LINK1
 encapsulation dot1Q 3333
 ip address 11.11.11.9 255.255.255.252
!
interface GigabitEthernet0/0/0.7777
 description  ISP LINK2
 encapsulation dot1Q 7777
 ip address 22.22.22.21 255.255.255.252

HTH

Sandy

Community Member

Hi Sandy,You're right, I saw

Hi Sandy,

You're right, I saw an IP address duplication message yesterday during deployment. 

Just a noob question, if the ISP configure their subnet mask in /30 and share the IP with switch. If setup the router /29 most probably, router will be denied by ISP. Am I right? I guess and I hope, the ISP do not set it to /30.

I will give it a try this afternoon.

Thanks,

Caren

 

 

Hi Caren ,   Expanding subnet

Hi Caren ,

   Expanding subnet mask should be done simultaneously at both side (ISP & Yourside)  . Else you will loose existing connectivity.

When you expand subnet mask NID , BID everything get changes . 

Normally ISP set /30 for all WAN connectivity .

HTH

Sandy 

Community Member

Hello Sandy,     Thanks for

Hello Sandy,

     Thanks for the explanation.

      I feel I am stuck here. Working with my ISP is a huge task and need more time to get their attention (my manager is rushing me to finish this off). Do I have any other option here like iBGP or any other workaround?

    

Thanks,

Caren

 

As i said earlier run one BGP

As i said earlier run one BGP session from ASR1001 & one BGP session from your 3560 . Internally between your 3560 & ASR1001 run IGP (OSPF /EIGRP) .

 

 

HTH

Sandy

Community Member

Hi Sandy,     Thanks for the

Hi Sandy,

     Thanks for the response. I'll fire up my gns3 and make some test.

 

Regards,

Caren

     

 

Community Member

Hi Sandy.Thank you for those

Hi Sandy.

Thank you for those ideas. My ASR is now working. I replaced the switch with ASR directly, got only 20 minutes downtime.

 

Regards,

Caren

79
Views
0
Helpful
7
Replies
CreatePlease to create content