Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

BGP IOS-NXOS: NSF no stale paths state is NSF not active

Hello,

I am trying to configure an IPv6 LISP ALT between and IOS router and an NXOS router but the BGP session to propagate EID prefixes  didn't stablish.

IOS Configuration:

vrf definition LISP

rd 1:1

!

address-family ipv6

exit-address-family

interface Tunnel0

vrf forwarding LISP

ipv6 address fd00:1000::1/32

tunnel source GigabitEthernet4/0.31

tunnel destination 192.168.0.1

exit

router lisp

site mob1

  authentication-key password

  eid-prefix FD00:1::/32 accept-more-specifics

  exit

  ipv6 map-server

  ipv6 map-resolver

  ipv6 alt-vrf LISP

!

exit

router bgp 65001

bgp log-neighbor-changes

no bgp default ipv4-unicast

!

address-family ipv6 vrf LISP

  redistribute lisp

  neighbor FD00:1000::2 remote-as 65002

  neighbor FD00:1000::2 activate

exit-address-family

NXOS Configuration:

vrf context LISP

  address-family ipv6 unicast

route-map LISP-Ok permit 10

  match tag 123

  set ipv6 next-hop fd00:1000::1

interface tunnel 0

  vrf member LISP

  ipv6 address fd00:1000::2/32

  tunnel source Ethernet2/3

  tunnel destination 192.168.0.2

  no shutdown

  exit

router bgp 65002

  address-family ipv6 unicast

  vrf LISP

    address-family ipv6 unicast

      redistribute lisp route-map LISP-Ok

    neighbor fd00:1000::1 remote-as 65001

      address-family ipv6 unicast

router bgp 65002

  address-family ipv6 unicast

  vrf LISP

    address-family ipv6 unicast

      redistribute lisp route-map LISP-Ok

    neighbor fd00:1000::1 remote-as 65001

      address-family ipv6 unicast

ipv6 lisp map-resolver

ipv6 lisp map-server

ipv6 lisp alt-vrf LISP

lisp site mob2

  eid-prefix fd00:2::/32 route-tag 123

  authentication-key 3 a0d2168319baa760

LOGS from IOS:

*Nov 25 00:55:50: BGP: FD00:1000::2 open active, local address FD00:1000::1

*Nov 25 00:55:50: BGP: ses LISP FD00:1000::2 (0x6A1BB9E8:0) act Adding topology VPNv6 Unicast:base

*Nov 25 00:55:50: BGP: ses LISP FD00:1000::2 (0x6A1BB9E8:0) act Send OPEN

*Nov 25 00:55:50: BGP: FD00:1000::2 active went from Active to OpenSent

*Nov 25 00:55:50: BGP: FD00:1000::2 active sending OPEN, version 4, my as: 65001, holdtime 180 seconds, ID AC1E0601

*Nov 25 00:55:50: BGP: ses LISP FD00:1000::2 (0x6A1BB9E8:0) act Remote close.

*Nov 25 00:55:50: BGP: nbr_topo LISP FD00:1000::2 VPNv6 Unicast:base (0x6A1BB9E8:0) Not scheduling for GR processing [Peer did not advertise GR cap]

*Nov 25 00:55:50: BGP: ses LISP FD00:1000::2 (0x6A1BB9E8:0) act Reset (Peer closed the session).

*Nov 25 00:55:50: BGP: nbr_topo LISP FD00:1000::2 VPNv6 Unicast:base (0x6A1BB9E8:0) NSF delete stale NSF not active

*Nov 25 00:55:50: BGP: nbr_topo LISP FD00:1000::2 VPNv6 Unicast:base (0x6A1BB9E8:0) NSF no stale paths state is NSF not active

*Nov 25 00:55:50: BGP: nbr_topo LISP FD00:1000::2 VPNv6 Unicast:base (0x6A1BB9E8:0) Resetting ALL counters.

*Nov 25 00:55:50: BGP: FD00:1000::2 active closing

*Nov 25 00:55:50: BGP: ses LISP FD00:1000::2 (0x6A1BB9E8:0) act Session close and reset neighbor FD00:1000::2 topostate

*Nov 25 00:55:50: BGP: nbr_topo LISP FD00:1000::2 VPNv6 Unicast:base (0x6A1BB9E8:0) Resetting ALL counters.

*Nov 25 00:55:50: BGP: FD00:1000::2 active went from OpenSent to Idle

Anyone could help me to solve this problem?

Thanks

Everyone's tags (3)
975
Views
0
Helpful
0
Replies
CreatePlease to create content