Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

BGP is not overriding OSPF?

All,

I'm playing with redistribution from OSPF into BGP for failover routes. The problem is that BGP doesn't show in the routing table until I clear the ospf process. These are set at the default distances:

RTRB#sh ip protocols

Routing Protocol is "bgp 3000"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

IGP synchronization is disabled

Automatic route summarization is disabled

Redistributing: ospf 1 (internal)

Neighbor(s):

Address FiltIn FiltOut DistIn DistOut Weight RouteMap

192.168.2.2

Maximum path: 1

Routing Information Sources:

Gateway Distance Last Update

10.12.12.1 20 00:44:30

192.168.2.2 20 00:13:03

Distance: external 20 internal 200 local 200

Routing Protocol is "ospf 1"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Router ID 3.3.3.1

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Maximum path: 4

Routing for Networks:

10.12.12.0 0.0.0.3 area 0

192.168.2.0 0.0.0.3 area 0

Routing Information Sources:

Gateway Distance Last Update

1.1.1.1 110 00:32:13

192.168.1.1 110 00:05:02

172.12.5.2 110 00:05:02

Distance: (default is 110)

1.0.0.0/24 is subnetted, 1 subnets

O 1.1.1.0 [110/3] via 10.12.12.1, 00:08:10, FastEthernet0/1

3.0.0.0/24 is subnetted, 1 subnets

C 3.3.3.0 is directly connected, Loopback1

172.12.0.0/30 is subnetted, 1 subnets

O 172.12.5.0 [110/2] via 10.12.12.1, 00:08:10, FastEthernet0/1

10.0.0.0/30 is subnetted, 1 subnets

C 10.12.12.0 is directly connected, FastEthernet0/1

192.168.1.0/30 is subnetted, 1 subnets

O 192.168.1.0 [110/3] via 10.12.12.1, 00:08:10, FastEthernet0/1

192.168.2.0/30 is subnetted, 1 subnets

C 192.168.2.0 is directly connected, FastEthernet0/0

RTRB#sh ip bgp

BGP table version is 59, local router ID is 3.3.3.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

* 1.1.1.0/24 192.168.2.2 0 100 1000 i

*> 10.12.12.1 3 32768 ?

*> 3.3.3.0/24 0.0.0.0 0 32768 i

*> 10.12.12.0/30 0.0.0.0 0 32768 ?

* 172.12.5.0/30 192.168.2.2 0 100 1000 i

*> 10.12.12.1 2 32768 ?

* 192.168.1.0/30 192.168.2.2 0 100 1000 i

*> 10.12.12.1 3 32768 ?

*> 192.168.2.0/30 0.0.0.0 0 32768 i

router ospf 1

log-adjacency-changes

network 10.12.12.0 0.0.0.3 area 0

network 192.168.2.0 0.0.0.3 area 0

!

router bgp 3000

no synchronization

bgp log-neighbor-changes

network 3.3.3.0 mask 255.255.255.0

network 192.168.2.0 mask 255.255.255.252

redistribute ospf 1 match internal

neighbor 192.168.2.2 remote-as 100

no auto-summary

Thanks,

John

HTH, John *** Please rate all useful posts ***
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: BGP is not overriding OSPF?

John

You are having fun with BGP at the moment :-)

Rather than change the OSPF weight you actually just make the BGP weight perferable ie.

router bgp 3000

neighbor 192.168.2.2 weight 40000

Jon

3 REPLIES

Re: BGP is not overriding OSPF?

I know why it's not. "sh ip bgp" shows that the weight for the redistributed route is 32768, but the externally learned route from BGP is 0. How can I change the weight of the redistributed OSPF since it thinks it's locally generated?

Thanks,

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Blue

Re: BGP is not overriding OSPF?

John

You are having fun with BGP at the moment :-)

Rather than change the OSPF weight you actually just make the BGP weight perferable ie.

router bgp 3000

neighbor 192.168.2.2 weight 40000

Jon

Hall of Fame Super Bronze

Re: BGP is not overriding OSPF?

..or route-map with set weight - then redistribute OSPF into BGP with such route-map..

Having the weight at the neighbor level will affect all routes, not just OSPF routes.

__

Edison.

294
Views
5
Helpful
3
Replies
CreatePlease to create content