Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

BGP issues

I have two issues. i am running two router using bgp on hotstandby. One router is the primary on one is the backup. the issue are,

1) BGP is not passing the default route

2)  Getting BGP identifier wrong

I would I appreciate any help.

Here is the configuration of the router,

Main router

interface GigabitEthernet0/0
description Internal Network
ip address x.x.41.2 255.255.255.0
duplex auto
speed auto
media-type rj45
standby 1 ip x.x.41.1
standby 1 preempt delay minimum 60
standby 1 track Serial1/0
no mop enabled

router bgp 65000
no synchronization
bgp log-neighbor-changes
network x.x.41.0
redistribute connected
redistribute static
neighbor x.x.41.3 remote-as 65000
neighbor x.x.41.3 next-hop-self
neighbor x.x.188.77 remote-as 209
neighbor x.x.188.77 send-community
neighbor x.x.188.77 default-originate
neighbor x.x.188.77 route-map setpath out
neighbor x.x.22.229 remote-as 209
neighbor x.x.22.229 send-community
neighbor x.x.22.229 default-originate
neighbor x.x.22.229 route-map Swales out
no auto-summary

ip route 0.0.0.0 0.0.0.0  x.x.41.5

ip route x.x.222.0 255.255.255.0 x.x.41.5

Backup router

interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address x.x.41.3 255.255.255.0
duplex full
speed auto
media-type rj45
standby 1 ip x.x.41.1
standby 1 preempt delay minimum 60
standby 1 track Serial1/0
no mop enabled

router bgp 65000

no synchronization

bgp log-neighbor-changes

network x.x.41.0

redistribute connected

redistribute static

neighbor x.x.41.2 remote-as 65000

neighbor x.x.41.2 next-hop-self

neighbor x.x.188.77 default-originate

neighbor x.x.188.77 remote-as 209

neighbor x.x.188.77 send-community

neighbor x.x.188.77 route-map setpath out

neighbor  x.x.22.229 remote-as 209

neighbor  x.x.22.229 default-originate

neighbor  x.x.22.229 send-community

neighbor  x.x.22.229 route-map Swales out

no auto-summary

ip route 0.0.0.0 0.0.0.0  x.x.41.5

ip route x.x.222.0 255.255.255.0 x.x.41.5

Thanks,

Jose' Luis Granda

3 REPLIES
Hall of Fame Super Silver

Re: BGP issues

Hello Josè,

bgp router-id can be configured with

router bgp 65000

bgp router-id x.x.x.x

post the route-map configurations they may influence the capability to advertise a prefix including a default route

>>>>neighbor x.x.188.77 route-map setpath out

Hope to help

Giuseppe

Community Member

Re: BGP issues

Hello Giuseppe, Thanks for the quik response. Here is the router map

Main site for box units

route-map Swales permit 10
set community 13697114 13698023
!
route-map setpath permit 10
set community 13697094 13697114 13698023

Let me know if you need anything else.


Thanks,

Jose' luis Granda

Hall of Fame Super Silver

Re: BGP issues

Hello Jose',

first of all, IOS provides a command to make BGP communities readable

conf t

ip bgp-community new-format

http://www.cisco.com/en/US/docs/ios/iproute_bgp/command/reference/irg_bgp2.html#wp1073721

if you post

sh ip bgp 0.0.0.0

what can we see?

and

sh ip bgp advertised-routes

Hope to help

Giuseppe

295
Views
0
Helpful
3
Replies
CreatePlease to create content