Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

BGP/Multihome using Private ASN

Hi guys,

Do you have a sample config on these ?

Thanks.

jeff

4 REPLIES

Re: BGP/Multihome using Private ASN

Dear,

Kindly use the below configurations example with some changes based on your routers interfaces and IP address.

IP CEF

ip classless

Interface Loopback 0

IP address 172.16.0.1 255.255.255.255

interface ATM1/0.1 point-to-point

desc ISP 1

ip address 172.16.1.1 255.255.255.252

pvc 1/1

enca aal5snap

!

Interface ATM2/0.1 point-to-point

desc ISP2

ip address 172.16.2.1 255.255.255.252

pvc 2/2

enca aal5snap

ip as-path access-list 1 permit ^$

router bgp 6500

no synchronization

bgp log-neighbor-changes

neighbor 172.16.100.1 remote-as 100

neighbor 172.16.100.1 ebgp-multihop 2

neighbor 172.16.100.1 update-source Loopback0

neighbor 172.16.200.1 remote-as 200

neighbor 172.16.200.1 ebgp-multihop 2

neighbor 172.16.100.1 filter-list 1 out

neighbor 172.16.200.1 filter-list 1 out

neighbor 172.16.200.1 update-source Loopback0

no auto-summary

ip route 172.16.100.1 255.255.255.255 atm1/0.1

ip route 172.16.200.1 255.255.255.255 atm2/0.1

Please Rate Helpful posts

Best Regards,

Mounir Mohamed

Re: BGP/Multihome using Private ASN

Hello Jeff,

what type of multi homing are you using. The config provided by Mounir assumes one BGP router connected to one other BGP router through two lines.

Or do you have

1) one BGP router connected to several BGP routers from one ISP

2) several BGP routers connected to several BGP routers from one ISP

3) one BGP router connected to several BGP routers from different ISPs

4) several BGP router connected to several BGP routers from different ISPs

As you might understand there are quite different configs resulting from the different requirements. Can you highlight, which case is close to your design?

Regards, Martin

New Member

Re: BGP/Multihome using Private ASN

Hi mheusinger,

i have two options.

1. one bgp router connected to two different isp

2. one bgp router connected to one isp

thanks.

jeff

Re: BGP/Multihome using Private ASN

Dear Jeef,

-the above configuration achive option 2 (One router with 2 ISP's)

-option can be done by using the following config on each router with some ip changes and ASN but also you have to clarify some points A)Are you gone use primary and backup design if Yes so you gone to use a higher local prefernace for the routes that received from the primary provider and run IBGP between both routers

B)Are you gone use Load balance design

c) How about the downstream traffic?

Interface Loopback 0

IP address 172.16.0.1 255.255.255.255

interface ATM1/0.1 point-to-point

desc ISP 1

ip address 172.16.1.1 255.255.255.252

pvc 1/1

enca aal5snap

!

ip as-path access-list 1 permit ^$

router bgp 6500

no synchronization

bgp log-neighbor-changes

neighbor 172.16.100.1 remote-as 100

neighbor 172.16.100.1 ebgp-multihop 2

neighbor 172.16.100.1 update-source Loopback0

neighbor 172.16.200.1 ebgp-multihop 2

neighbor 172.16.100.1 filter-list 1 out

no auto-summary

ip route 172.16.100.1 255.255.255.255 atm1/0.1

If all that doesn't solve your problem please provide us with full details about your case in order to let the guys to provide you with best solution.

PLease Rate Helpful posts.

Best Regards,

Mounir Mohamed

226
Views
0
Helpful
4
Replies
CreatePlease to create content