Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

BGP New network range not working

Hi,

I have 4 routers running BGP through megapop circuit.2 Routers from Remote A, which acts as redundancy connecting to Remote B, which got another 2 routers as redundancy also.

A new network range 192.168.1.0/24 added at Remote A's Routers.

But seems like the Routers at Remote A's BGP not able to advertise to Remote B's Routers.

What have i done wrong? I have did a clear ip bgp * on the remote site A , to advertise the new network but to still no avail.

Need help urgently. Thanks..

ken

5 REPLIES

Re: BGP New network range not working

Hi Ken,

Do u see the route installed in the BGP route table. please check by issuing sh ip bgp

BGP does not advertise a network if it does not find a corresponding valid route in the IGP routing table.

so make sure you have a route in the IGP route table for the subnet you are advertising.

Also posting your configs would help

HTH, rate if it does

Narayan

New Member

Re: BGP New network range not working

Hi Narayan,

Thanks for your input. Have done Sh ip bgp,

and the routes are pointing to the right destination.

eg:

the 192.168.1.0/24 will need to push to 172.16.1.196 which is able to trace from Routers at remote A.

Is just that can;t able to trace to 192.168.1.0/24 from the remote B Routers, it can't go to another hop. It goes * * *.

whats next follow-up action that i need to check?

thanks,

ken

New Member

Re: BGP New network range not working

Sorry, just to confirm.

Did a "clear ip bgp" on the routers at Remote A which going to advertise new network range 192.168.1.0/24. Is that correct??

Or i should do clear ip bgp at Remote B routers instead??

thanks again.

Re: BGP New network range not working

can you post the outputs of sh ip bgp, sh ip route for all the routers

Narayan

New Member

Re: BGP New network range not working

Thanks Narayan.

The problem actually was solved. It was due to the access-list of the route-map that applies on the bgp. Once the network range is permitted under the access list, it works like a charm..:D thanks for all your input..

ken

219
Views
0
Helpful
5
Replies