Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP not advertising a particular subnet

Hi,

Please refer to the following configuration. I want to know why the subnet 12.23.0.0/18 is not advertised out.

router bgp aaaaa

no synchronization

no bgp log-neighbor-changes

network 12.23.0.0 mask 255.255.192.0

network 12.35.0.0 mask 255.255.192.0

network 12.35.64.0 mask 255.255.224.0

network 12.35.86.0 mask 255.255.255.0

network 20.10.218.180 mask 255.255.255.255

neighbor 22.23.62.23 remote-as 4773

neighbor 22.23.62.23 route-map AS-PREPEND out

no auto-summary

!

route-map AS-PREPEND permit 10

match ip address prefix-list prependlist

set as-path prepend aaaaa

!

route-map AS-PREPEND permit 20

!

ip prefix-list prependlist seq 5 permit 12.23.0.0/18

!

#########################

Router> sh ip bgp ne 22.23.62.23 ad

BGP table version is 8389, local router ID is 20.10.218.180

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 12.35.0.0/18 12.35.35.2 30720 32768 i

*> 12.35.64.0/19 12.35.35.2 30720 32768 i

*> 12.35.86.0/24 12.35.35.2 30720 32768 i

*> 20.10.218.180/32

0.0.0.0 0 32768 i

###

Router>sh ip bgp 12.23.0.0

BGP routing table entry for 12.23.0.0/18, version 7068

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Not advertised to any peer

4773 65204, (aggregated by 65204 22.23.6.46)

22.32.62.23 from 22.32.62.23 (22.23.62.23)

Origin IGP, localpref 100, valid, external, atomic-aggregate, best

Extended Community: RT:4773:4801

3 REPLIES

Re: BGP not advertising a particular subnet

Try routing 12.23.0.0/18 to a null interface. Be sure you have more specific routes in your IGP.

interface null0

ip route 12.23.0.0 255.255.192.0 null0

Don't forget to soft reset the BGP advertisement.

clear ip bgp 22.23.62.23 soft out

Re: BGP not advertising a particular subnet

Hello!

I would advice first do a

sh ip route | i 12.23.0.0

if there you cannot find anything related to this subnet, then follow the steps from medan post.

@medan, very good explanation, you have your post rated by me.

Best regards,

Calin

Re: BGP not advertising a particular subnet

Thanks Calin, your advice is good also in case there is already a route locally.

419
Views
10
Helpful
3
Replies
CreatePlease login to create content